aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/ots
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-30 12:21:58 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-30 12:21:58 +0000
commit683ddd6c03331e1f5f5edc11c53571fe700812c4 (patch)
tree3a13ebe495c89f73fd49612db1037b87ab9d6247 /x11-fonts/ots
parente786e0fa0d30d1da84337ef8579248ed3d8e1e10 (diff)
downloadports-683ddd6c03331e1f5f5edc11c53571fe700812c4.tar.gz
ports-683ddd6c03331e1f5f5edc11c53571fe700812c4.zip
Update to 8.1.3
Notes
Notes: svn path=/head/; revision=563305
Diffstat (limited to 'x11-fonts/ots')
-rw-r--r--x11-fonts/ots/Makefile6
-rw-r--r--x11-fonts/ots/distinfo6
-rw-r--r--x11-fonts/ots/files/patch-meson.build182
3 files changed, 12 insertions, 182 deletions
diff --git a/x11-fonts/ots/Makefile b/x11-fonts/ots/Makefile
index c4eea0f137c7..2dcb608f8b18 100644
--- a/x11-fonts/ots/Makefile
+++ b/x11-fonts/ots/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ots
-PORTVERSION= 8.1.1
+PORTVERSION= 8.1.3
CATEGORIES= x11-fonts
MASTER_SITES= https://github.com/khaledhosny/ots/releases/download/v${PORTVERSION}/
@@ -12,6 +12,7 @@ COMMENT= OpenType Sanitizer
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= meson>=0.55.2:devel/meson
LIB_DEPENDS= libbrotlidec.so:archivers/brotli \
libfreetype.so:print/freetype2 \
libgtest.so:devel/googletest \
@@ -28,9 +29,6 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
SHEBANG_FILES= tests/*.sh
bash_CMD= ${SH}
-post-patch:
- @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/meson.build
-
do-test:
${SETENV} top_builddir=${BUILD_WRKSRC} top_srcdir=${WRKSRC} ${SH} ${WRKSRC}/tests/test_bad_fonts.sh
${SETENV} top_builddir=${BUILD_WRKSRC} top_srcdir=${WRKSRC} ${SH} ${WRKSRC}/tests/test_fuzzed_fonts.sh
diff --git a/x11-fonts/ots/distinfo b/x11-fonts/ots/distinfo
index a71506607779..36d7230de574 100644
--- a/x11-fonts/ots/distinfo
+++ b/x11-fonts/ots/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1608366116
-SHA256 (ots-8.1.1.tar.xz) = 8b912fae494228c5e308225ff15d1aaaf026587661c3c2d20676adb28795ff48
-SIZE (ots-8.1.1.tar.xz) = 58775484
+TIMESTAMP = 1611856516
+SHA256 (ots-8.1.3.tar.xz) = d26ba3956568163ea9c34c8c6f46ba15e4659cdd558b998b5f353070159f0a39
+SIZE (ots-8.1.3.tar.xz) = 18345584
diff --git a/x11-fonts/ots/files/patch-meson.build b/x11-fonts/ots/files/patch-meson.build
index 98642988cd94..edc5ce2037c4 100644
--- a/x11-fonts/ots/files/patch-meson.build
+++ b/x11-fonts/ots/files/patch-meson.build
@@ -1,165 +1,23 @@
---- meson.build.orig 2020-12-02 12:55:02 UTC
+--- meson.build.orig 2021-01-12 17:06:54 UTC
+++ meson.build
@@ -1,6 +1,6 @@
project('ots', 'c', 'cpp',
- version: '8.1.1',
+ version: '8.1.3',
- default_options : ['cpp_std=c++11', 'default_library=static'],
+ default_options : ['cpp_std=c++11', 'default_library=both'],
+ meson_version : '>= 0.55.2',
)
- cxx = meson.get_compiler('cpp')
-@@ -44,28 +44,28 @@ if 'undefined' in get_option('b_sanitize').split(',')
- brotli_c_args += '-DBROTLI_BUILD_PORTABLE'
- endif
-
--brotli_includes = ['third_party/brotli/c/include']
--libbrotli = library('brotli',
-- 'third_party/brotli/c/common/constants.h',
-- 'third_party/brotli/c/common/dictionary.c',
-- 'third_party/brotli/c/common/dictionary.h',
-- 'third_party/brotli/c/common/transform.c',
-- 'third_party/brotli/c/common/transform.h',
-- 'third_party/brotli/c/common/version.h',
-- 'third_party/brotli/c/dec/bit_reader.c',
-- 'third_party/brotli/c/dec/bit_reader.h',
-- 'third_party/brotli/c/dec/decode.c',
-- 'third_party/brotli/c/dec/huffman.c',
-- 'third_party/brotli/c/dec/huffman.h',
-- 'third_party/brotli/c/dec/prefix.h',
-- 'third_party/brotli/c/dec/state.c',
-- 'third_party/brotli/c/dec/state.h',
-- 'third_party/brotli/c/include/brotli/decode.h',
-- 'third_party/brotli/c/include/brotli/port.h',
-- 'third_party/brotli/c/include/brotli/types.h',
-- include_directories: include_directories(brotli_includes),
-- c_args: brotli_c_args,
--)
-+#brotli_includes = ['third_party/brotli/c/include']
-+#libbrotli = library('brotli',
-+# 'third_party/brotli/c/common/constants.h',
-+# 'third_party/brotli/c/common/dictionary.c',
-+# 'third_party/brotli/c/common/dictionary.h',
-+# 'third_party/brotli/c/common/transform.c',
-+# 'third_party/brotli/c/common/transform.h',
-+# 'third_party/brotli/c/common/version.h',
-+# 'third_party/brotli/c/dec/bit_reader.c',
-+# 'third_party/brotli/c/dec/bit_reader.h',
-+# 'third_party/brotli/c/dec/decode.c',
-+# 'third_party/brotli/c/dec/huffman.c',
-+# 'third_party/brotli/c/dec/huffman.h',
-+# 'third_party/brotli/c/dec/prefix.h',
-+# 'third_party/brotli/c/dec/state.c',
-+# 'third_party/brotli/c/dec/state.h',
-+# 'third_party/brotli/c/include/brotli/decode.h',
-+# 'third_party/brotli/c/include/brotli/port.h',
-+# 'third_party/brotli/c/include/brotli/types.h',
-+# include_directories: include_directories(brotli_includes),
-+# c_args: brotli_c_args,
-+#)
-
-
- woff2_cpp_args = []
-@@ -75,30 +75,30 @@ if 'undefined' in get_option('b_sanitize').split(',')
- woff2_cpp_args += '-U__BYTE_ORDER__'
- endif
-
--woff2_includes = ['third_party/brotli/c/include', 'third_party/woff2/include']
--libwoff2 = library('woff2',
-- 'third_party/woff2/include/woff2/decode.h',
-- 'third_party/woff2/include/woff2/output.h',
-- 'third_party/woff2/src/buffer.h',
-- 'third_party/woff2/src/port.h',
-- 'third_party/woff2/src/round.h',
-- 'third_party/woff2/src/store_bytes.h',
-- 'third_party/woff2/src/table_tags.cc',
-- 'third_party/woff2/src/table_tags.h',
-- 'third_party/woff2/src/variable_length.cc',
-- 'third_party/woff2/src/variable_length.h',
-- 'third_party/woff2/src/woff2_common.cc',
-- 'third_party/woff2/src/woff2_common.h',
-- 'third_party/woff2/src/woff2_dec.cc',
-- 'third_party/woff2/src/woff2_out.cc',
-- include_directories: include_directories(woff2_includes),
-- cpp_args: woff2_cpp_args,
--)
-+#woff2_includes = ['third_party/brotli/c/include', 'third_party/woff2/include']
-+#libwoff2 = library('woff2',
-+# 'third_party/woff2/include/woff2/decode.h',
-+# 'third_party/woff2/include/woff2/output.h',
-+# 'third_party/woff2/src/buffer.h',
-+# 'third_party/woff2/src/port.h',
-+# 'third_party/woff2/src/round.h',
-+# 'third_party/woff2/src/store_bytes.h',
-+# 'third_party/woff2/src/table_tags.cc',
-+# 'third_party/woff2/src/table_tags.h',
-+# 'third_party/woff2/src/variable_length.cc',
-+# 'third_party/woff2/src/variable_length.h',
-+# 'third_party/woff2/src/woff2_common.cc',
-+# 'third_party/woff2/src/woff2_common.h',
-+# 'third_party/woff2/src/woff2_dec.cc',
-+# 'third_party/woff2/src/woff2_out.cc',
-+# include_directories: include_directories(woff2_includes),
-+# cpp_args: woff2_cpp_args,
-+#)
-
-
- ots_includes = [
- 'include',
-- 'third_party/woff2/include',
-+ '%%LOCALBASE%%/include/woff2',
- ]
-
- ots_sources = [
-@@ -180,10 +180,10 @@ ots_sources = [
- 'src/vvar.h',
- ]
-
--ots_libs = [libbrotli, libwoff2]
-+#ots_libs = [libbrotli, libwoff2]
-
- if get_option('graphite')
-- ots_includes += ['third_party/lz4/lib']
-+ ots_includes += ['%%LOCALBASE%%/include']
- ots_sources += [
- 'src/feat.cc',
- 'src/feat.h',
-@@ -199,21 +199,28 @@ if get_option('graphite')
- 'src/sill.h',
- 'src/sill.cc',
- ]
-- liblz4 = library('lz4',
-- 'third_party/lz4/lib/lz4.c',
-- 'third_party/lz4/lib/lz4.h',
-- )
-- ots_libs += [liblz4]
-+# liblz4 = library('lz4',
-+# 'third_party/lz4/lib/lz4.c',
-+# 'third_party/lz4/lib/lz4.h',
-+# )
-+# ots_libs += [liblz4]
- endif
-
-+libbrotlicommon = dependency('libbrotlicommon')
-+libbrotlidec = dependency('libbrotlidec')
-+libwoff2common = dependency('libwoff2common')
-+libwoff2dec = dependency('libwoff2dec')
-+liblz4 = dependency('liblz4')
- zlib = dependency('zlib', fallback : ['zlib', 'zlib_dep'])
-
- libots = library('ots',
- ots_sources,
- include_directories: include_directories(ots_includes),
-- link_with: ots_libs,
-+# link_with: ots_libs,
+@@ -150,6 +150,8 @@ libots = library('ots',
+ include_directories: include_directories('include'),
cpp_args : '-DHAVE_CONFIG_H',
-- dependencies: zlib,
-+ dependencies: [libbrotlicommon, libbrotlidec, libwoff2common, libwoff2dec, liblz4, zlib],
+ dependencies: ots_deps,
+ version : meson.project_version(),
+ install: true,
)
-@@ -239,6 +246,7 @@ executable('ots-fuzzer',
+@@ -175,6 +177,7 @@ executable('ots-fuzzer',
cpp_args: fuzzer_defines,
link_with: libots,
link_args: fuzzer_ldflags,
@@ -167,29 +25,3 @@
)
-@@ -305,13 +313,14 @@ endif
-
- install_man('docs/ots-sanitize.1')
-
--gtest = subproject('gtest').get_variable('gtest_main_dep')
-+gtest = dependency('gtest', fallback: ['gtest', 'gtest_main_dep'])
-+gtest_main = dependency('gtest_main')
-
- cff_charstring = executable('cff_charstring',
- 'tests/cff_charstring_test.cc',
- include_directories: include_directories(['include', 'src']),
- link_with: libots,
-- dependencies: gtest,
-+ dependencies: [gtest, gtest_main],
- )
-
- test('cff_charstring', cff_charstring)
-@@ -321,7 +330,7 @@ layout_common_table = executable('layout_common_table'
- 'tests/layout_common_table_test.cc',
- include_directories: include_directories(['include', 'src']),
- link_with: libots,
-- dependencies: gtest,
-+ dependencies: [gtest, gtest_main],
- )
-
- test('layout_common_table', layout_common_table)