aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/proggy_fonts-ttf
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2010-10-25 18:03:59 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2010-10-25 18:03:59 +0000
commita19e847c3b0f66da5d8e3aeb39b0822776a9bcde (patch)
treeed22d0103c85590c6c69e510608fa6d6e4e0b7ec /x11-fonts/proggy_fonts-ttf
parentcefeb9d7538b4c5cf13efd3e90f43c9ed272615b (diff)
downloadports-a19e847c3b0f66da5d8e3aeb39b0822776a9bcde.tar.gz
ports-a19e847c3b0f66da5d8e3aeb39b0822776a9bcde.zip
The proggy programmer's fonts (Proggy Clean, Proggy Square, Proggy Small,
and Proggy Tiny) are a set of fixed-width screen fonts that are designed for code listings. Each font only comes in one size that it looks good at. The fonts were optimized while coding in C or C++. For this reason, characters like the '*' were placed vertically centered, as '*' usually means dereference or multiply, but never 'to the power of' like in Fortran. The {}s are centered horizontally (as the author's coding style aligns braces vertically), the zero looks different from the capital oh, and there is never any confusion between ells, ones, and eyes. Additionally, the arithmetic operators (+ - * < >) are all axis aligned. Author: Tristan Grimmer WWW: http://www.proggyfonts.com/ PR: ports/151652 Submitted by: Raphael Kubo da Costa <kubito at gmail.com>
Notes
Notes: svn path=/head/; revision=263582
Diffstat (limited to 'x11-fonts/proggy_fonts-ttf')
-rw-r--r--x11-fonts/proggy_fonts-ttf/Makefile38
-rw-r--r--x11-fonts/proggy_fonts-ttf/distinfo24
-rw-r--r--x11-fonts/proggy_fonts-ttf/pkg-descr13
-rw-r--r--x11-fonts/proggy_fonts-ttf/pkg-plist13
4 files changed, 88 insertions, 0 deletions
diff --git a/x11-fonts/proggy_fonts-ttf/Makefile b/x11-fonts/proggy_fonts-ttf/Makefile
new file mode 100644
index 000000000000..4c0d8890940f
--- /dev/null
+++ b/x11-fonts/proggy_fonts-ttf/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: proggy_fonts-x11
+# Date created: 22 October 2010
+# Whom: Raphael Kubo da Costa <kubito@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= proggy_fonts-ttf
+PORTVERSION= 1.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://www.proggyfonts.com/download/
+DISTFILES= ProggyClean.ttf.zip ProggySquare.ttf.zip \
+ ProggySmall.ttf.zip ProggyTiny.ttf.zip \
+ ProggyCleanSZ.ttf.zip ProggySquareSZ.ttf.zip \
+ ProggyTinySZ.ttf.zip ProggyCleanSZBP.ttf.zip
+DIST_SUBDIR= proggy_fonts-ttf
+
+MAINTAINER= kubito@gmail.com
+COMMENT= The perfect monospaced bitmap programming fonts, TTF version
+
+LICENSE= MIT
+
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+INSTALLDIR= ${PREFIX}/lib/X11/fonts/${PORTNAME}
+
+do-build:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/mkfontscale
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/mkfontdir
+
+do-install:
+ @${MKDIR} ${INSTALLDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} fonts.dir fonts.scale *.ttf ${INSTALLDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/proggy_fonts-ttf/distinfo b/x11-fonts/proggy_fonts-ttf/distinfo
new file mode 100644
index 000000000000..1723d46d1f54
--- /dev/null
+++ b/x11-fonts/proggy_fonts-ttf/distinfo
@@ -0,0 +1,24 @@
+MD5 (proggy_fonts-ttf/ProggyClean.ttf.zip) = 522c036b817b7deadb110499ac2849a6
+SHA256 (proggy_fonts-ttf/ProggyClean.ttf.zip) = 0009f3cd9622966c0bc81d61b14ada0a54f71b1ec7629e5b0f97cf2a44ff33c7
+SIZE (proggy_fonts-ttf/ProggyClean.ttf.zip) = 15325
+MD5 (proggy_fonts-ttf/ProggySquare.ttf.zip) = 901450e8216b40f607c9971d6e3d7bc6
+SHA256 (proggy_fonts-ttf/ProggySquare.ttf.zip) = 422160f2631ea1ec0ffb58b40a488b0ed4654f55509aedda60567639ab238200
+SIZE (proggy_fonts-ttf/ProggySquare.ttf.zip) = 6901
+MD5 (proggy_fonts-ttf/ProggySmall.ttf.zip) = 0dad38f7617a44ab4c74537ab74e1012
+SHA256 (proggy_fonts-ttf/ProggySmall.ttf.zip) = 9b0009d2aeb50cbbaff9e7a5b06f2632bf12265c1ce315edf76847bc3638cc23
+SIZE (proggy_fonts-ttf/ProggySmall.ttf.zip) = 6490
+MD5 (proggy_fonts-ttf/ProggyTiny.ttf.zip) = db01b9bd4b8c2b29d315b010c72288da
+SHA256 (proggy_fonts-ttf/ProggyTiny.ttf.zip) = 9c9877f0b91fa63091da4188778fe9e45a6ed679e6f6d45db23281bb26a9ea55
+SIZE (proggy_fonts-ttf/ProggyTiny.ttf.zip) = 6875
+MD5 (proggy_fonts-ttf/ProggyCleanSZ.ttf.zip) = 8672020fd2116c1aa02264ce61a00dbb
+SHA256 (proggy_fonts-ttf/ProggyCleanSZ.ttf.zip) = 063400d14c91adfa1e885fb1aeee1dac9a839ce4dd39b5f676bd7466b7af7e4b
+SIZE (proggy_fonts-ttf/ProggyCleanSZ.ttf.zip) = 7560
+MD5 (proggy_fonts-ttf/ProggySquareSZ.ttf.zip) = 573250a940e0371c8ab7578f021e5cb0
+SHA256 (proggy_fonts-ttf/ProggySquareSZ.ttf.zip) = 8d48ae4d413e851bb4bf7ae1b7ec5328dcabdfc2c48d79de4e48bd4b54be09f4
+SIZE (proggy_fonts-ttf/ProggySquareSZ.ttf.zip) = 6917
+MD5 (proggy_fonts-ttf/ProggyTinySZ.ttf.zip) = d07b6c7f0de1a35b91e289b4dd6352bd
+SHA256 (proggy_fonts-ttf/ProggyTinySZ.ttf.zip) = 71c1cafbf4912524d4e304652c22f7cf2825fe1b5f877f94a551d6e15b2eb4e8
+SIZE (proggy_fonts-ttf/ProggyTinySZ.ttf.zip) = 6894
+MD5 (proggy_fonts-ttf/ProggyCleanSZBP.ttf.zip) = 8548b859a0e2e7357c48c2aacfa2c2d5
+SHA256 (proggy_fonts-ttf/ProggyCleanSZBP.ttf.zip) = 3c6d71e0fcf1e7ab7d9fde576750159dc3c93fca8147367fe00417d9766652a3
+SIZE (proggy_fonts-ttf/ProggyCleanSZBP.ttf.zip) = 7610
diff --git a/x11-fonts/proggy_fonts-ttf/pkg-descr b/x11-fonts/proggy_fonts-ttf/pkg-descr
new file mode 100644
index 000000000000..7e74cafb09dd
--- /dev/null
+++ b/x11-fonts/proggy_fonts-ttf/pkg-descr
@@ -0,0 +1,13 @@
+The proggy programmer's fonts (Proggy Clean, Proggy Square, Proggy Small,
+and Proggy Tiny) are a set of fixed-width screen fonts that are designed
+for code listings. Each font only comes in one size that it looks good at.
+The fonts were optimized while coding in C or C++. For this reason,
+characters like the '*' were placed vertically centered, as '*' usually
+means dereference or multiply, but never 'to the power of' like in Fortran.
+The {}s are centered horizontally (as the author's coding style aligns
+braces vertically), the zero looks different from the capital oh, and there
+is never any confusion between ells, ones, and eyes. Additionally, the
+arithmetic operators (+ - * < >) are all axis aligned.
+
+Author: Tristan Grimmer
+WWW: http://www.proggyfonts.com/
diff --git a/x11-fonts/proggy_fonts-ttf/pkg-plist b/x11-fonts/proggy_fonts-ttf/pkg-plist
new file mode 100644
index 000000000000..5c051eef28ff
--- /dev/null
+++ b/x11-fonts/proggy_fonts-ttf/pkg-plist
@@ -0,0 +1,13 @@
+lib/X11/fonts/proggy_fonts-ttf/ProggyClean.ttf
+lib/X11/fonts/proggy_fonts-ttf/ProggyCleanCE.ttf
+lib/X11/fonts/proggy_fonts-ttf/ProggyCleanSZ.ttf
+lib/X11/fonts/proggy_fonts-ttf/ProggyCleanSZBP.ttf
+lib/X11/fonts/proggy_fonts-ttf/ProggySmall.ttf
+lib/X11/fonts/proggy_fonts-ttf/ProggySquare.ttf
+lib/X11/fonts/proggy_fonts-ttf/ProggySquareSZ.ttf
+lib/X11/fonts/proggy_fonts-ttf/ProggyTiny.ttf
+lib/X11/fonts/proggy_fonts-ttf/ProggyTinySZ.ttf
+lib/X11/fonts/proggy_fonts-ttf/fonts.dir
+lib/X11/fonts/proggy_fonts-ttf/fonts.scale
+@dirrm lib/X11/fonts/proggy_fonts-ttf
+@exec fc-cache -v %D/lib/X11/fonts/proggy_fonts-ttf 2>/dev/null || true