aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/stix-fonts
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2015-03-21 23:05:19 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2015-03-21 23:05:19 +0000
commita5da770e67afce95b829c38c5d5330fe69f7822c (patch)
treeb9556c9042a9d20d7c71f49869f39f95afc00052 /x11-fonts/stix-fonts
parent51da733b698e7bbedaac4743f457352334401249 (diff)
downloadports-a5da770e67afce95b829c38c5d5330fe69f7822c.tar.gz
ports-a5da770e67afce95b829c38c5d5330fe69f7822c.zip
Make fonts repecting XDG
Xorg is now looking in ${LOCALBASE}/share/fonts by default Xorg now accepts symlinks in etc/X11/fontpath.d (as decribed in Xserver(1)) Large cleanup on lots of font ports All fonts are now properly dynamically generating fonts.dir and fonts.scale instead of sometime overwriting existing ones) All fonts are generating fontconfig's cache Improve consistency in fonts ports
Notes
Notes: svn path=/head/; revision=381876
Diffstat (limited to 'x11-fonts/stix-fonts')
-rw-r--r--x11-fonts/stix-fonts/Makefile24
-rw-r--r--x11-fonts/stix-fonts/files/pkg-message.in2
-rw-r--r--x11-fonts/stix-fonts/pkg-plist173
3 files changed, 89 insertions, 110 deletions
diff --git a/x11-fonts/stix-fonts/Makefile b/x11-fonts/stix-fonts/Makefile
index 6c0176ed3532..63698aad15b9 100644
--- a/x11-fonts/stix-fonts/Makefile
+++ b/x11-fonts/stix-fonts/Makefile
@@ -3,6 +3,7 @@
PORTNAME= stixfonts
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= SF/${PORTNAME}/Current%20Release/
DISTNAME= STIXv${PORTVERSION}-webfonts
@@ -12,28 +13,14 @@ COMMENT= OpenType Unicode fonts for Scientific, Technical, and Math texts
LICENSE= OFL11
-BUILD_DEPENDS= mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale \
- mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
-RUN_DEPENDS= fc-cache:${PORTSDIR}/x11-fonts/fontconfig
-
NO_WRKSUBDIR= yes
-USES= zip
+USES= fonts zip
USE_XORG= x11
-PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}" \
- FCCACHE='${FCCACHE}'
-
SUB_FILES= pkg-message
-PKGMESSAGE= ${WRKDIR}/pkg-message
-SUB_LIST= FONTDIR=${FONTDIR}
FONTNAME= stix
-FONTDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
-
-MKFONTSCL_CMD= ${LOCALBASE}/bin/mkfontscale
-MKFONTDIR_CMD= ${LOCALBASE}/bin/mkfontdir
-FCCACHE= ${LOCALBASE}/bin/fc-cache -f -v
OPTIONS_DEFINE= DOCS
@@ -44,13 +31,10 @@ do-build:
.for group in stix-web STIX-MathJax/woff
${CP} ${WRKSRC}/${group}/*.woff ${WRKDIR}/build/
.endfor
- cd ${WRKDIR}/build && ${MKFONTSCL_CMD}
- ${REINPLACE_CMD} -e 's|-misc-|-stix-|' ${WRKDIR}/build/fonts.scale
- cd ${WRKDIR}/build && ${MKFONTDIR_CMD}
do-install:
- ${MKDIR} ${STAGEDIR}${FONTDIR}
- cd ${WRKDIR}/build && ${INSTALL_DATA} fonts.dir fonts.scale *.woff ${STAGEDIR}${FONTDIR}
+ ${MKDIR} ${STAGEDIR}${FONTSDIR}
+ cd ${WRKDIR}/build && ${INSTALL_DATA} *.woff ${STAGEDIR}${FONTSDIR}
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/x11-fonts/stix-fonts/files/pkg-message.in b/x11-fonts/stix-fonts/files/pkg-message.in
index 9c1334d88b56..b61ca8aad6d0 100644
--- a/x11-fonts/stix-fonts/files/pkg-message.in
+++ b/x11-fonts/stix-fonts/files/pkg-message.in
@@ -7,4 +7,4 @@ line to the "Modules" section of your X11 / x.org configuration file:
Add the following line to the "Files" section:
- FontPath "%%FONTDIR%%/"
+ FontPath "%%FONTSDIR%%/"
diff --git a/x11-fonts/stix-fonts/pkg-plist b/x11-fonts/stix-fonts/pkg-plist
index 6fe7365e3ec3..e6d23d2d0091 100644
--- a/x11-fonts/stix-fonts/pkg-plist
+++ b/x11-fonts/stix-fonts/pkg-plist
@@ -1,89 +1,84 @@
-%%FONTDIR%%/STIXGeneral-Bold.woff
-%%FONTDIR%%/STIXGeneral-BoldItalic.woff
-%%FONTDIR%%/STIXGeneral-Italic.woff
-%%FONTDIR%%/STIXGeneral-Regular.woff
-%%FONTDIR%%/STIXIntegralsD-Bold.woff
-%%FONTDIR%%/STIXIntegralsD-Regular.woff
-%%FONTDIR%%/STIXIntegralsSm-Bold.woff
-%%FONTDIR%%/STIXIntegralsSm-Regular.woff
-%%FONTDIR%%/STIXIntegralsUp-Bold.woff
-%%FONTDIR%%/STIXIntegralsUp-Regular.woff
-%%FONTDIR%%/STIXIntegralsUpD-Bold.woff
-%%FONTDIR%%/STIXIntegralsUpD-Regular.woff
-%%FONTDIR%%/STIXIntegralsUpSm-Bold.woff
-%%FONTDIR%%/STIXIntegralsUpSm-Regular.woff
-%%FONTDIR%%/STIXMathJax_Alphabets-Bold.woff
-%%FONTDIR%%/STIXMathJax_Alphabets-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Alphabets-Italic.woff
-%%FONTDIR%%/STIXMathJax_Alphabets-Regular.woff
-%%FONTDIR%%/STIXMathJax_Arrows-Bold.woff
-%%FONTDIR%%/STIXMathJax_Arrows-Regular.woff
-%%FONTDIR%%/STIXMathJax_DoubleStruck-Bold.woff
-%%FONTDIR%%/STIXMathJax_DoubleStruck-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_DoubleStruck-Italic.woff
-%%FONTDIR%%/STIXMathJax_DoubleStruck-Regular.woff
-%%FONTDIR%%/STIXMathJax_Fraktur-Bold.woff
-%%FONTDIR%%/STIXMathJax_Fraktur-Regular.woff
-%%FONTDIR%%/STIXMathJax_Latin-Bold.woff
-%%FONTDIR%%/STIXMathJax_Latin-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Latin-Italic.woff
-%%FONTDIR%%/STIXMathJax_Latin-Regular.woff
-%%FONTDIR%%/STIXMathJax_Main-Bold.woff
-%%FONTDIR%%/STIXMathJax_Main-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Main-Italic.woff
-%%FONTDIR%%/STIXMathJax_Main-Regular.woff
-%%FONTDIR%%/STIXMathJax_Marks-Bold.woff
-%%FONTDIR%%/STIXMathJax_Marks-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Marks-Italic.woff
-%%FONTDIR%%/STIXMathJax_Marks-Regular.woff
-%%FONTDIR%%/STIXMathJax_Misc-Bold.woff
-%%FONTDIR%%/STIXMathJax_Misc-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Misc-Italic.woff
-%%FONTDIR%%/STIXMathJax_Misc-Regular.woff
-%%FONTDIR%%/STIXMathJax_Monospace-Regular.woff
-%%FONTDIR%%/STIXMathJax_Normal-Bold.woff
-%%FONTDIR%%/STIXMathJax_Normal-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Normal-Italic.woff
-%%FONTDIR%%/STIXMathJax_Operators-Bold.woff
-%%FONTDIR%%/STIXMathJax_Operators-Regular.woff
-%%FONTDIR%%/STIXMathJax_SansSerif-Bold.woff
-%%FONTDIR%%/STIXMathJax_SansSerif-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_SansSerif-Italic.woff
-%%FONTDIR%%/STIXMathJax_SansSerif-Regular.woff
-%%FONTDIR%%/STIXMathJax_Script-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Script-Italic.woff
-%%FONTDIR%%/STIXMathJax_Script-Regular.woff
-%%FONTDIR%%/STIXMathJax_Shapes-Bold.woff
-%%FONTDIR%%/STIXMathJax_Shapes-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Shapes-Regular.woff
-%%FONTDIR%%/STIXMathJax_Size1-Regular.woff
-%%FONTDIR%%/STIXMathJax_Size2-Regular.woff
-%%FONTDIR%%/STIXMathJax_Size3-Regular.woff
-%%FONTDIR%%/STIXMathJax_Size4-Regular.woff
-%%FONTDIR%%/STIXMathJax_Size5-Regular.woff
-%%FONTDIR%%/STIXMathJax_Symbols-Bold.woff
-%%FONTDIR%%/STIXMathJax_Symbols-Regular.woff
-%%FONTDIR%%/STIXMathJax_Variants-Bold.woff
-%%FONTDIR%%/STIXMathJax_Variants-BoldItalic.woff
-%%FONTDIR%%/STIXMathJax_Variants-Italic.woff
-%%FONTDIR%%/STIXMathJax_Variants-Regular.woff
-%%FONTDIR%%/STIXNonUnicode-Bold.woff
-%%FONTDIR%%/STIXNonUnicode-BoldItalic.woff
-%%FONTDIR%%/STIXNonUnicode-Italic.woff
-%%FONTDIR%%/STIXNonUnicode-Regular.woff
-%%FONTDIR%%/STIXSizeFiveSym-Regular.woff
-%%FONTDIR%%/STIXSizeFourSym-Bold.woff
-%%FONTDIR%%/STIXSizeFourSym-Regular.woff
-%%FONTDIR%%/STIXSizeOneSym-Bold.woff
-%%FONTDIR%%/STIXSizeOneSym-Regular.woff
-%%FONTDIR%%/STIXSizeThreeSym-Bold.woff
-%%FONTDIR%%/STIXSizeThreeSym-Regular.woff
-%%FONTDIR%%/STIXSizeTwoSym-Bold.woff
-%%FONTDIR%%/STIXSizeTwoSym-Regular.woff
-%%FONTDIR%%/STIXVariants-Bold.woff
-%%FONTDIR%%/STIXVariants-Regular.woff
-%%FONTDIR%%/fonts.dir
-%%FONTDIR%%/fonts.scale
-@exec %%FCCACHE%% %D/%%FONTDIR%% 2>/dev/null || true
-@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || true
-@dirrm %%FONTDIR%%
+%%FONTSDIR%%/STIXGeneral-Bold.woff
+%%FONTSDIR%%/STIXGeneral-BoldItalic.woff
+%%FONTSDIR%%/STIXGeneral-Italic.woff
+%%FONTSDIR%%/STIXGeneral-Regular.woff
+%%FONTSDIR%%/STIXIntegralsD-Bold.woff
+%%FONTSDIR%%/STIXIntegralsD-Regular.woff
+%%FONTSDIR%%/STIXIntegralsSm-Bold.woff
+%%FONTSDIR%%/STIXIntegralsSm-Regular.woff
+%%FONTSDIR%%/STIXIntegralsUp-Bold.woff
+%%FONTSDIR%%/STIXIntegralsUp-Regular.woff
+%%FONTSDIR%%/STIXIntegralsUpD-Bold.woff
+%%FONTSDIR%%/STIXIntegralsUpD-Regular.woff
+%%FONTSDIR%%/STIXIntegralsUpSm-Bold.woff
+%%FONTSDIR%%/STIXIntegralsUpSm-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Alphabets-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Alphabets-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Alphabets-Italic.woff
+%%FONTSDIR%%/STIXMathJax_Alphabets-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Arrows-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Arrows-Regular.woff
+%%FONTSDIR%%/STIXMathJax_DoubleStruck-Bold.woff
+%%FONTSDIR%%/STIXMathJax_DoubleStruck-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_DoubleStruck-Italic.woff
+%%FONTSDIR%%/STIXMathJax_DoubleStruck-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Fraktur-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Fraktur-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Latin-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Latin-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Latin-Italic.woff
+%%FONTSDIR%%/STIXMathJax_Latin-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Main-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Main-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Main-Italic.woff
+%%FONTSDIR%%/STIXMathJax_Main-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Marks-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Marks-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Marks-Italic.woff
+%%FONTSDIR%%/STIXMathJax_Marks-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Misc-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Misc-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Misc-Italic.woff
+%%FONTSDIR%%/STIXMathJax_Misc-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Monospace-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Normal-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Normal-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Normal-Italic.woff
+%%FONTSDIR%%/STIXMathJax_Operators-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Operators-Regular.woff
+%%FONTSDIR%%/STIXMathJax_SansSerif-Bold.woff
+%%FONTSDIR%%/STIXMathJax_SansSerif-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_SansSerif-Italic.woff
+%%FONTSDIR%%/STIXMathJax_SansSerif-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Script-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Script-Italic.woff
+%%FONTSDIR%%/STIXMathJax_Script-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Shapes-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Shapes-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Shapes-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Size1-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Size2-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Size3-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Size4-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Size5-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Symbols-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Symbols-Regular.woff
+%%FONTSDIR%%/STIXMathJax_Variants-Bold.woff
+%%FONTSDIR%%/STIXMathJax_Variants-BoldItalic.woff
+%%FONTSDIR%%/STIXMathJax_Variants-Italic.woff
+%%FONTSDIR%%/STIXMathJax_Variants-Regular.woff
+%%FONTSDIR%%/STIXNonUnicode-Bold.woff
+%%FONTSDIR%%/STIXNonUnicode-BoldItalic.woff
+%%FONTSDIR%%/STIXNonUnicode-Italic.woff
+%%FONTSDIR%%/STIXNonUnicode-Regular.woff
+%%FONTSDIR%%/STIXSizeFiveSym-Regular.woff
+%%FONTSDIR%%/STIXSizeFourSym-Bold.woff
+%%FONTSDIR%%/STIXSizeFourSym-Regular.woff
+%%FONTSDIR%%/STIXSizeOneSym-Bold.woff
+%%FONTSDIR%%/STIXSizeOneSym-Regular.woff
+%%FONTSDIR%%/STIXSizeThreeSym-Bold.woff
+%%FONTSDIR%%/STIXSizeThreeSym-Regular.woff
+%%FONTSDIR%%/STIXSizeTwoSym-Bold.woff
+%%FONTSDIR%%/STIXSizeTwoSym-Regular.woff
+%%FONTSDIR%%/STIXVariants-Bold.woff
+%%FONTSDIR%%/STIXVariants-Regular.woff