aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-30 19:16:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-30 19:16:51 +0000
commit6fc804f45a0fc2b492616f8b859562ab3635084b (patch)
tree4e72210e9eadddaa4f08372e9d8139cea2811fba /x11-fonts
parent83c16a3eca11fda47345b4257a75dd06949bcfa4 (diff)
downloadports-6fc804f45a0fc2b492616f8b859562ab3635084b.tar.gz
ports-6fc804f45a0fc2b492616f8b859562ab3635084b.zip
Fix build with Python 3.8+
PR: 254503 Submitted by: kai
Notes
Notes: svn path=/head/; revision=569586
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/py-opentype-sanitizer/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/x11-fonts/py-opentype-sanitizer/Makefile b/x11-fonts/py-opentype-sanitizer/Makefile
index 2d603f7d1a93..4aade5f5270e 100644
--- a/x11-fonts/py-opentype-sanitizer/Makefile
+++ b/x11-fonts/py-opentype-sanitizer/Makefile
@@ -21,6 +21,12 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 3800
+LDFLAGS+= -lpython${PYTHON_VER}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/src/python/ots/__init__.py
@${RM} -r ${WRKSRC}/src/c/
@@ -31,4 +37,4 @@ post-install:
do-test:
cd ${WRKSRC}/ && ${PYTHON_CMD} -m pytest -v
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>