aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2014-05-06 04:47:02 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2014-05-06 04:47:02 +0000
commit7dc624750ca9dcc8c48be1fc94cd7f8d0674eed3 (patch)
tree964686efb0f08bef9100bf8a701ee90b5a71690f /x11-fonts
parentc2570e0d5646600d41c01cbd8a2c6010f0a29192 (diff)
Carlito is metric-compatible with Calibri font.
Carlito comes in regular, bold, italic, and bold italic. WWW: https://code.google.com/p/chromium/issues/detail?id=280557
Notes
Notes: svn path=/head/; revision=353060
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/crosextrafonts-carlito-ttf/Makefile41
-rw-r--r--x11-fonts/crosextrafonts-carlito-ttf/distinfo2
-rw-r--r--x11-fonts/crosextrafonts-carlito-ttf/files/pkg-message.in5
-rw-r--r--x11-fonts/crosextrafonts-carlito-ttf/pkg-descr4
-rw-r--r--x11-fonts/crosextrafonts-carlito-ttf/pkg-plist8
6 files changed, 61 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index 4ccb9bf8ff11..40f5c8e75e92 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -27,6 +27,7 @@
SUBDIR += consolamono-ttf
SUBDIR += croscorefonts-fonts-ttf
SUBDIR += crosextrafonts-caladea-ttf
+ SUBDIR += crosextrafonts-carlito-ttf
SUBDIR += cyberbit-ttfonts
SUBDIR += cyr-rfx
SUBDIR += dejavu
diff --git a/x11-fonts/crosextrafonts-carlito-ttf/Makefile b/x11-fonts/crosextrafonts-carlito-ttf/Makefile
new file mode 100644
index 000000000000..f00af9729a02
--- /dev/null
+++ b/x11-fonts/crosextrafonts-carlito-ttf/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= crosextrafonts-carlito
+PORTVERSION= 20130920
+CATEGORIES= x11-fonts
+MASTER_SITES= http://gsdview.appspot.com/chromeos-localmirror/distfiles/
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Font created by Google for ChromeOS to replace MS Calibri
+
+LICENSE= OFL11
+
+BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
+ mkfontscale:${PORTSDIR}/x11-fonts/mkfontscale
+
+USE_XORG= x11
+
+PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}"
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_LIST= FONTDIR=${FONTDIR}
+
+FONTNAME= Carlito
+FONTDIR= ${PREFIX}/lib/X11/fonts/${FONTNAME}
+INSTDAT= fonts.dir fonts.scale
+
+MKFONTSCL_CMD= ${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD= ${LOCALBASE}/bin/mkfontdir
+
+do-build:
+ cd ${WRKSRC} && ${MKFONTSCL_CMD}
+ ${REINPLACE_CMD} -e 's|-misc-|-google-|' ${WRKSRC}/fonts.scale
+ cd ${WRKSRC} && ${MKFONTDIR_CMD}
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${FONTDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${INSTDAT} *.ttf ${STAGEDIR}${FONTDIR}
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/crosextrafonts-carlito-ttf/distinfo b/x11-fonts/crosextrafonts-carlito-ttf/distinfo
new file mode 100644
index 000000000000..6aa21faab9cc
--- /dev/null
+++ b/x11-fonts/crosextrafonts-carlito-ttf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (crosextrafonts-carlito-20130920.tar.gz) = 4bd12b6cbc321c1cf16da76e2c585c925ce956a08067ae6f6c64eff6ccfdaf5a
+SIZE (crosextrafonts-carlito-20130920.tar.gz) = 1169488
diff --git a/x11-fonts/crosextrafonts-carlito-ttf/files/pkg-message.in b/x11-fonts/crosextrafonts-carlito-ttf/files/pkg-message.in
new file mode 100644
index 000000000000..dca252c8f1d3
--- /dev/null
+++ b/x11-fonts/crosextrafonts-carlito-ttf/files/pkg-message.in
@@ -0,0 +1,5 @@
+You can start using the fonts by following these instructions:
+
+Add the following line to the "Files" section of your x.org configuration file:
+
+ FontPath "%%FONTDIR%%/"
diff --git a/x11-fonts/crosextrafonts-carlito-ttf/pkg-descr b/x11-fonts/crosextrafonts-carlito-ttf/pkg-descr
new file mode 100644
index 000000000000..457de83c973f
--- /dev/null
+++ b/x11-fonts/crosextrafonts-carlito-ttf/pkg-descr
@@ -0,0 +1,4 @@
+Carlito is metric-compatible with Calibri font.
+Carlito comes in regular, bold, italic, and bold italic.
+
+WWW: https://code.google.com/p/chromium/issues/detail?id=280557
diff --git a/x11-fonts/crosextrafonts-carlito-ttf/pkg-plist b/x11-fonts/crosextrafonts-carlito-ttf/pkg-plist
new file mode 100644
index 000000000000..915870026fce
--- /dev/null
+++ b/x11-fonts/crosextrafonts-carlito-ttf/pkg-plist
@@ -0,0 +1,8 @@
+%%FONTDIR%%/Carlito-Bold.ttf
+%%FONTDIR%%/Carlito-BoldItalic.ttf
+%%FONTDIR%%/Carlito-Italic.ttf
+%%FONTDIR%%/Carlito-Regular.ttf
+%%FONTDIR%%/fonts.dir
+%%FONTDIR%%/fonts.scale
+@unexec rm %D/%%FONTDIR%%/fonts.cache-1 2>/dev/null || /usr/bin/true
+@dirrm %%FONTDIR%%