aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/Xfstt/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-11-18 23:45:17 +0000
committerAde Lovett <ade@FreeBSD.org>2000-11-18 23:45:17 +0000
commit0de2b402202cce32ef8b4b509d44fde7c5d84b0d (patch)
tree8c2e607069989ac7240317939e6234d5e647097d /x11-servers/Xfstt/Makefile
parentca308a57a4e20159c5bd91e96fec6697b6e12c39 (diff)
downloadports-0de2b402202cce32ef8b4b509d44fde7c5d84b0d.tar.gz
ports-0de2b402202cce32ef8b4b509d44fde7c5d84b0d.zip
Notes
Diffstat (limited to 'x11-servers/Xfstt/Makefile')
-rw-r--r--x11-servers/Xfstt/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/x11-servers/Xfstt/Makefile b/x11-servers/Xfstt/Makefile
index 7fb16c6e5a2f..fea95c40ae67 100644
--- a/x11-servers/Xfstt/Makefile
+++ b/x11-servers/Xfstt/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xfstt
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= x11-servers
MASTER_SITES= $(MASTER_SITE_SUNSITE)
MASTER_SITE_SUBDIR= X11/fonts
@@ -16,12 +17,22 @@ MAINTAINER= olgeni@uli.it
USE_X_PREFIX= yes
MAN1= xfstt.1
+.if defined(NOPORTDOCS)
+NODOCS= "@comment "
+.endif
+
+PLIST_SUB= NOPORTDOCS=${NODOCS}
+
do-install:
$(INSTALL_PROGRAM) $(WRKSRC)/xfstt $(PREFIX)/bin
$(INSTALL_MAN) $(WRKSRC)/xfstt.1x $(PREFIX)/man/man1/xfstt.1
post-install:
strip $(PREFIX)/bin/xfstt
+ ${SED} -e "/%%PREFIX%%/s##${PREFIX}#g" ${FILESDIR}/xfstt.sh \
+ > ${PREFIX}/etc/rc.d/xfstt.sh
+ ${CHMOD} 755 ${PREFIX}/etc/rc.d/xfstt.sh
+ $(MKDIR) $(PREFIX)/lib/X11/fonts/TrueType
.if !defined(NOPORTDOCS)
$(MKDIR) $(PREFIX)/share/doc/xfstt
$(INSTALL_DATA) $(WRKSRC)/FAQ $(PREFIX)/share/doc/xfstt
@@ -29,5 +40,8 @@ post-install:
$(INSTALL_DATA) $(WRKSRC)/INSTALL $(PREFIX)/share/doc/xfstt
$(INSTALL_DATA) $(WRKSRC)/THANKS.txt $(PREFIX)/share/doc/xfstt
.endif
+ @${ECHO}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO}
.include <bsd.port.mk>