aboutsummaryrefslogtreecommitdiff
path: root/x11-servers/xorg-server
diff options
context:
space:
mode:
authorJohn Kennedy <warlock@phouka.net>2022-08-15 13:49:33 +0000
committerMikael Urankar <mikael@FreeBSD.org>2022-08-15 15:10:00 +0000
commit39d767fa0b00ed86b29b388d946f3934d9cd6460 (patch)
tree1eaf666e0e2608d9e06839531ea9097d6eb3606d /x11-servers/xorg-server
parent99f5901e00bf9b641e62d889875919aee33acba6 (diff)
downloadports-39d767fa0b00ed86b29b388d946f3934d9cd6460.tar.gz
ports-39d767fa0b00ed86b29b388d946f3934d9cd6460.zip
Diffstat (limited to 'x11-servers/xorg-server')
-rw-r--r--x11-servers/xorg-server/files/patch-hw_xfree86_os-support_meson.build11
-rw-r--r--x11-servers/xorg-server/files/patch-include_meson.build11
2 files changed, 18 insertions, 4 deletions
diff --git a/x11-servers/xorg-server/files/patch-hw_xfree86_os-support_meson.build b/x11-servers/xorg-server/files/patch-hw_xfree86_os-support_meson.build
index 12373890385d..5051539d3aeb 100644
--- a/x11-servers/xorg-server/files/patch-hw_xfree86_os-support_meson.build
+++ b/x11-servers/xorg-server/files/patch-hw_xfree86_os-support_meson.build
@@ -1,8 +1,11 @@
---- hw/xfree86/os-support/meson.build.orig 2022-07-12 13:27:57 UTC
-+++ hw/xfree86/os-support/meson.build
-@@ -113,7 +113,7 @@ elif host_machine.system().endswith('bsd')
+--- hw/xfree86/os-support/meson.build.orig 2022-07-12 13:27:57.000000000 +0000
++++ hw/xfree86/os-support/meson.build 2022-08-08 23:22:53.349353000 +0000
+@@ -111,9 +111,9 @@
+ if host_machine.system() == 'netbsd' or host_machine.system() == 'openbsd'
+ os_dep += cc.find_library('i386')
endif
- elif host_machine.cpu_family() == 'arm'
+- elif host_machine.cpu_family() == 'arm'
++ elif host_machine.cpu_family() == 'arm' or host_machine.cpu_family() == 'aarch64'
srcs_xorg_os_support += 'bsd/arm_video.c'
- elif host_machine.cpu_family() == 'powerpc'
+ elif host_machine.cpu_family() == 'ppc' or host_machine.cpu_family() == 'ppc64'
diff --git a/x11-servers/xorg-server/files/patch-include_meson.build b/x11-servers/xorg-server/files/patch-include_meson.build
new file mode 100644
index 000000000000..a873f548052d
--- /dev/null
+++ b/x11-servers/xorg-server/files/patch-include_meson.build
@@ -0,0 +1,11 @@
+--- include/meson.build.orig 2022-07-12 13:27:57.000000000 +0000
++++ include/meson.build 2022-08-09 00:48:12.688887000 +0000
+@@ -377,7 +377,7 @@
+ xorg_data.set('HAVE_SYS_VT_H', cc.has_header('sys/vt.h') ? '1' : false)
+
+ if host_machine.system() == 'freebsd' or host_machine.system() == 'dragonfly'
+- if host_machine.cpu_family() == 'x86' or host_machine.cpu_family() == 'x86_64'
++ if host_machine.cpu_family() == 'x86' or host_machine.cpu_family() == 'x86_64' or host_machine.cpu_family() == 'aarch64'
+ xorg_data.set('USE_DEV_IO', '1')
+ endif
+ elif host_machine.system() == 'netbsd'