aboutsummaryrefslogtreecommitdiff
path: root/x11-servers
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-11-27 22:11:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-11-27 22:11:12 +0000
commita395432e4205c6bffb2c7aad3093a163ade580be (patch)
treeb913c0999b29add7696aad1aed35e6740391d6e8 /x11-servers
parentcb93d69930809e6df50ea354e25efe3935fa392b (diff)
downloadports-a395432e4205c6bffb2c7aad3093a163ade580be.tar.gz
ports-a395432e4205c6bffb2c7aad3093a163ade580be.zip
x11-servers/xarcan: add new port
This is a patched Xserver with a KDrive backend that uses the arcan-shmif to map Xlib/Xcb/X clients to a running Arcan instance. It currently works as a 'desktop in a window', where you supply the window manager and so on, and use the X side as normal. Some Arcan features will be lost, particularly any customizations done to the keybindings - normal X controls for defining keyboard maps and overrides are needed. https://github.com/letoram/xarcan
Notes
Notes: svn path=/head/; revision=556458
Diffstat (limited to 'x11-servers')
-rw-r--r--x11-servers/Makefile1
-rw-r--r--x11-servers/xarcan/Makefile63
-rw-r--r--x11-servers/xarcan/distinfo21
-rw-r--r--x11-servers/xarcan/pkg-descr10
4 files changed, 95 insertions, 0 deletions
diff --git a/x11-servers/Makefile b/x11-servers/Makefile
index 1c257544d379..52d1535c01ee 100644
--- a/x11-servers/Makefile
+++ b/x11-servers/Makefile
@@ -6,6 +6,7 @@
SUBDIR += Xfstt
SUBDIR += x2vnc
SUBDIR += x2x
+ SUBDIR += xarcan
SUBDIR += xephyr
SUBDIR += xorg-dmx
SUBDIR += xorg-nestserver
diff --git a/x11-servers/xarcan/Makefile b/x11-servers/xarcan/Makefile
new file mode 100644
index 000000000000..71ac8d8dccca
--- /dev/null
+++ b/x11-servers/xarcan/Makefile
@@ -0,0 +1,63 @@
+# $FreeBSD$
+
+PORTNAME= xarcan
+DISTVERSION= 0.5.4-1
+DISTVERSIONSUFFIX= -g8f075d78b
+CATEGORIES= x11-servers
+
+PATCH_SITES= https://github.com/freedesktop/xorg-xserver/commit/
+PATCHFILES+= 98dc1228f407.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/292
+PATCHFILES+= c7486613b0dc.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/304
+PATCHFILES+= 3340ddf37743.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/305
+PATCHFILES+= 622eea366aaf.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/318
+PATCHFILES+= 741bd73429e3.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/322
+PATCHFILES+= f2cf236da8e8.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/393
+PATCHFILES+= be731e0bdc7d.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/393
+PATCHFILES+= b5b529799a20.patch:-p1 # https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/393
+PATCHFILES+= fb310852f67d.patch:-p1 # https://github.com/letoram/xarcan/pull/7
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= X11 server as Arcan client
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/GL/internal/dri_interface.h:graphics/mesa-dri
+LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
+ libarcan_shmif_ext.so:multimedia/arcan
+RUN_DEPENDS= xkbcomp:x11/xkbcomp \
+ xkeyboard-config>0:x11/xkeyboard-config
+
+USES= compiler:c11 gl meson pkgconfig xorg
+USE_GITHUB= yes
+USE_GL= gbm gl
+USE_XORG= pixman xau xdmcp xfont2 xkbfile xshmfence xtrans
+GH_ACCOUNT= letoram
+MESON_ARGS= -D${PORTNAME}=true \
+ -Dxorg=false \
+ -Dxnest=false \
+ -Dxvfb=false \
+ -Dxwayland=false \
+ -Dudev=false \
+ -Dudev_kms=false \
+ -Ddefault_font_path="${DEFAULT_FONTPATH_LIST:ts,}"
+PLIST_FILES= bin/Xarcan
+
+# Keep in sync with xorg-server
+FONTPATH_ROOT?= ${LOCALBASE}/share/fonts
+FONTPATHD?= ${PREFIX}/etc/X11/fontpath.d
+DEFAULT_FONTPATH_LIST= \
+ ${FONTPATH_ROOT}/misc/ \
+ ${FONTPATH_ROOT}/TTF/ \
+ ${FONTPATH_ROOT}/OTF/ \
+ ${FONTPATH_ROOT}/Type1/ \
+ ${FONTPATH_ROOT}/100dpi/ \
+ ${FONTPATH_ROOT}/75dpi/ \
+ catalogue:${FONTPATHD}
+
+do-install:
+# XXX Prevent Meson from installing unrelated files
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/hw/kdrive/arcan/Xarcan \
+ ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/x11-servers/xarcan/distinfo b/x11-servers/xarcan/distinfo
new file mode 100644
index 000000000000..52b8b95fc792
--- /dev/null
+++ b/x11-servers/xarcan/distinfo
@@ -0,0 +1,21 @@
+TIMESTAMP = 1564316190
+SHA256 (letoram-xarcan-0.5.4-1-g8f075d78b_GH0.tar.gz) = eb923b332074c4076218c7e1bb42a3d687972fc364db175beb89b95710a69544
+SIZE (letoram-xarcan-0.5.4-1-g8f075d78b_GH0.tar.gz) = 5083988
+SHA256 (98dc1228f407.patch) = 463cbe0a7f81410d73e2a3b5563a1790ab3af4ab4fd0b4d0c769b739a3946037
+SIZE (98dc1228f407.patch) = 1422
+SHA256 (c7486613b0dc.patch) = 451be598799b4d306533664e6b74013f54b24fe3b85459d2efea7c5db98516cf
+SIZE (c7486613b0dc.patch) = 707
+SHA256 (3340ddf37743.patch) = f7f19d2772499ba8bbebbd114278c2eca1133c0fb8696cb1f046c40d966cf380
+SIZE (3340ddf37743.patch) = 664
+SHA256 (622eea366aaf.patch) = 8057a6dcbdc59b746a9f5ff7664a4288e980d7f788ff1d7b137ee82db3ffbd48
+SIZE (622eea366aaf.patch) = 5537
+SHA256 (741bd73429e3.patch) = 46888acb4f377ee0066c6e119b87a058262d903ebc584e70c7380a7c1ae4cdef
+SIZE (741bd73429e3.patch) = 3465
+SHA256 (f2cf236da8e8.patch) = 562c7d358803cf617a7fdafff037fd982b8e000c3dda6d6b2b8b54acb61437ca
+SIZE (f2cf236da8e8.patch) = 1380
+SHA256 (be731e0bdc7d.patch) = 0f69ec23cf3c8a6c2024a48d3f1b12d5851547b6c923ad3f233bf425ad3847bf
+SIZE (be731e0bdc7d.patch) = 1540
+SHA256 (b5b529799a20.patch) = a53167a35a3f416242156b134147530e303dc80db7516d9192cb96538ac89a10
+SIZE (b5b529799a20.patch) = 4501
+SHA256 (fb310852f67d.patch) = 8d8a4b58a084607bfe6149ab07d7d288c4b41cf40623912055f16276de14473f
+SIZE (fb310852f67d.patch) = 2136
diff --git a/x11-servers/xarcan/pkg-descr b/x11-servers/xarcan/pkg-descr
new file mode 100644
index 000000000000..5bf9e25b6990
--- /dev/null
+++ b/x11-servers/xarcan/pkg-descr
@@ -0,0 +1,10 @@
+This is a patched Xserver with a KDrive backend that uses the
+arcan-shmif to map Xlib/Xcb/X clients to a running Arcan instance.
+
+It currently works as a 'desktop in a window', where you supply the
+window manager and so on, and use the X side as normal. Some Arcan
+features will be lost, particularly any customizations done to the
+keybindings - normal X controls for defining keyboard maps and
+overrides are needed.
+
+WWW: https://github.com/letoram/xarcan