aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gnome-icons-faenza
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-10-06 19:02:37 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-10-06 19:02:37 +0000
commit62627f140769b6d77ee78186ff827faef4306504 (patch)
tree81316c69cec3f195a9ab989cc67e4897a9534b0f /x11-themes/gnome-icons-faenza
parent83d76a5e259d6f8e8cdc9e7e7983ed9d819e63d5 (diff)
downloadports-62627f140769b6d77ee78186ff827faef4306504.tar.gz
ports-62627f140769b6d77ee78186ff827faef4306504.zip
Add support for STAGEDIR
Notes
Notes: svn path=/head/; revision=329625
Diffstat (limited to 'x11-themes/gnome-icons-faenza')
-rw-r--r--x11-themes/gnome-icons-faenza/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-themes/gnome-icons-faenza/Makefile b/x11-themes/gnome-icons-faenza/Makefile
index 5f1dabd52395..74033bc48e3f 100644
--- a/x11-themes/gnome-icons-faenza/Makefile
+++ b/x11-themes/gnome-icons-faenza/Makefile
@@ -22,24 +22,24 @@ THEMES= Faenza Faenza-Dark Faenza-Darkest Faenza-Darker \
Faenza-Ambiance Faenza-Radiance
FAENZA_LIGHT= Faenza
FAENZA_DARK= Faenza-Dark
+INSTALLDIR= ${STAGEDIR}${PREFIX}/share/icons
-NO_STAGE= yes
do-install:
+ @${MKDIR} ${INSTALLDIR}
.for theme in ${THEMES}
- @cd ${WRKDIR} && ${TAR} -xf ${theme}.tar.gz
+ @cd ${INSTALLDIR} && ${TAR} -xf ${WRKDIR}/${theme}.tar.gz
.if ${FAENZA_LIGHT} == ${theme} || ${FAENZA_DARK} == ${theme}
- @cd ${WRKDIR}/${theme}/places/scalable && \
+ @cd ${INSTALLDIR}/${theme}/places/scalable && \
${LN} -sf start-here-gnome.svg start-here.svg && \
${LN} -sf start-here-gnome-symbolic.svg start-here-symbolic.svg
.for size in 22 24 32 48 64 96
- @cd ${WRKDIR}/${theme}/places/${size} && \
+ @cd ${INSTALLDIR}/${theme}/places/${size} && \
${LN} -sf start-here-gnome.png start-here.png
.endfor
.endif
-
- ${CP} -R ${WRKDIR}/${theme} ${PREFIX}/share/icons
- @cd ${PREFIX} && ${FIND} share/icons/${theme} ! -type d >> ${TMPPLIST} && \
+ @cd ${STAGEDIR}${PREFIX} && ${FIND} share/icons/${theme} ! \
+ -type d >> ${TMPPLIST} && \
${FIND} share/icons/${theme} -type d | ${SORT} -r | \
${SED} 's|^|@dirrm |' >> ${TMPPLIST}
.endfor