aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gnome-icons
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-04 19:32:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-04 19:32:17 +0000
commit4c73586a9d7c141674cdfa4feb5e608757ff626c (patch)
treeed126c56825c27740346dfd566c4fa585f1b0f9c /x11-themes/gnome-icons
parent9d51d547e26d57b7e489b3abaeb87ed16a1a068e (diff)
downloadports-4c73586a9d7c141674cdfa4feb5e608757ff626c.tar.gz
ports-4c73586a9d7c141674cdfa4feb5e608757ff626c.zip
Add helper Makefile for coming gnome-icons-* ports.
PR: ports/63744 Submitted by: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
Notes
Notes: svn path=/head/; revision=102933
Diffstat (limited to 'x11-themes/gnome-icons')
-rw-r--r--x11-themes/gnome-icons/Makefile.icons32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/gnome-icons/Makefile.icons b/x11-themes/gnome-icons/Makefile.icons
new file mode 100644
index 000000000000..29a61c824c38
--- /dev/null
+++ b/x11-themes/gnome-icons/Makefile.icons
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Gnome iconset
+# Date created: 29 Feb 2004
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+#
+
+# Port logic gratuitously stolen from x11-themes/kde-icons-noia by
+# lioux@.
+
+PKGNAMEPREFIX= gnome-icons-
+MASTER_SITES?= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR?= teams/art.gnome.org/themes/icon
+
+NO_BUILD= yes
+USE_SIZE= yes
+
+REASON= Themes may contain artwork not done by the author. \
+ Keep FreeBSD safe if theme author violated copyrights.
+
+USE_X_PREFIX= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/icons/${PORTNAME}
+ cd ${WRKSRC} && ${FIND} . -type d ! -empty \
+ -exec ${MKDIR} -m 0755 \
+ ${PREFIX}/share/icons/${PORTNAME}/"{}" \;
+ cd ${WRKSRC} && ${FIND} . -type f \
+ -exec ${INSTALL_DATA} ${WRKSRC}/"{}" \
+ ${PREFIX}/share/icons/${PORTNAME}/"{}" \;
+
+.include <bsd.port.mk>