aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/gtk-oxygen-engine
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-12-15 19:41:43 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-12-15 19:41:43 +0000
commit0a5f41a746a71f4d5ab393d29746f7d6c1d41c56 (patch)
tree099d46f8f890fd15ff4b68a279d009dd8b1887c2 /x11-themes/gtk-oxygen-engine
parentb5745d260a9e1a688d1878468056f50ba61393f6 (diff)
downloadports-0a5f41a746a71f4d5ab393d29746f7d6c1d41c56.tar.gz
ports-0a5f41a746a71f4d5ab393d29746f7d6c1d41c56.zip
- Update to 1.4.1.
- Support staging. Changes in this version: * Mark zotero as XUL application * Fix some antialias issue on sliders
Notes
Notes: svn path=/head/; revision=336573
Diffstat (limited to 'x11-themes/gtk-oxygen-engine')
-rw-r--r--x11-themes/gtk-oxygen-engine/Makefile9
-rw-r--r--x11-themes/gtk-oxygen-engine/distinfo4
-rw-r--r--x11-themes/gtk-oxygen-engine/files/patch-git_14571f161
-rw-r--r--x11-themes/gtk-oxygen-engine/pkg-plist3
4 files changed, 9 insertions, 68 deletions
diff --git a/x11-themes/gtk-oxygen-engine/Makefile b/x11-themes/gtk-oxygen-engine/Makefile
index 44c34a890ee3..e8826d724cbb 100644
--- a/x11-themes/gtk-oxygen-engine/Makefile
+++ b/x11-themes/gtk-oxygen-engine/Makefile
@@ -1,10 +1,10 @@
# $FreeBSD$
PORTNAME= oxygen
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.1
CATEGORIES= x11-themes
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTNAME}-gtk2/${PORTVERSION}/src/
+MASTER_SITE_SUBDIR= stable/${PORTNAME}-gtk2/${PORTVERSION}/src
PKGNAMEPREFIX= gtk-
PKGNAMESUFFIX= -engine
DISTNAME= ${PORTNAME}-gtk2-${PORTVERSION}
@@ -14,12 +14,11 @@ COMMENT= Oxygen-Gtk engine and theme
LICENSE= LGPL21
-LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
- dbus-glib-1:${PORTSDIR}/devel/dbus-glib
+LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
USE_BZIP2= yes
USE_GNOME= gtk20
USES= cmake pkgconfig
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11-themes/gtk-oxygen-engine/distinfo b/x11-themes/gtk-oxygen-engine/distinfo
index dc5c5f951fc6..f1af8236921b 100644
--- a/x11-themes/gtk-oxygen-engine/distinfo
+++ b/x11-themes/gtk-oxygen-engine/distinfo
@@ -1,2 +1,2 @@
-SHA256 (oxygen-gtk2-1.4.0.tar.bz2) = 84e24b78c71a73c38bfe41da609524307344060fe7e74fa9790380da234e1734
-SIZE (oxygen-gtk2-1.4.0.tar.bz2) = 198415
+SHA256 (oxygen-gtk2-1.4.1.tar.bz2) = 8dab594f7ddd133068d2abe18bab023579e78b7108114780edaf40f43e6d798f
+SIZE (oxygen-gtk2-1.4.1.tar.bz2) = 197293
diff --git a/x11-themes/gtk-oxygen-engine/files/patch-git_14571f1 b/x11-themes/gtk-oxygen-engine/files/patch-git_14571f1
deleted file mode 100644
index 70755aeef0e3..000000000000
--- a/x11-themes/gtk-oxygen-engine/files/patch-git_14571f1
+++ /dev/null
@@ -1,61 +0,0 @@
-commit 14571f123ad56909986f795c26ae48e42b0ceb26
-Author: Raphael Kubo da Costa <rakuco@FreeBSD.org>
-Date: Sat Aug 31 16:12:49 2013 +0300
-
- Use g_mkdir() instead of different versions of mkdir().
-
- The current code was erroneously relying on the _POSIX_C_SOURCE macro to
- decide whether to use mkdir() with the signature present in POSIX-compliant
- systems or with the Windows signature.
-
- It turns out POSIX.1 expects the applications to define _POSIX_C_SOURCE to
- certain values. Only glibc resorts to defining it to a value by default,
- opposing what the standard says. It would then break systems that use
- another libc, such as the BSDs, OS X and maybe even other Linux libc
- implementations.
-
- Work around the issue by just relying on glib's g_mkdir(), which has the
- proper means to decide which mkdir() function to call. We still need to
- check for whether we are on Windows, though, since some of the mode
- constants are not defined on it.
-
- REVIEW: 112402
-
-diff --git a/src/oxygenqtsettings.cpp b/src/oxygenqtsettings.cpp
-index 9027d30..10ebdf8 100644
---- src/oxygenqtsettings.cpp
-+++ src/oxygenqtsettings.cpp
-@@ -28,6 +28,8 @@
- #include "oxygentimeline.h"
- #include "config.h"
-
-+#include <glib.h>
-+#include <glib/gstdio.h>
- #include <gtk/gtk.h>
-
- #include <algorithm>
-@@ -38,7 +40,6 @@
- #include <fstream>
- #include <iostream>
- #include <sstream>
--#include <unistd.h>
-
- namespace Oxygen
- {
-@@ -330,11 +331,12 @@ namespace Oxygen
- struct stat st;
- if( stat( _userConfigDir.c_str(), &st ) != 0 )
- {
--
-- #if _POSIX_C_SOURCE
-- mkdir( _userConfigDir.c_str(), S_IRWXU|S_IRWXG|S_IRWXO );
-+ #ifdef G_OS_WIN32
-+ // S_IRWXG and S_IRWXO are undefined on Windows, and g_mkdir()
-+ // ignores its second parameter on Windows anyway.
-+ g_mkdir( _userConfigDir.c_str(), 0 );
- #else
-- mkdir( _userConfigDir.c_str() );
-+ g_mkdir( _userConfigDir.c_str(), S_IRWXU|S_IRWXG|S_IRWXO );
- #endif
- }
-
diff --git a/x11-themes/gtk-oxygen-engine/pkg-plist b/x11-themes/gtk-oxygen-engine/pkg-plist
index ca801f85f499..2c2a46a10980 100644
--- a/x11-themes/gtk-oxygen-engine/pkg-plist
+++ b/x11-themes/gtk-oxygen-engine/pkg-plist
@@ -12,3 +12,6 @@ share/themes/oxygen-gtk/gtk-2.0/special-icons/standardbutton-closetab-hover-16.p
@dirrm share/themes/oxygen-gtk/gtk-2.0
@dirrmtry share/themes/oxygen-gtk
@dirrmtry share/themes
+@dirrmtry lib/gtk-2.0/%%GTK2_VERSION%%/engines
+@dirrmtry lib/gtk-2.0/%%GTK2_VERSION%%
+@dirrmtry lib/gtk-2.0