aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/kf5-qqc2-desktop-style
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-09-01 15:04:28 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-09-01 15:04:28 +0000
commita910a496a1460f9a366f023ab5e651a9ff9c51ef (patch)
tree3911ef6776caac0bd44dc0ea9c5fbc738fb521b7 /x11-themes/kf5-qqc2-desktop-style
parenta3fe9493c54ff377fb13b9395ef221e4c60989e3 (diff)
downloadports-a910a496a1460f9a366f023ab5e651a9ff9c51ef.tar.gz
ports-a910a496a1460f9a366f023ab5e651a9ff9c51ef.zip
Backport theme-style fix for KDE qqc2-desktop-style
The theme was doing weird things which broke Musescore. Upstream (except there's a whole forest of intertwined bug reports) report https://bugs.kde.org/show_bug.cgi?id=425949 PR: 247466 Reported by: Keith White
Notes
Notes: svn path=/head/; revision=547276
Diffstat (limited to 'x11-themes/kf5-qqc2-desktop-style')
-rw-r--r--x11-themes/kf5-qqc2-desktop-style/Makefile1
-rw-r--r--x11-themes/kf5-qqc2-desktop-style/files/patch-git-1f0f210ad1d8286ba7a8254664489f922cbba0c345
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-themes/kf5-qqc2-desktop-style/Makefile b/x11-themes/kf5-qqc2-desktop-style/Makefile
index 292ccc949d94..bb87a50162a3 100644
--- a/x11-themes/kf5-qqc2-desktop-style/Makefile
+++ b/x11-themes/kf5-qqc2-desktop-style/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qqc2-desktop-style
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-themes kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
diff --git a/x11-themes/kf5-qqc2-desktop-style/files/patch-git-1f0f210ad1d8286ba7a8254664489f922cbba0c3 b/x11-themes/kf5-qqc2-desktop-style/files/patch-git-1f0f210ad1d8286ba7a8254664489f922cbba0c3
new file mode 100644
index 000000000000..63b4bfa2d2cf
--- /dev/null
+++ b/x11-themes/kf5-qqc2-desktop-style/files/patch-git-1f0f210ad1d8286ba7a8254664489f922cbba0c3
@@ -0,0 +1,45 @@
+Git commit 1f0f210ad1d8286ba7a8254664489f922cbba0c3 by Noah Davis.
+Committed on 31/08/2020 at 12:46.
+Pushed by ndavis into branch 'master'.
+
+Don't use parent height/width for implicit ToolSeparator sizing
+
+I realized this was pretty much all wrong, so I rewrote the whole thing with a structure inspired by the Default QQC2 theme.
+
+Padding property was removed since it was originally added to give the
+separator back the padding that it lost by having the same height as the
+parent.
+
+diff --git org.kde.desktop/ToolSeparator.qml org.kde.desktop/ToolSeparator.qml
+index 197cd46..80d172f 100644
+--- org.kde.desktop/ToolSeparator.qml
++++ org.kde.desktop/ToolSeparator.qml
+@@ -12,20 +12,14 @@ import org.kde.kirigami 2.4 as Kirigami
+ T.ToolSeparator {
+ id: controlRoot
+
+- topPadding: 0
+- bottomPadding: 0
+- leftPadding: Kirigami.Units.smallSpacing
+- rightPadding: Kirigami.Units.smallSpacing
++ implicitWidth: Math.max(implicitBackgroundWidth + leftInset + rightInset,
++ implicitContentWidth + leftPadding + rightPadding)
++ implicitHeight: Math.max(implicitBackgroundHeight + topInset + bottomInset,
++ implicitContentHeight + topPadding + bottomPadding)
+
+- implicitWidth: separator.width + controlRoot.leftPadding + controlRoot.rightPadding
+- implicitHeight: parent.height
+-
+- background: Kirigami.Separator {
+- id: separator
+- anchors {
+- top: controlRoot.top
+- bottom: controlRoot.bottom
+- horizontalCenter: controlRoot.horizontalCenter
+- }
++ contentItem: Kirigami.Separator {
++ // implicitHeight is the same as ToolBar implicitHeight minus ToolBar padding if not horizontal
++ implicitHeight: horizontal ? Math.floor(Kirigami.Units.devicePixelRatio) : 40 - (Kirigami.Units.smallSpacing * 2)
++ implicitWidth: horizontal ? 40 - (Kirigami.Units.smallSpacing * 2) : Math.floor(Kirigami.Units.devicePixelRatio)
+ }
+ }