aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/mate-themes/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
commita236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1 (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /x11-themes/mate-themes/Makefile
parentfdf023af8a1f19bbc7987f3abfb59c503eb6d52c (diff)
downloadports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.tar.gz
ports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.zip
Notes
Diffstat (limited to 'x11-themes/mate-themes/Makefile')
-rw-r--r--x11-themes/mate-themes/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-themes/mate-themes/Makefile b/x11-themes/mate-themes/Makefile
new file mode 100644
index 000000000000..c8afccf1ba38
--- /dev/null
+++ b/x11-themes/mate-themes/Makefile
@@ -0,0 +1,29 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-themes
+PORTVERSION= 1.6.1
+CATEGORIES= x11-themes mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Collection of themes and icons for MATE
+
+BUILD_DEPENDS= gtk-engines2>=2.15.0:${PORTSDIR}/x11-themes/gtk-engines2 \
+ icon-naming-utils>=0.8.7:${PORTSDIR}/x11-themes/icon-naming-utils
+RUN_DEPENDS= gtk-engines2>=2.15.0:${PORTSDIR}/x11-themes/gtk-engines2 \
+ gtk-murrine-engine>=0.98:${PORTSDIR}/x11-themes/gtk-murrine-engine
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= marco
+USE_GNOME= gdkpixbuf2 gtk20 intlhack
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+.include <bsd.port.mk>