aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/qt5-style-plugins
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-07-08 07:08:07 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-07-08 07:08:07 +0000
commit2b8a1b4ad4d9ae2057652123a3793c07c9ae7f4f (patch)
treea1a4316772ef35c5c153f9bf58ee84afbf3cb827 /x11-themes/qt5-style-plugins
parente57319baf9096066cce78e19df885408291d7fe4 (diff)
downloadports-2b8a1b4ad4d9ae2057652123a3793c07c9ae7f4f.tar.gz
ports-2b8a1b4ad4d9ae2057652123a3793c07c9ae7f4f.zip
x11-themes/qt5-style-plugins: fix build against Qt5.15
- patches obtained from Suse via arch PR: 247841 Submitted by: rewest <rewestwork@gmail.com>
Notes
Notes: svn path=/head/; revision=541466
Diffstat (limited to 'x11-themes/qt5-style-plugins')
-rw-r--r--x11-themes/qt5-style-plugins/Makefile2
-rw-r--r--x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.1543
2 files changed, 43 insertions, 2 deletions
diff --git a/x11-themes/qt5-style-plugins/Makefile b/x11-themes/qt5-style-plugins/Makefile
index 340db3ed90f5..14fc90c63c34 100644
--- a/x11-themes/qt5-style-plugins/Makefile
+++ b/x11-themes/qt5-style-plugins/Makefile
@@ -14,8 +14,6 @@ COMMENT= Additional Styles for Qt 5 and KDE
LICENSE= LGPL21
-BROKEN= Not compatible with modern Qt
-
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
diff --git a/x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.15 b/x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.15
new file mode 100644
index 000000000000..2211542ed61c
--- /dev/null
+++ b/x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.15
@@ -0,0 +1,43 @@
+From 335dbece103e2cbf6c7cf819ab6672c2956b17b3 Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fvogt@suse.de>
+Date: Thu, 28 May 2020 12:35:42 +0200
+Subject: [PATCH] fix build against Qt 5.15
+
+With 0a93db4d82c051164923a10e4382b12de9049b45 ("Unify application
+palette handling between QGuiApplication and QApplication")
+QApplicationPrivate::setSystemPalette is no longer used and necessary.
+---
+ src/plugins/styles/gtk2/qgtkstyle.cpp | 2 ++
+ src/plugins/styles/gtk2/qgtkstyle_p.cpp | 2 ++
+ 2 files changed, 4 insertions(+)
+
+diff --git a/src/plugins/styles/gtk2/qgtkstyle.cpp b/src/plugins/styles/gtk2/qgtkstyle.cpp
+index 36169c9..2544593 100644
+--- src/plugins/styles/gtk2/qgtkstyle.cpp
++++ src/plugins/styles/gtk2/qgtkstyle.cpp
+@@ -440,7 +440,9 @@ void QGtkStyle::polish(QApplication *app)
+ // not supported as these should be entirely determined by
+ // current Gtk settings
+ if (app->desktopSettingsAware() && d->isThemeAvailable()) {
++#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
+ QApplicationPrivate::setSystemPalette(standardPalette());
++#endif
+ QApplicationPrivate::setSystemFont(d->getThemeFont());
+ d->applyCustomPaletteHash();
+ if (!d->isKDE4Session())
+diff --git a/src/plugins/styles/gtk2/qgtkstyle_p.cpp b/src/plugins/styles/gtk2/qgtkstyle_p.cpp
+index e57b3d8..e71beb0 100644
+--- src/plugins/styles/gtk2/qgtkstyle_p.cpp
++++ src/plugins/styles/gtk2/qgtkstyle_p.cpp
+@@ -508,7 +508,9 @@ void QGtkStyleUpdateScheduler::updateTheme()
+ if (oldTheme != QGtkStylePrivate::getThemeName()) {
+ oldTheme = QGtkStylePrivate::getThemeName();
+ QPalette newPalette = qApp->style()->standardPalette();
++#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
+ QApplicationPrivate::setSystemPalette(newPalette);
++#endif
+ QApplication::setPalette(newPalette);
+ if (!QGtkStylePrivate::instances.isEmpty()) {
+ QGtkStylePrivate::instances.last()->initGtkWidgets();
+--
+2.26.2