aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/qtcurve
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-10-22 23:20:21 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-10-22 23:20:21 +0000
commit1580accc3341a5546b96f19c1b0896d5d07b8817 (patch)
treeb489cb8e0350cb25c1df7512711a05f56ec56526 /x11-themes/qtcurve
parent7e8c48b45dd35b96a832f60524ea2b35c5956a30 (diff)
downloadports-1580accc3341a5546b96f19c1b0896d5d07b8817.tar.gz
ports-1580accc3341a5546b96f19c1b0896d5d07b8817.zip
- Fix NULL pointer dereference in gtkDrawFlatBox() in x11-themes/qtcurve-gtk2 [1]
- Set LICENSE - Take maintainership of the qtcurve ports PR: 211391 [1] Submitted by: <f.degner@gmx.de> [1]
Notes
Notes: svn path=/head/; revision=424491
Diffstat (limited to 'x11-themes/qtcurve')
-rw-r--r--x11-themes/qtcurve/Makefile5
-rw-r--r--x11-themes/qtcurve/files/patch-gtk2_style_qtcurve.c11
2 files changed, 15 insertions, 1 deletions
diff --git a/x11-themes/qtcurve/Makefile b/x11-themes/qtcurve/Makefile
index b5794ad11a06..bdf7b266cdf9 100644
--- a/x11-themes/qtcurve/Makefile
+++ b/x11-themes/qtcurve/Makefile
@@ -4,7 +4,7 @@ PORTNAME= qtcurve
PORTVERSION= 1.8.18
CATEGORIES= x11-themes
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jhale@FreeBSD.org
COMMENT?= Widget styles for Qt and GTK+ toolkits
.if !defined(QTCURVE_SLAVE)
@@ -21,6 +21,9 @@ QT4_RUN_DEPENDS= qt4-style-qtcurve>=1.8.18:x11-themes/qtcurve-qt4
QT5_RUN_DEPENDS= qt5-style-qtcurve>=1.8.18:x11-themes/qtcurve-qt5
.else # !defined(QTCURVE_SLAVE)
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_GITHUB= yes
GH_ACCOUNT= QtCurve
diff --git a/x11-themes/qtcurve/files/patch-gtk2_style_qtcurve.c b/x11-themes/qtcurve/files/patch-gtk2_style_qtcurve.c
new file mode 100644
index 000000000000..800e3dfffd0a
--- /dev/null
+++ b/x11-themes/qtcurve/files/patch-gtk2_style_qtcurve.c
@@ -0,0 +1,11 @@
+--- gtk2/style/qtcurve.c.orig 2014-01-25 20:13:54 UTC
++++ gtk2/style/qtcurve.c
+@@ -372,7 +372,7 @@ gtkDrawFlatBox(GtkStyle *style, GdkWindo
+ } else if (!(qtSettings.app == GTK_APP_JAVA && widget &&
+ GTK_IS_LABEL(widget))) {
+ if (state != GTK_STATE_PRELIGHT || opts.crHighlight ||
+- strcmp(detail, "checkbutton") != 0) {
++ ( detail != NULL && strcmp(detail, "checkbutton") != 0 )) {
+ parent_class->draw_flat_box(style, window, state, shadow, area,
+ widget, detail, x, y, width, height);
+ }