aboutsummaryrefslogtreecommitdiff
path: root/x11-themes/qtcurve
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-05-18 21:26:50 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-05-18 21:26:50 +0000
commite1a86f3168fdbb6508792511551443c4aaf116a2 (patch)
tree5208110a22a56b2e398ad8f978199ad7bc4d2865 /x11-themes/qtcurve
parent3ebfd7377f8b66b84568a2b600490418f3b33ab8 (diff)
downloadports-e1a86f3168fdbb6508792511551443c4aaf116a2.tar.gz
ports-e1a86f3168fdbb6508792511551443c4aaf116a2.zip
x11-themes/qtcurve-*:
- Update to 1.8.18 and reorganize ports due to upstream changes - And new port for Qt 5 [1] - Add meta port to install styles for all toolkits PR: 199871 [1] Submitted by: matthew@reztek.cz
Notes
Notes: svn path=/head/; revision=386718
Diffstat (limited to 'x11-themes/qtcurve')
-rw-r--r--x11-themes/qtcurve/Makefile92
-rw-r--r--x11-themes/qtcurve/distinfo2
-rw-r--r--x11-themes/qtcurve/files/patch-323402d56
-rw-r--r--x11-themes/qtcurve/files/patch-bdf0a5c22
-rw-r--r--x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt11
-rw-r--r--x11-themes/qtcurve/files/patch-lib_utils_fd__utils.c10
-rw-r--r--x11-themes/qtcurve/files/patch-lib_utils_map.c20
-rw-r--r--x11-themes/qtcurve/files/patch-lib_utils_process.c12
-rw-r--r--x11-themes/qtcurve/pkg-descr3
-rw-r--r--x11-themes/qtcurve/pkg-plist.gtk212
-rw-r--r--x11-themes/qtcurve/pkg-plist.kde421
-rw-r--r--x11-themes/qtcurve/pkg-plist.utils10
12 files changed, 271 insertions, 0 deletions
diff --git a/x11-themes/qtcurve/Makefile b/x11-themes/qtcurve/Makefile
new file mode 100644
index 000000000000..271da21dd062
--- /dev/null
+++ b/x11-themes/qtcurve/Makefile
@@ -0,0 +1,92 @@
+# $FreeBSD$
+
+PORTNAME= qtcurve
+PORTVERSION= 1.8.18
+CATEGORIES= x11-themes
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT?= Widget styles for Qt and GTK+ toolkits
+
+.if !defined(QTCURVE_SLAVE)
+USES= metaport
+# There is no NO_PATCH
+PATCHDIR= ${MASTERDIR}/none
+
+OPTIONS_DEFINE= GTK2 KDE4 QT4 QT5
+OPTIONS_DEFAULT:= ${OPTIONS_DEFINE}
+
+GTK2_RUN_DEPENDS= gtk2-qtcurve-theme>=1.8.18:${PORTSDIR}/x11-themes/qtcurve-gtk2
+KDE4_RUN_DEPENDS= kde4-style-qtcurve>=1.8.18:${PORTSDIR}/x11-themes/qtcurve-kde4
+QT4_RUN_DEPENDS= qt4-style-qtcurve>=1.8.18:${PORTSDIR}/x11-themes/qtcurve-qt4
+QT5_RUN_DEPENDS= qt5-style-qtcurve>=1.8.18:${PORTSDIR}/x11-themes/qtcurve-qt5
+
+.else # !defined(QTCURVE_SLAVE)
+USE_GITHUB= yes
+GH_ACCOUNT= QtCurve
+
+USES= compiler:c++0x cmake execinfo pkgconfig
+USE_XORG= x11 xcb
+
+.for i in gtk2 kde4 qt4 qt5
+WITH_${i}= Off
+.endfor
+WITH_${QTCURVE_SLAVE}= On
+
+CMAKE_ARGS+= -DENABLE_GTK2=${WITH_gtk2} \
+ -DENABLE_QT4=${WITH_qt4} \
+ -DENABLE_QT5=${WITH_qt5} \
+ -DQTC_QT4_ENABLE_KDE=${WITH_kde4}
+LDFLAGS+= -L${LOCALBASE}/lib
+
+BUILD_WRKSRC= ${WRKSRC}/${QTCURVE_SLAVE}
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+
+PLIST= ${PKGDIR}/pkg-plist.${QTCURVE_SLAVE}
+
+.if ${QTCURVE_SLAVE} == "utils"
+PKGNAMESUFFIX= -utils
+USE_LDCONFIG= yes
+BUILD_WRKSRC= ${WRKSRC}
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext-tools:build
+NLS_CMAKE_OFF= -DQTC_INSTALL_PO=Off
+.else
+LIB_DEPENDS+= libqtcurve-utils.so:${PORTSDIR}/x11-themes/qtcurve-utils
+.endif
+
+.if ${QTCURVE_SLAVE} == "gtk2"
+PKGNAMEPREFIX= gtk2-
+PKGNAMESUFFIX= -theme
+USE_GNOME= gtk20 cairo pango
+USE_LDCONFIG= yes
+
+post-install:
+ @(cd ${WRKSRC}/lib/cairo && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET})
+.endif
+
+.if ${QTCURVE_SLAVE} == "kde4"
+WITH_qt4= On # required for KDE 4
+PKGNAMEPREFIX= kde4-style-
+USE_KDE4= kdelibs workspace kdeprefix automoc4
+USE_QT4= moc_build qmake_build rcc_build uic_build
+BUILD_WRKSRC= ${WRKSRC}/qt4
+.endif
+
+.if ${QTCURVE_SLAVE} == "qt4"
+PKGNAMEPREFIX= qt4-style-
+USE_QT4= dbus gui svg moc_build qmake_build rcc_build uic_build
+PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/qtcurve.so
+.endif
+
+.if ${QTCURVE_SLAVE} == "qt5"
+PKGNAMEPREFIX= qt5-style-
+USE_QT5= dbus gui svg widgets x11extras buildtools_build qmake_build
+PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/qtcurve.so
+.endif
+
+.endif # !defined(QTCURVE_SLAVE)
+
+.include <bsd.port.mk>
diff --git a/x11-themes/qtcurve/distinfo b/x11-themes/qtcurve/distinfo
new file mode 100644
index 000000000000..905dc3b50a4e
--- /dev/null
+++ b/x11-themes/qtcurve/distinfo
@@ -0,0 +1,2 @@
+SHA256 (QtCurve-qtcurve-1.8.18_GH0.tar.gz) = 85997c9fa4a948945d719342f5993486aecf189d176408280bad9af8600873a6
+SIZE (QtCurve-qtcurve-1.8.18_GH0.tar.gz) = 991195
diff --git a/x11-themes/qtcurve/files/patch-323402d b/x11-themes/qtcurve/files/patch-323402d
new file mode 100644
index 000000000000..28ccc2aeb8f5
--- /dev/null
+++ b/x11-themes/qtcurve/files/patch-323402d
@@ -0,0 +1,56 @@
+From: Marco Martin <notmart@gmail.com>
+Date: Mon, 19 May 2014 08:37:37 +0000
+Subject: remove qt_filedialog_* api
+X-Git-Url: http://quickgit.kde.org/?p=qtcurve.git&a=commitdiff&h=323402d8b99502300f65e909c61153cbd5d5d997
+---
+remove qt_filedialog_* api
+
+it has been removed and doesn't build anymore with recent Qt5 stable
+branch
+---
+
+
+--- qt5/style/qtcurve_api.cpp
++++ qt5/style/qtcurve_api.cpp
+@@ -67,25 +67,6 @@
+
+ #include <QDebug>
+
+-extern QString (*qt_filedialog_existing_directory_hook)(
+- QWidget *parent, const QString &caption, const QString &dir,
+- QFileDialog::Options options);
+-
+-extern QString (*qt_filedialog_open_filename_hook)(
+- QWidget *parent, const QString &caption, const QString &dir,
+- const QString &filter, QString *selectedFilter,
+- QFileDialog::Options options);
+-
+-extern QStringList (*qt_filedialog_open_filenames_hook)(
+- QWidget * parent, const QString &caption, const QString &dir,
+- const QString &filter, QString *selectedFilter,
+- QFileDialog::Options options);
+-
+-extern QString (*qt_filedialog_save_filename_hook)(
+- QWidget *parent, const QString &caption, const QString &dir,
+- const QString &filter, QString *selectedFilter,
+- QFileDialog::Options options);
+-
+ namespace QtCurve {
+
+ void
+@@ -161,13 +142,6 @@
+ if(!qtcIsFlatBgnd(opts.menuBgndAppearance) && 0 == opts.lighterPopupMenuBgnd)
+ opts.lighterPopupMenuBgnd=1; // shade so that we dont have 3d-ish borders...
+ opts.menuBgndAppearance = APPEARANCE_FLAT;
+- }
+-
+- if (opts.useQtFileDialogApps.contains(appName)) {
+- qt_filedialog_existing_directory_hook = 0L;
+- qt_filedialog_open_filename_hook = 0L;
+- qt_filedialog_open_filenames_hook = 0L;
+- qt_filedialog_save_filename_hook = 0L;
+ }
+
+ QCommonStyle::polish(app);
+
+
diff --git a/x11-themes/qtcurve/files/patch-bdf0a5c b/x11-themes/qtcurve/files/patch-bdf0a5c
new file mode 100644
index 000000000000..f93b61fe01dc
--- /dev/null
+++ b/x11-themes/qtcurve/files/patch-bdf0a5c
@@ -0,0 +1,22 @@
+From: Yichao Yu <yyc1992@gmail.com>
+Date: Sun, 02 Feb 2014 12:11:06 +0000
+Subject: [lib/utils/x11shadow] typo in shadow color .... #54
+X-Git-Url: http://quickgit.kde.org/?p=qtcurve.git&a=commitdiff&h=bdf0a5ce3ecc7ac0a7f9636358d444b7c4305828
+---
+[lib/utils/x11shadow] typo in shadow color .... #54
+---
+
+
+--- lib/utils/x11helpers.c
++++ lib/utils/x11helpers.c
+@@ -77,7 +77,7 @@
+ {
+ int shadow_size = 30;
+ int shadow_radius = 4;
+- QtcColor c1 = {0.5, 0.4, 0.4};
++ QtcColor c1 = {0.4, 0.4, 0.4};
+ QtcColor c2 = {0.2, 0.2, 0.2};
+ QtcImage *shadow_images[8];
+ qtcShadowCreate(shadow_size, &c1, &c2, shadow_radius, false,
+
+
diff --git a/x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt b/x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt
new file mode 100644
index 000000000000..e18f39c1c884
--- /dev/null
+++ b/x11-themes/qtcurve/files/patch-lib_utils_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- lib/utils/CMakeLists.txt.orig 2014-01-25 20:13:54 UTC
++++ lib/utils/CMakeLists.txt
+@@ -13,7 +13,7 @@ set(qtcurve_utils_SRCS
+ x11helpers.c
+ x11wrap.c)
+ set(qtcurve_utils_LINKS
+- m rt dl ${LIBEXECINFO_LIBRARIES} pthread)
++ m rt ${CMAKE_DL_LIBS} ${LIBEXECINFO_LIBRARIES} pthread)
+
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}")
+
diff --git a/x11-themes/qtcurve/files/patch-lib_utils_fd__utils.c b/x11-themes/qtcurve/files/patch-lib_utils_fd__utils.c
new file mode 100644
index 000000000000..b7c67c7d82c1
--- /dev/null
+++ b/x11-themes/qtcurve/files/patch-lib_utils_fd__utils.c
@@ -0,0 +1,10 @@
+--- lib/utils/fd_utils.c.orig 2014-01-25 20:13:54 UTC
++++ lib/utils/fd_utils.c
+@@ -21,6 +21,7 @@
+
+ #include "fd_utils.h"
+ #include <sys/socket.h>
++#include <sys/types.h>
+ #include <fcntl.h>
+
+ QTC_EXPORT bool
diff --git a/x11-themes/qtcurve/files/patch-lib_utils_map.c b/x11-themes/qtcurve/files/patch-lib_utils_map.c
new file mode 100644
index 000000000000..07d7c18d0f42
--- /dev/null
+++ b/x11-themes/qtcurve/files/patch-lib_utils_map.c
@@ -0,0 +1,20 @@
+--- lib/utils/map.c.orig 2015-05-02 14:52:48 UTC
++++ lib/utils/map.c
+@@ -22,7 +22,7 @@
+ #include "map.h"
+
+ static int
+-qtcStrMapItemCompare(const void *_left, const void *_right, void *_map)
++qtcStrMapItemCompare(void *_map, const void *_left, const void *_right)
+ {
+ const char **left = (const char**)_left;
+ const char **right = (const char**)_right;
+@@ -36,7 +36,7 @@ qtcStrMapInit(QtcStrMap *map)
+ {
+ QTC_RET_IF_FAIL(map && !map->inited && map->items && map->size && map->num);
+ qsort_r(map->items, map->num, map->size,
+- qtcStrMapItemCompare, map);
++ map, qtcStrMapItemCompare);
+ map->inited = true;
+ }
+
diff --git a/x11-themes/qtcurve/files/patch-lib_utils_process.c b/x11-themes/qtcurve/files/patch-lib_utils_process.c
new file mode 100644
index 000000000000..2f13171b77e2
--- /dev/null
+++ b/x11-themes/qtcurve/files/patch-lib_utils_process.c
@@ -0,0 +1,12 @@
+--- lib/utils/process.c.orig 2014-01-25 20:13:54 UTC
++++ lib/utils/process.c
+@@ -23,7 +23,8 @@
+ #include "fd_utils.h"
+ #include "timer.h"
+ #include <unistd.h>
+-#include <wait.h>
++#include <signal.h>
++#include <sys/wait.h>
+ #include <sys/stat.h>
+ #include <sys/socket.h>
+ #include <fcntl.h>
diff --git a/x11-themes/qtcurve/pkg-descr b/x11-themes/qtcurve/pkg-descr
new file mode 100644
index 000000000000..7787d397accd
--- /dev/null
+++ b/x11-themes/qtcurve/pkg-descr
@@ -0,0 +1,3 @@
+QtCurve is a set of widget styles for Qt and GTK+ toolkits.
+
+WWW: https://projects.kde.org/projects/playground/base/qtcurve
diff --git a/x11-themes/qtcurve/pkg-plist.gtk2 b/x11-themes/qtcurve/pkg-plist.gtk2
new file mode 100644
index 000000000000..65332866e6d1
--- /dev/null
+++ b/x11-themes/qtcurve/pkg-plist.gtk2
@@ -0,0 +1,12 @@
+lib/gtk-2.0/%%GTK2_VERSION%%/engines/libqtcurve.so
+lib/libqtcurve-cairo.so
+lib/libqtcurve-cairo.so.0
+lib/libqtcurve-cairo.so.0.1
+share/themes/QtCurve/gtk-2.0/gtkrc
+share/themes/QtCurve/gtk-2.0/icons3
+share/themes/QtCurve/gtk-2.0/icons4
+share/themes/QtCurve/gtk-2.0/kdeglobals
+share/themes/QtCurve/gtk-2.0/map_kde_icons.pl
+share/themes/QtCurve/mozilla/QtCurve-KDEButtonOrder.css
+share/themes/QtCurve/mozilla/QtCurve.css
+share/themes/QtCurve/mozilla/preferences-rev.xml
diff --git a/x11-themes/qtcurve/pkg-plist.kde4 b/x11-themes/qtcurve/pkg-plist.kde4
new file mode 100644
index 000000000000..7273aeb7dab2
--- /dev/null
+++ b/x11-themes/qtcurve/pkg-plist.kde4
@@ -0,0 +1,21 @@
+lib/kde4/kstyle_qtcurve_config.so
+lib/kde4/kwin3_qtcurve.so
+lib/kde4/kwin_qtcurve_config.so
+lib/kde4/plugins/styles/qtcurve.so
+share/apps/QtCurve/Agua.qtcurve
+share/apps/QtCurve/Agua_II.qtcurve
+share/apps/QtCurve/Curve.qtcurve
+share/apps/QtCurve/Flat.qtcurve
+share/apps/QtCurve/Human.qtcurve
+share/apps/QtCurve/Inverted.qtcurve
+share/apps/QtCurve/Klearlooks.qtcurve
+share/apps/QtCurve/Milk.qtcurve
+share/apps/QtCurve/Murrine.qtcurve
+share/apps/QtCurve/Ozone.qtcurve
+share/apps/QtCurve/Plastic.qtcurve
+share/apps/QtCurve/QtCurveui.rc
+share/apps/QtCurve/Silk.qtcurve
+share/apps/color-schemes/QtCurve.colors
+share/apps/color-schemes/QtCurveAgua.colors
+share/apps/kstyle/themes/qtcurve.themerc
+share/apps/kwin/qtcurve.desktop
diff --git a/x11-themes/qtcurve/pkg-plist.utils b/x11-themes/qtcurve/pkg-plist.utils
new file mode 100644
index 000000000000..52ec93dbf5ee
--- /dev/null
+++ b/x11-themes/qtcurve/pkg-plist.utils
@@ -0,0 +1,10 @@
+lib/libqtcurve-utils.so
+lib/libqtcurve-utils.so.1
+lib/libqtcurve-utils.so.1.0
+%%NLS%%share/locale/ko/LC_MESSAGES/qtcurve.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/qtcurve.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/qtcurve.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/qtcurve.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/qtcurve.mo
+%%NLS%%share/locale/zh_HK/LC_MESSAGES/qtcurve.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/qtcurve.mo