aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-04 00:05:24 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-04 00:05:24 +0000
commit1d7d307b023d39e76765fee75813ae37210c2de2 (patch)
tree63b520b427b18eda088cf567dba56c59ac57e116 /x11-themes
parent6de8e0157b05b1d4129cc4a578dc60b109466d27 (diff)
downloadports-1d7d307b023d39e76765fee75813ae37210c2de2.tar.gz
ports-1d7d307b023d39e76765fee75813ae37210c2de2.zip
Notes
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-smooth-engine/Makefile67
-rw-r--r--x11-themes/gtk-smooth-engine/distinfo1
-rw-r--r--x11-themes/gtk-smooth-engine/files/patch-configure28
-rw-r--r--x11-themes/gtk-smooth-engine/files/patch-gtk1_gtk1_patches.c21
-rw-r--r--x11-themes/gtk-smooth-engine/pkg-descr8
-rw-r--r--x11-themes/gtk-smooth-engine/pkg-plist2
6 files changed, 127 insertions, 0 deletions
diff --git a/x11-themes/gtk-smooth-engine/Makefile b/x11-themes/gtk-smooth-engine/Makefile
new file mode 100644
index 000000000000..701ca432f1f2
--- /dev/null
+++ b/x11-themes/gtk-smooth-engine/Makefile
@@ -0,0 +1,67 @@
+# New ports collection makefile for: gtk-smooth-engine
+# Date created: 19 November 2003
+# Whom: Anish Mistry
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk-smooth-engine
+PORTVERSION= 0.5.6
+CATEGORIES= x11-toolkits gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= smooth-engine
+
+MAINTAINER= amistry@am-productions.biz
+COMMENT= Flexible GTK Theme Engine
+
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+USE_GNOME= gnometarget
+WANT_GNOME= yes
+CONFIGURE_ENV= X11BASE="${X11BASE}"
+
+CONFLICTS= gnome-themes-extras-*
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgtk20}!=""
+WITH_GTK2= yes
+.endif
+
+.if ${HAVE_GNOME:Mgtk12}!=""
+WITH_GTK12= yes
+.endif
+
+# if neither gtk is detected automatically pull in gtk2
+.if !defined(WITH_GTK12) && !defined(WITH_GTK2)
+WITH_GTK2= yes
+.endif
+
+.if defined(WITH_GTK2)
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+=--enable-gtk-2
+PLIST_SUB+= GTK2:=""
+.else
+CONFIGURE_ARGS+=--disable-gtk-2
+PLIST_SUB+= GTK2:="@comment "
+.endif
+
+.if defined(WITH_GTK12)
+USE_GNOME+= gtk12
+CONFIGURE_ARGS+=--enable-gtk-1
+PLIST_SUB+= GTK1:=""
+.else
+CONFIGURE_ARGS+=--disable-gtk-1
+PLIST_SUB+= GTK1:="@comment "
+.endif
+
+pre-everything::
+.if !defined(WITH_GTK2)
+ @${ECHO_MSG} "To enable gtk2 support define WITH_GTK2."
+.endif
+
+.if !defined(WITH_GTK12)
+ @${ECHO_MSG} "To enable gtk12 support define WITH_GTK12."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-themes/gtk-smooth-engine/distinfo b/x11-themes/gtk-smooth-engine/distinfo
new file mode 100644
index 000000000000..6665b1559813
--- /dev/null
+++ b/x11-themes/gtk-smooth-engine/distinfo
@@ -0,0 +1 @@
+MD5 (gtk-smooth-engine-0.5.6.tar.gz) = f2d3e1f85652db8e77c725e7b73cff4f
diff --git a/x11-themes/gtk-smooth-engine/files/patch-configure b/x11-themes/gtk-smooth-engine/files/patch-configure
new file mode 100644
index 000000000000..a2843d3b1525
--- /dev/null
+++ b/x11-themes/gtk-smooth-engine/files/patch-configure
@@ -0,0 +1,28 @@
+--- configure.orig Tue Dec 16 17:35:58 2003
++++ configure Sat Jan 3 18:50:45 2004
+@@ -7997,6 +7997,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -8050,7 +8051,7 @@
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $prefix/bin
++for as_dir in $prefix/bin $X11BASE/bin
+ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
+@@ -8101,7 +8102,7 @@
+ ;;
+ *)
+ as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
+-for as_dir in $prefix/bin
++for as_dir in $prefix/bin $X11BASE/bin
+ do
+ IFS=$as_save_IFS
+ test -z "$as_dir" && as_dir=.
diff --git a/x11-themes/gtk-smooth-engine/files/patch-gtk1_gtk1_patches.c b/x11-themes/gtk-smooth-engine/files/patch-gtk1_gtk1_patches.c
new file mode 100644
index 000000000000..2358ab57a5a2
--- /dev/null
+++ b/x11-themes/gtk-smooth-engine/files/patch-gtk1_gtk1_patches.c
@@ -0,0 +1,21 @@
+--- gtk1/gtk1_patches.c.orig Sat Jan 3 18:40:36 2004
++++ gtk1/gtk1_patches.c Sat Jan 3 18:41:07 2004
+@@ -1197,6 +1197,7 @@
+ GtkRange *range;
+ gint slider_width, slider_length, stepper_size, trough_border, stepper_spacing;
+ GdkRectangle range_rect;
++ int size1, size2;
+
+ g_return_if_fail (widget != NULL);
+ g_return_if_fail (GTK_IS_SCROLLBAR (widget));
+@@ -1212,8 +1213,8 @@
+ slider_length = SCROLLBAR_MIN_SLIDER_LENGTH(widget->style);
+ }
+
+- int size1 = (slider_length + stepper_size + stepper_spacing + trough_border) * 2;
+- int size2 = (slider_width + trough_border * 2);
++ size1 = (slider_length + stepper_size + stepper_spacing + trough_border) * 2;
++ size2 = (slider_width + trough_border * 2);
+
+ if (GTK_IS_HSCROLLBAR(widget)) {
+ requisition->width = size1;
diff --git a/x11-themes/gtk-smooth-engine/pkg-descr b/x11-themes/gtk-smooth-engine/pkg-descr
new file mode 100644
index 000000000000..fbb53b110063
--- /dev/null
+++ b/x11-themes/gtk-smooth-engine/pkg-descr
@@ -0,0 +1,8 @@
+This is the Smooth GTK engine, currently it supports GTK2 and GTK1.2, however
+GTK 1.2 support is a bit messier/less reliable then GTK2.
+
+WWW: http://sourceforge.net/projects/smooth-engine/
+
+- Anish Mistry
+amistry@am-productions.biz
+AM Productions http://am-productions.biz
diff --git a/x11-themes/gtk-smooth-engine/pkg-plist b/x11-themes/gtk-smooth-engine/pkg-plist
new file mode 100644
index 000000000000..ed1be4564da4
--- /dev/null
+++ b/x11-themes/gtk-smooth-engine/pkg-plist
@@ -0,0 +1,2 @@
+%%GTK1:%%lib/gtk/themes/engines/libsmooth.so
+%%GTK2:%%lib/gtk-2.0/2.2.0/engines/libsmooth.so