aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 11:46:27 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 11:49:50 +0000
commit5f925921c7fb2282b2673b38a4fafd4545fcbe1d (patch)
tree63128d080547d718cdb5481e075ddf21cb73e706 /x11-themes
parentd27b286dc212485a817f5941964d59a07b00a17a (diff)
downloadports-5f925921c7fb2282b2673b38a4fafd4545fcbe1d.tar.gz
ports-5f925921c7fb2282b2673b38a4fafd4545fcbe1d.zip
x11-themes/gtk-arc-themes: Try to fix build order bug (D29353)
Uncovered while building with devel/samurai but can probably also happen with ninja eventually. samu: job failed: /usr/local/bin/glib-compile-resources --sourcedir=common/gtk-3.0 --target=common/gtk-3.0/gtk-lighter.gresource common/gtk-3.0/gtk-lighter.gresource.xml common/gtk-3.0/gtk-lighter.gresource.xml: Failed to locate checkbox-checked.png http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-04-05_21h03m50s/logs/errors/gtk-arc-themes-20210127.log PR: 254678
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-arc-themes/files/patch-common_gtk-3.0_meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-themes/gtk-arc-themes/files/patch-common_gtk-3.0_meson.build b/x11-themes/gtk-arc-themes/files/patch-common_gtk-3.0_meson.build
new file mode 100644
index 000000000000..0adc3b379d42
--- /dev/null
+++ b/x11-themes/gtk-arc-themes/files/patch-common_gtk-3.0_meson.build
@@ -0,0 +1,28 @@
+Try to fix build order bug
+
+samu: job failed: /usr/local/bin/glib-compile-resources --sourcedir=common/gtk-3.0 --target=common/gtk-3.0/gtk-lighter.gresource common/gtk-3.0/gtk-lighter.gresource.xml
+common/gtk-3.0/gtk-lighter.gresource.xml: Failed to locate checkbox-checked.png
+
+--- common/gtk-3.0/meson.build.orig 2021-04-07 08:43:47 UTC
++++ common/gtk-3.0/meson.build
+@@ -42,8 +42,10 @@ gtk3_asset_names = run_command(
+
+ assets_svg = gtk3_ver / 'assets.svg'
+
++gtk3_assets = []
++gtk3_hidpi_assets = []
+ foreach asset : gtk3_asset_names
+- gtk3_assets = custom_target(
++ gtk3_assets += custom_target(
+ 'gtk3-' + asset,
+ input : assets_svg,
+ output : asset + '.png',
+@@ -58,7 +60,7 @@ foreach asset : gtk3_asset_names
+ build_by_default : true
+ )
+
+- gtk3_hidpi_assets = custom_target(
++ gtk3_hidpi_assets += custom_target(
+ 'gtk3-' + asset + '-hidpi',
+ input : assets_svg,
+ output : asset + '@2.png',