aboutsummaryrefslogtreecommitdiff
path: root/x11-themes
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-11-06 20:28:44 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-11-06 20:28:44 +0000
commita7cf17600b502a9d79f70a1c1690e93e53eda3c5 (patch)
tree7ebd2e4ee477afb2d00b0a71da4b0feb36dd59f1 /x11-themes
parent9ddffc16dbdf2dab52914e23fc681297d13ff501 (diff)
downloadports-a7cf17600b502a9d79f70a1c1690e93e53eda3c5.tar.gz
ports-a7cf17600b502a9d79f70a1c1690e93e53eda3c5.zip
x11-themes/qt5-style-plugins: fix background colour handling
PR: 250235 Submitted by: Marcel Kaiser <mk@nic-nac-project.org> Obtained from: https://aur.tuna.tsinghua.edu.cn/cgit/aur.git/tree/0002-fix-gtk2-background.patch?h=qt5-styleplugins
Notes
Notes: svn path=/head/; revision=554313
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qt5-style-plugins/Makefile2
-rw-r--r--x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.1523
2 files changed, 10 insertions, 15 deletions
diff --git a/x11-themes/qt5-style-plugins/Makefile b/x11-themes/qt5-style-plugins/Makefile
index 14fc90c63c34..976e2659a6a2 100644
--- a/x11-themes/qt5-style-plugins/Makefile
+++ b/x11-themes/qt5-style-plugins/Makefile
@@ -5,7 +5,7 @@ PORTNAME= qt5-style-plugins
DISTVERSIONPREFIX= v
DISTVERSION= 5.0.0-23
DISTVERSIONSUFFIX= -g335dbe
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= x11-themes
DIST_SUBDIR= KDE/Qt/addons
diff --git a/x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.15 b/x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.15
index 2211542ed61c..d0c6e078e997 100644
--- a/x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.15
+++ b/x11-themes/qt5-style-plugins/files/patch-fix_build_against_qt5.15
@@ -6,28 +6,25 @@ Subject: [PATCH] fix build against Qt 5.15
With 0a93db4d82c051164923a10e4382b12de9049b45 ("Unify application
palette handling between QGuiApplication and QApplication")
QApplicationPrivate::setSystemPalette is no longer used and necessary.
----
- src/plugins/styles/gtk2/qgtkstyle.cpp | 2 ++
- src/plugins/styles/gtk2/qgtkstyle_p.cpp | 2 ++
- 2 files changed, 4 insertions(+)
-
-diff --git a/src/plugins/styles/gtk2/qgtkstyle.cpp b/src/plugins/styles/gtk2/qgtkstyle.cpp
-index 36169c9..2544593 100644
---- src/plugins/styles/gtk2/qgtkstyle.cpp
+--- src/plugins/styles/gtk2/qgtkstyle.cpp.orig 2017-03-11 09:23:02 UTC
+++ src/plugins/styles/gtk2/qgtkstyle.cpp
-@@ -440,7 +440,9 @@ void QGtkStyle::polish(QApplication *app)
+@@ -440,7 +440,11 @@ void QGtkStyle::polish(QApplication *app)
// not supported as these should be entirely determined by
// current Gtk settings
if (app->desktopSettingsAware() && d->isThemeAvailable()) {
+#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
QApplicationPrivate::setSystemPalette(standardPalette());
++#else
++ QApplication::setPalette(standardPalette());
+#endif
QApplicationPrivate::setSystemFont(d->getThemeFont());
d->applyCustomPaletteHash();
if (!d->isKDE4Session())
-diff --git a/src/plugins/styles/gtk2/qgtkstyle_p.cpp b/src/plugins/styles/gtk2/qgtkstyle_p.cpp
-index e57b3d8..e71beb0 100644
---- src/plugins/styles/gtk2/qgtkstyle_p.cpp
+ src/plugins/styles/gtk2/qgtkstyle.cpp | 2 ++
+ src/plugins/styles/gtk2/qgtkstyle_p.cpp | 2 ++
+ 2 files changed, 4 insertions(+)
+
+--- src/plugins/styles/gtk2/qgtkstyle_p.cpp.orig 2017-03-11 09:23:02 UTC
+++ src/plugins/styles/gtk2/qgtkstyle_p.cpp
@@ -508,7 +508,9 @@ void QGtkStyleUpdateScheduler::updateTheme()
if (oldTheme != QGtkStylePrivate::getThemeName()) {
@@ -39,5 +36,3 @@ index e57b3d8..e71beb0 100644
QApplication::setPalette(newPalette);
if (!QGtkStylePrivate::instances.isEmpty()) {
QGtkStylePrivate::instances.last()->initGtkWidgets();
---
-2.26.2