aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/efltk
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-10 19:22:49 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-10 19:22:49 +0000
commit52d7cef96cd60836317e25bc878703a674d4df49 (patch)
treed6309ab85373f88eb12b36e403a77372a0e0ea57 /x11-toolkits/efltk
parent2c80031a831d037356dffe178460a597b4562326 (diff)
downloadports-52d7cef96cd60836317e25bc878703a674d4df49.tar.gz
ports-52d7cef96cd60836317e25bc878703a674d4df49.zip
Notes
Diffstat (limited to 'x11-toolkits/efltk')
-rw-r--r--x11-toolkits/efltk/Makefile29
-rw-r--r--x11-toolkits/efltk/files/patch-src-filename_list.cpp19
-rw-r--r--x11-toolkits/efltk/pkg-plist4
3 files changed, 31 insertions, 21 deletions
diff --git a/x11-toolkits/efltk/Makefile b/x11-toolkits/efltk/Makefile
index 72ec94f4f1e3..823169c29eff 100644
--- a/x11-toolkits/efltk/Makefile
+++ b/x11-toolkits/efltk/Makefile
@@ -21,27 +21,26 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
ONLY_FOR_ARCHS= i386
-.if defined(WITHOUT_MYSQL)
-CONFIGURE_ARGS+= --disable-mysql
-.else
-USE_MYSQL= yes
-.endif
-
-USE_GMAKE= yes
-USE_GETTEXT= yes
+USE_XORG= x11 xext
USE_AUTOTOOLS= autoconf213
+USE_GETTEXT= yes
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
- DEBUGFLAG="${CFLAGS} -I${LOCALBASE}/include"
-MAKE_ENV+= LD_LIBRARY_PATH="${WRKSRC}/lib"
-
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" DEBUGFLAG="${CFLAGS}"
+MAKE_ENV= LD_LIBRARY_PATH="${WRKSRC}/lib"
USE_LDCONFIG= yes
-USE_XORG= x11 xext
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800069
-BROKEN= does not build
+.if defined(WITHOUT_MYSQL)
+CONFIGURE_ARGS+=--disable-mysql
+PLIST_SUB+= MYSQL="@comment "
+.else
+USE_MYSQL= yes
+PLIST_SUB+= MYSQL=""
.endif
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/efltk/files/patch-src-filename_list.cpp b/x11-toolkits/efltk/files/patch-src-filename_list.cpp
index c7452a030a6f..e448163c9e54 100644
--- a/x11-toolkits/efltk/files/patch-src-filename_list.cpp
+++ b/x11-toolkits/efltk/files/patch-src-filename_list.cpp
@@ -1,11 +1,22 @@
---- src/core/filename_list.cpp 2010-11-12 00:31:17.000000000 +0100
-+++ src/core/filename_list.cpp 2009-04-22 13:51:38.000000000 +0200
-@@ -59,7 +59,7 @@
+--- src/core/filename_list.cpp.orig 2009-04-22 20:51:38.000000000 +0900
++++ src/core/filename_list.cpp 2011-07-25 20:26:24.000000000 +0900
+@@ -34,6 +34,7 @@
+
+ #include <efltk/filename.h>
+ #include <efltk/Fl_String.h>
++#include <sys/param.h>
+
+ #if !HAVE_SCANDIR
+ extern int fl_scandir(const char *dir, dirent ***namelist,
+@@ -59,7 +60,11 @@
// The vast majority of Unix systems want the sort function to have this
// prototype, most likely so that it can be passed to qsort without any
// changes:
-- return scandir(dir, list, 0, (int(*)(const void*,const void*))sort);
++#if defined(__FreeBSD__) && (__FreeBSD_version >= 900006 || (__FreeBSD_version >= 800501 && __FreeBSD_version < 900000) || (__FreeBSD_version >= 730000 && __FreeBSD_version < 800000))
+ return scandir(dir, list, 0, (int(*)(const dirent **, const dirent **))sort);
++#else
+ return scandir(dir, list, 0, (int(*)(const void*,const void*))sort);
++#endif
#else
// This version is when we define our own scandir (WIN32 and perhaps
// some Unix systems) and apparently on Irix:
diff --git a/x11-toolkits/efltk/pkg-plist b/x11-toolkits/efltk/pkg-plist
index 8d5ece0621c8..efbcd84db940 100644
--- a/x11-toolkits/efltk/pkg-plist
+++ b/x11-toolkits/efltk/pkg-plist
@@ -215,8 +215,8 @@ lib/libefltk_gl.so
lib/libefltk_gl.so.2
lib/libefltk_images.so
lib/libefltk_images.so.2
-lib/libefltk_mysql.so
-lib/libefltk_mysql.so.2
+%%MYSQL%%lib/libefltk_mysql.so
+%%MYSQL%%lib/libefltk_mysql.so.2
lib/libefltk_net.so
lib/libefltk_net.so.2
lib/libefltk_xml.so