aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fl_editor/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2003-02-14 09:18:26 +0000
committerMark Pulford <markp@FreeBSD.org>2003-02-14 09:18:26 +0000
commit1186c9d3255a5a7e7bdf6d4495d7c526e3c62451 (patch)
treed7788d1db4f6968323804f7e5e018d233a47ad0a /x11-toolkits/fl_editor/Makefile
parentaefbd9ef958b7ac531e493709be6b9827105ef12 (diff)
downloadports-1186c9d3255a5a7e7bdf6d4495d7c526e3c62451.tar.gz
ports-1186c9d3255a5a7e7bdf6d4495d7c526e3c62451.zip
Notes
Diffstat (limited to 'x11-toolkits/fl_editor/Makefile')
-rw-r--r--x11-toolkits/fl_editor/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/x11-toolkits/fl_editor/Makefile b/x11-toolkits/fl_editor/Makefile
index e126922a77aa..1e2f7fccfd5d 100644
--- a/x11-toolkits/fl_editor/Makefile
+++ b/x11-toolkits/fl_editor/Makefile
@@ -6,13 +6,10 @@
#
PORTNAME= fl_editor
-PORTVERSION= 0.4
+PORTVERSION= 0.4.5
CATEGORIES= x11-toolkits
-MASTER_SITES= http://www.mysql.com/Downloads/%SUBDIR%/ \
- ftp://mysql.nixc.net/pub/mysql/Downloads/%SUBDIR%/ \
- ftp://sunsite.dk/ftp/mirrors/mysql/Downloads/%SUBDIR%/ \
- ftp://ftp.sunet.se/pub/unix/databases/relational/mysql/Downloads/%SUBDIR%/
-MASTER_SITE_SUBDIR= mysqlgui
+MASTER_SITES= http://robertk.com/source/fl_editor/
+EXTRACT_SUFX= .tgz
MAINTAINER= cyrille.lefevre@laposte.net
@@ -26,8 +23,8 @@ CONFIGURE_ARGS= --enable-shared --with-fltk=${PREFIX}
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
DOC_FILES= documentation/*.html documentation/*.jpg
-DOC_SUBDIR= share/doc/${PKGBASE}
INC1_FILES= Fl_Editor.H Fl_FancyEditor.H Fl_FancyMultiEditor.H \
Fl_MultiEditor.H Fl_ProgressBox.H Fl_StatusPanel.H
INC2_FILES= editengine.h editvars.h lists.h stringsup.h wstring.h
@@ -52,9 +49,9 @@ symlink-lib:
install-doc:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/${DOC_SUBDIR}
+ @${MKDIR} ${DOCSDIR}
.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/${DOC_SUBDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif