aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fltk
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-08-04 20:48:24 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-08-04 20:48:24 +0000
commit2a288980b3dd5b6d018d361fd95b820a4c7c8b12 (patch)
treea6c3fd25c960c996a5be4dfe3931ca2fe02d75cc /x11-toolkits/fltk
parent299d16cc9e360114aa33c26df219ef7863cb0810 (diff)
downloadports-2a288980b3dd5b6d018d361fd95b820a4c7c8b12.tar.gz
ports-2a288980b3dd5b6d018d361fd95b820a4c7c8b12.zip
- Update `x11-toolkits/fltk' to version 1.3.4 (version 1.3.4-1 is available,
but the only difference is fixes for Windows IDE solutions Visual C 2008 and Visual C 2010, so prefer 1.3.4 to avoid dealing with the DISTVERSION) - Move out .so.1-suffixed symlink creation to `post-install' target rather than patching `src/Makefile' since the patch tends to get modified with each update; and drop no longer needed patches that were merged upstream - Define LICENSE_FILE as it is not just a standard boilerplate PR: 220649 (modified) Submitted by: sunpoet
Notes
Notes: svn path=/head/; revision=447379
Diffstat (limited to 'x11-toolkits/fltk')
-rw-r--r--x11-toolkits/fltk/Makefile14
-rw-r--r--x11-toolkits/fltk/distinfo5
-rw-r--r--x11-toolkits/fltk/files/patch-configure17
-rw-r--r--x11-toolkits/fltk/files/patch-src_Fl__Tree__Item.cxx16
-rw-r--r--x11-toolkits/fltk/files/patch-src_Makefile34
-rw-r--r--x11-toolkits/fltk/pkg-plist1
6 files changed, 20 insertions, 67 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index c6edd8265275..d35649d0780e 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fltk
-PORTVERSION= 1.3.3
-PORTREVISION= 5
+PORTVERSION= 1.3.4
CATEGORIES= x11-toolkits
MASTER_SITES= http://fltk.org/pub/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
@@ -12,6 +11,7 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= Cross-platform C++ graphical user interface toolkit
LICENSE= LGPL20
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
@@ -39,9 +39,11 @@ post-patch: .SILENT
${REINPLACE_CMD} -E \
's,(.*)LDFLAGS(.*)LINKSHARED(.*),\1LINKSHARED\2LDFLAGS\3,' \
${WRKSRC}/fluid/Makefile
- ${REINPLACE_CMD} -e '/Fl_XFont_On_Demand/s,class,& FL_EXPORT,' \
- ${WRKSRC}/FL/x.H
- ${REINPLACE_CMD} -e 's,result = 0;,fl_open_display(); &,' \
- ${WRKSRC}/src/Fl_x.cxx
+
+post-install:
+.for x in fltk fltk_forms fltk_gl fltk_images
+ ${LN} -sf lib${x}.so.${PORTVERSION:R} \
+ ${STAGEDIR}${PREFIX}/lib/lib${x}.so.1
+.endfor
.include <bsd.port.mk>
diff --git a/x11-toolkits/fltk/distinfo b/x11-toolkits/fltk/distinfo
index a8bec97da239..e3dad2aa5667 100644
--- a/x11-toolkits/fltk/distinfo
+++ b/x11-toolkits/fltk/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fltk-1.3.3-source.tar.gz) = f8398d98d7221d40e77bc7b19e761adaf2f1ef8bb0c30eceb7beb4f2273d0d97
-SIZE (fltk-1.3.3-source.tar.gz) = 4986376
+TIMESTAMP = 1478880621
+SHA256 (fltk-1.3.4-source.tar.gz) = c8ab01c4e860d53e11d40dc28f98d2fe9c85aaf6dbb5af50fd6e66afec3dc58f
+SIZE (fltk-1.3.4-source.tar.gz) = 5284217
diff --git a/x11-toolkits/fltk/files/patch-configure b/x11-toolkits/fltk/files/patch-configure
index 38502025c303..7b60c0c4e1a9 100644
--- a/x11-toolkits/fltk/files/patch-configure
+++ b/x11-toolkits/fltk/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2011-08-31 09:14:41.000000000 +0200
-+++ configure 2011-08-31 09:14:54.000000000 +0200
-@@ -7362,7 +7362,7 @@
+--- configure.orig 2016-11-11 16:04:30 UTC
++++ configure
+@@ -7408,7 +7408,7 @@ $as_echo "$as_me: WARNING: Ignoring libraries \"$X_PRE
LIBS="$LIBS -lX11 $X_EXTRA_LIBS"
CFLAGS="$CFLAGS $X_CFLAGS"
CXXFLAGS="$CXXFLAGS $X_CFLAGS"
@@ -9,21 +9,20 @@
DSOFLAGS="$X_LIBS $DSOFLAGS"
$as_echo "#define USE_X11 1" >>confdefs.h
-@@ -8137,17 +8137,10 @@
- # Don't use -fforce-mem, -fforce-addr, or -fcaller-saves.
+@@ -8276,16 +8276,9 @@ if test -n "$GCC"; then
# They all seem to make either no difference or enlarge
# the code by a few hundred bytes.
-- #
+ #
- # "-Os" seems to be the best compromise between speed and
- # code size. "-O3" and higher seem to make no effective
- # difference in the speed of the code, but does bloat the
- # library 10+%.
- #
+- #
- if test "x$with_optim" != x; then
+ if test "x$with_optim" != x; then
OPTIM="$with_optim $OPTIM"
- else
-- OPTIM="-Os $OPTIM"
+- OPTIM="-Os $OPTIM"
fi
fi
diff --git a/x11-toolkits/fltk/files/patch-src_Fl__Tree__Item.cxx b/x11-toolkits/fltk/files/patch-src_Fl__Tree__Item.cxx
deleted file mode 100644
index 08a2c4a364a9..000000000000
--- a/x11-toolkits/fltk/files/patch-src_Fl__Tree__Item.cxx
+++ /dev/null
@@ -1,16 +0,0 @@
-------------------------------------------------------------------------
-r10699 | greg.ercolano | 2015-04-13 16:55:27 +0000 (Mon, 13 Apr 2015) | 3 lines
-
-Fix return value test, as pointed out by Albrecht.
-
---- src/Fl_Tree_Item.cxx.orig 2014-09-05 02:59:00 UTC
-+++ src/Fl_Tree_Item.cxx
-@@ -549,7 +549,7 @@ int Fl_Tree_Item::move(Fl_Tree_Item *ite
- } else { // different parent?
- if ( to > to_parent->children() ) // try to prevent a reparent() error
- return -4;
-- if ( from_parent->deparent(from) < 0 ) // deparent self from current parent
-+ if ( from_parent->deparent(from) == NULL ) // deparent self from current parent
- return -5;
- if ( to_parent->reparent(this, to) < 0 ) { // reparent self to new parent at position 'to'
- to_parent->reparent(this, 0); // failed? shouldn't happen, reparent at 0
diff --git a/x11-toolkits/fltk/files/patch-src_Makefile b/x11-toolkits/fltk/files/patch-src_Makefile
deleted file mode 100644
index a546de50137a..000000000000
--- a/x11-toolkits/fltk/files/patch-src_Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/Makefile.orig 2011-08-27 01:18:14.000000000 +0000
-+++ src/Makefile 2011-08-27 01:31:39.000000000 +0000
-@@ -576,6 +576,7 @@
- $(RM) $(DESTDIR)$(libdir)/libfltk.so*;\
- $(INSTALL_LIB) libfltk.so.1.3 $(DESTDIR)$(libdir); \
- $(LN) libfltk.so.1.3 $(DESTDIR)$(libdir)/libfltk.so;\
-+ $(LN) libfltk.so.1.3 $(DESTDIR)$(libdir)/libfltk.so.1;\
- fi
- if test x$(DSONAME) = xlibfltk.sl.1.3; then\
- $(RM) $(DESTDIR)$(libdir)/libfltk.sl*;\
-@@ -607,6 +608,7 @@
- $(RM) $(DESTDIR)$(libdir)/libfltk_forms.so*;\
- $(INSTALL_LIB) libfltk_forms.so.1.3 $(DESTDIR)$(libdir); \
- $(LN) libfltk_forms.so.1.3 $(DESTDIR)$(libdir)/libfltk_forms.so;\
-+ $(LN) libfltk_forms.so.1.3 $(DESTDIR)$(libdir)/libfltk_forms.so.1;\
- fi
- if test x$(FLDSONAME) = xlibfltk_forms.sl.1.3; then\
- $(RM) $(DESTDIR)$(libdir)/libfltk_forms.sl*;\
-@@ -638,6 +640,7 @@
- $(RM) $(DESTDIR)$(libdir)/libfltk_gl.so*;\
- $(INSTALL_LIB) libfltk_gl.so.1.3 $(DESTDIR)$(libdir); \
- $(LN) libfltk_gl.so.1.3 $(DESTDIR)$(libdir)/libfltk_gl.so;\
-+ $(LN) libfltk_gl.so.1.3 $(DESTDIR)$(libdir)/libfltk_gl.so.1;\
- fi
- if test x$(GLDSONAME) = xlibfltk_gl.sl.1.3; then\
- $(RM) $(DESTDIR)$(libdir)/libfltk_gl.sl*;\
-@@ -669,6 +672,7 @@
- $(RM) $(DESTDIR)$(libdir)/libfltk_images.so*;\
- $(INSTALL_LIB) libfltk_images.so.1.3 $(DESTDIR)$(libdir); \
- $(LN) libfltk_images.so.1.3 $(DESTDIR)$(libdir)/libfltk_images.so;\
-+ $(LN) libfltk_images.so.1.3 $(DESTDIR)$(libdir)/libfltk_images.so.1;\
- fi
- if test x$(IMGDSONAME) = xlibfltk_images.sl.1.3; then\
- $(RM) $(DESTDIR)$(libdir)/libfltk_images.sl*;\
diff --git a/x11-toolkits/fltk/pkg-plist b/x11-toolkits/fltk/pkg-plist
index 1aacbd5541c2..ae7e1a61ad66 100644
--- a/x11-toolkits/fltk/pkg-plist
+++ b/x11-toolkits/fltk/pkg-plist
@@ -123,6 +123,7 @@ include/FL/Fl_Window.H
include/FL/Fl_Wizard.H
include/FL/Fl_XBM_Image.H
include/FL/Fl_XPM_Image.H
+include/FL/abi-version.h
include/FL/dirent.h
include/FL/filename.H
include/FL/fl_ask.H