aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fltk
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-11-08 09:11:52 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-11-08 09:11:52 +0000
commit3f57704933aa2079e719d4228be81ae1534ef4dc (patch)
tree9c7f318f9276f2c38d37625bec93c9825face4cc /x11-toolkits/fltk
parent94f55ca5e29f770bc97997f7e5cfec515fa77c21 (diff)
downloadports-3f57704933aa2079e719d4228be81ae1534ef4dc.tar.gz
ports-3f57704933aa2079e719d4228be81ae1534ef4dc.zip
- Update to 1.3.1
Release notes: http://www.fltk.org/articles.php?L1253 Feature safe: yes
Notes
Notes: svn path=/head/; revision=307158
Diffstat (limited to 'x11-toolkits/fltk')
-rw-r--r--x11-toolkits/fltk/Makefile10
-rw-r--r--x11-toolkits/fltk/distinfo4
-rw-r--r--x11-toolkits/fltk/files/patch-FL_Fl_Check_Browser.H8
-rw-r--r--x11-toolkits/fltk/files/patch-src_Fl_x.cxx11
4 files changed, 9 insertions, 24 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index 44af1930bc79..e7b73b4229e9 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: fltk
-# Date created: 11 February 1999
-# Whom: Dima Sivachenko <dima@Chg.RU>
-#
+# Created by: Dima Sivachenko <dima@Chg.RU>
# $FreeBSD$
-#
PORTNAME= fltk
-PORTVERSION= 1.3.0
-PORTREVISION= 2
+PORTVERSION= 1.3.1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_EASYSW}
MASTER_SITE_SUBDIR= fltk/${PORTVERSION}
@@ -22,6 +17,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
USE_LDCONFIG= yes
USE_XORG= xft
USE_GL= gl glu
+USE_GCC= any
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--enable-threads \
--enable-shared \
diff --git a/x11-toolkits/fltk/distinfo b/x11-toolkits/fltk/distinfo
index 23ea5454a456..be0effc710ca 100644
--- a/x11-toolkits/fltk/distinfo
+++ b/x11-toolkits/fltk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fltk-1.3.0-source.tar.gz) = 990676808294cea4cca3de833ad5a5de08073c11b665356d4ecf35d22535b21c
-SIZE (fltk-1.3.0-source.tar.gz) = 4111004
+SHA256 (fltk-1.3.1-source.tar.gz) = 49006c148fad8c31a3a961c74486fb485c7878b9d0d084e597f30e354d7cf549
+SIZE (fltk-1.3.1-source.tar.gz) = 4257291
diff --git a/x11-toolkits/fltk/files/patch-FL_Fl_Check_Browser.H b/x11-toolkits/fltk/files/patch-FL_Fl_Check_Browser.H
index 847ec5345318..51cd967ac17a 100644
--- a/x11-toolkits/fltk/files/patch-FL_Fl_Check_Browser.H
+++ b/x11-toolkits/fltk/files/patch-FL_Fl_Check_Browser.H
@@ -1,10 +1,10 @@
---- FL/Fl_Check_Browser.H.orig 2012-09-11 17:32:07.000000000 +0200
-+++ FL/Fl_Check_Browser.H 2012-09-11 17:33:20.000000000 +0200
-@@ -97,6 +97,7 @@
+--- FL/Fl_Check_Browser.H.orig 2012-11-07 18:19:01.000000000 +0100
++++ FL/Fl_Check_Browser.H 2012-11-07 18:19:16.000000000 +0100
+@@ -88,6 +88,7 @@
Returns how many lines are in the browser. The last line number is equal to
this.
*/
-+#undef nitems // nitems was added as a macro in sys/param.h in r236486
++#undef nitems // nitems was added as a macro in sys/param.h in r236486
int nitems() const { return nitems_; }
/** Returns how many items are currently checked. */
int nchecked() const { return nchecked_; }
diff --git a/x11-toolkits/fltk/files/patch-src_Fl_x.cxx b/x11-toolkits/fltk/files/patch-src_Fl_x.cxx
deleted file mode 100644
index b6946d4ed00d..000000000000
--- a/x11-toolkits/fltk/files/patch-src_Fl_x.cxx
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Fl_x.cxx.orig 2011-11-28 10:52:26.000000000 +0100
-+++ src/Fl_x.cxx 2011-11-28 11:01:42.000000000 +0100
-@@ -1858,7 +1858,7 @@
- prop[1] = 1|2|16; // MWM_FUNC_ALL | MWM_FUNC_RESIZE | MWM_FUNC_MAXIMIZE
- }
-
-- if (w->flags() & Fl_Widget::FORCE_POSITION) {
-+ if (w->force_position()) {
- hints->flags |= USPosition;
- hints->x = w->x();
- hints->y = w->y();