aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox14
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-10-03 12:14:18 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-10-03 12:14:18 +0000
commita4c556a23bfd3ccf6916a93ecca67bd883aa9a17 (patch)
tree559e1c1d26b622ea8e496443b6983285f45e174b /x11-toolkits/fox14
parent8be1420b3fe6ce20e1a79f29d8088375a327d4d3 (diff)
downloadports-a4c556a23bfd3ccf6916a93ecca67bd883aa9a17.tar.gz
ports-a4c556a23bfd3ccf6916a93ecca67bd883aa9a17.zip
Notes
Diffstat (limited to 'x11-toolkits/fox14')
-rw-r--r--x11-toolkits/fox14/Makefile49
-rw-r--r--x11-toolkits/fox14/files/patch-src_FXFile.cpp (renamed from x11-toolkits/fox14/files/patch-src::FXFile.cpp)0
-rw-r--r--x11-toolkits/fox14/files/patch-src_FXGZStream.cpp29
-rw-r--r--x11-toolkits/fox14/files/patch-src_fxpngio.cpp (renamed from x11-toolkits/fox14/files/patch-src-fxpngio.cpp)0
4 files changed, 50 insertions, 28 deletions
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index 38f810c52c57..3c2ca59f8f8c 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fox
-# Date created: 23 Feb 2000
-# Whom: Will Andrews <andrews@technologist.com>
-#
+# Created by: Will Andrews <andrews@technologist.com>
# $FreeBSD$
-#
PORTNAME= fox
PORTVERSION= ${MAJORVER}.${SHVER}
@@ -21,7 +17,7 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
Xft.2:${PORTSDIR}/x11-fonts/libXft
-CONFLICTS= fox-1.6.* fox-1.7.*
+#CONFLICTS= fox-1.6.* fox-1.7.*
LATEST_LINK= fox14
@@ -40,60 +36,57 @@ MAN1= shutterbug.1 reswrap.1
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS= OPTIMIZED_CXXFLAGS "Enable additional optimizations" off \
- CUPS "Enable CUPS support" off \
- DEBUG "Build with DEBUG support" off \
- FOX_APPLICATIONS "Install sample applications" off \
- PROFILING "Build with PROFILING support" off \
- SHM "Enable Shared Memory support" on \
- XFT "Enable Xft support" on
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS CUPS DEBUG APPS PROFILE SHM XFT
+OPTIONS_DEFAULT=SHM XFT
+APPS_DESC= Install sample applications
+SHM_DESC= Shared Memory support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
##
## Additional Options
##
#
-.if defined(WITHOUT_XFT)
-CONFIGURE_ARGS+= --with-xft=no
-.else
+.if ${PORT_OPTIONS:MXFT}
CONFIGURE_ARGS+= --with-xft=yes
CPPFLAGS+= `freetype-config --cflags`
LDFLAGS+= `freetype-config --libs`
+.else
+CONFIGURE_ARGS+= --with-xft=no
.endif
#
-.if defined(WITHOUT_SHM)
-CONFIGURE_ARGS+= --with-xshm=no
-.else
+.if ${PORT_OPTIONS:MSHM}
CONFIGURE_ARGS+= --with-xshm=yes
+.else
+CONFIGURE_ARGS+= --with-xshm=no
.endif
#
-.if defined(WITH_CUPS)
+.if ${PORT_OPTIONS:MCUPS}
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
CONFIGURE_ARGS+= --enable-cups
.else
CONFIGURE_ARGS+= --disable-cups
.endif
#
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --enable-release
.endif
#
-.if defined(WITH_FOX_APPLICATIONS)
+.if ${PORT_OPTIONS:MAPPS}
MAN1+= PathFinder.1 adie.1 calculator.1
PLIST_SUB+= APPS=""
.else
PLIST_SUB+= APPS="@comment "
.endif
#
-.if defined(WITH_OPTIMIZED_CXXFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
# turn distribution-recommended optimization flags back on
CXXFLAGS+= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-pointer -fexpensive-optimizations
.endif
#
-.if defined(WITH_PROFILING)
+.if ${PORT_OPTIONS:MPROFILE}
CONFIGURE_ARGS+= --with-profiling=gprof
.endif
@@ -114,12 +107,12 @@ post-patch:
@${REINPLACE_CMD} -E -e \
's|^(screenshotsdir).*$$|\1=${DOCSDIR}/html|' \
${WRKSRC}/doc/screenshots/Makefile.in
-.if defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS} == ""
@${REINPLACE_CMD} -e \
'/^SUBDIRS/s/ doc//' \
${WRKSRC}/Makefile.in
.endif
-.if !defined(WITH_FOX_APPLICATIONS)
+.if ${PORT_OPTIONS:MAPPS} == ""
@${REINPLACE_CMD} -E -e \
's,^(SUBDIRS.*)adie,\1,; \
s,^(SUBDIRS.*)pathfinder,\1,; \
@@ -127,4 +120,4 @@ post-patch:
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/fox14/files/patch-src::FXFile.cpp b/x11-toolkits/fox14/files/patch-src_FXFile.cpp
index 44f33e7947d7..44f33e7947d7 100644
--- a/x11-toolkits/fox14/files/patch-src::FXFile.cpp
+++ b/x11-toolkits/fox14/files/patch-src_FXFile.cpp
diff --git a/x11-toolkits/fox14/files/patch-src_FXGZStream.cpp b/x11-toolkits/fox14/files/patch-src_FXGZStream.cpp
new file mode 100644
index 000000000000..e267cd54a25f
--- /dev/null
+++ b/x11-toolkits/fox14/files/patch-src_FXGZStream.cpp
@@ -0,0 +1,29 @@
+--- src/FXGZStream.cpp.orig 2012-10-03 10:13:33.000000000 +0200
++++ src/FXGZStream.cpp 2012-10-03 10:15:57.000000000 +0200
+@@ -60,7 +60,7 @@
+ FXASSERT(wrptr<=endptr);
+ if(code==FXStreamOK){
+ m=wrptr-rdptr;
+- n=gzwrite((gzFile*)file,rdptr,m);
++ n=gzwrite((gzFile)file,rdptr,m);
+ if(0<n){
+ m-=n;
+ if(m){memmove(begptr,rdptr+n,m);}
+@@ -85,7 +85,7 @@
+ if(m){memmove(begptr,rdptr,m);}
+ rdptr=begptr;
+ wrptr=begptr+m;
+- n=gzread((gzFile*)file,wrptr,endptr-wrptr);
++ n=gzread((gzFile)file,wrptr,endptr-wrptr);
+ if(0<n){
+ wrptr+=n;
+ }
+@@ -117,7 +117,7 @@
+ FXbool FXGZFileStream::close(){
+ if(dir){
+ if(dir==FXStreamSave) flush();
+- gzclose((gzFile*)file);
++ gzclose((gzFile)file);
+ return FXStream::close();
+ }
+ return FALSE;
diff --git a/x11-toolkits/fox14/files/patch-src-fxpngio.cpp b/x11-toolkits/fox14/files/patch-src_fxpngio.cpp
index b1854671bad9..b1854671bad9 100644
--- a/x11-toolkits/fox14/files/patch-src-fxpngio.cpp
+++ b/x11-toolkits/fox14/files/patch-src_fxpngio.cpp