aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox17
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2016-11-21 03:13:55 +0000
committerJason E. Hale <jhale@FreeBSD.org>2016-11-21 03:13:55 +0000
commit1aa61d1cc9ac525f9cffdddd19512e9ef5ef9349 (patch)
tree99a8420d062a02f568399aec8083f1aa73280da4 /x11-toolkits/fox17
parent6a739f4a9758e8904843ceaa687f91748cfc7f5c (diff)
downloadports-1aa61d1cc9ac525f9cffdddd19512e9ef5ef9349.tar.gz
ports-1aa61d1cc9ac525f9cffdddd19512e9ef5ef9349.zip
Update to 1.7.56
Convert to options helpers Take maintainership
Notes
Notes: svn path=/head/; revision=426685
Diffstat (limited to 'x11-toolkits/fox17')
-rw-r--r--x11-toolkits/fox17/Makefile101
-rw-r--r--x11-toolkits/fox17/distinfo5
-rw-r--r--x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp26
-rw-r--r--x11-toolkits/fox17/files/patch-tests_math.cpp26
-rw-r--r--x11-toolkits/fox17/pkg-plist50
5 files changed, 128 insertions, 80 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index b9b9571fd1ce..46bdc2ddce16 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -2,25 +2,29 @@
# $FreeBSD$
PORTNAME= fox
-PORTVERSION= 1.7.50
-PORTREVISION= 1
+PORTVERSION= 1.7.56
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.fox-toolkit.org/pub/ \
ftp://ftp.fox-toolkit.org/pub/
PKGNAMESUFFIX= ${PORTVERSION:R:S/.//}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jhale@FreeBSD.org
COMMENT= Fast and extensive C++ GUI toolkit (development version)
-USES= libtool pathfix
+LICENSE= LGPL3+
+
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libfontconfig.so:x11-fonts/fontconfig
+
+USES= compiler:c++11-lib libtool pathfix
GNU_CONFIGURE= yes
-USE_GL= glut
-USE_XORG= sm xft
+USE_GL= gl glu
+USE_XORG= ice sm x11 xcursor xext xfixes xft xi xrandr xrender
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-opengl=yes \
--bindir=${PREFIX}/bin/${PORTNAME}-${MAJORVER}
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 -fPIC -DPIC
LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
@@ -31,51 +35,72 @@ DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${MAJORVER}
BROKEN_aarch64= Fails to compile: cannot initialize a parameter of type void * with an lvalue of type long
BROKEN_powerpc= missing __sync_bool_compare_and_swap_8()
-OPTIONS_DEFINE= DOCS JPEG PNG TIFF WEBP
-OPTIONS_DEFAULT= JPEG PNG TIFF WEBP
+OPTIONS_DEFINE= DEBUG DOCS EXAMPLES OPTIMIZED_CFLAGS PROFILE
+OPTIONS_GROUP= IMGFMTS
+OPTIONS_GROUP_IMGFMTS= JPEG OPENJPEG PNG TIFF WEBP
+OPTIONS_DEFAULT= JPEG OPENJPEG PNG TIFF WEBP
+IMGFMTS_DESC= Image formats
-.include <bsd.port.options.mk>
+DEBUG_CONFIGURE_ON= --enable-debug
+DEBUG_CONFIGURE_OFF= --enable-release
-.if ${PORT_OPTIONS:MJPEG}
-USES+= jpeg
-.else
-CONFIGURE_ARGS+=--disable-jpeg
-.endif
+JPEG_USES= jpeg
+JPEG_CONFIGURE_ENABLE= jpeg
-.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= libpng.so:graphics/png
-.else
-CONFIGURE_ARGS+=--disable-png
-.endif
+OPENJPEG_LIB_DEPENDS= libopenjpeg.so:graphics/openjpeg15
+OPENJPEG_CONFIGURE_ENABLE= jp2
-.if ${PORT_OPTIONS:MTIFF}
-LIB_DEPENDS+= libtiff.so:graphics/tiff
-.else
-CONFIGURE_ARGS+=--disable-tiff
-.endif
+PNG_LIB_DEPENDS= libpng.so:graphics/png
+PNG_CONFIGURE_ENABLE= png
+
+PROFILE_CONFIGURE_ON= --with-profiling=gprof
-.if ${PORT_OPTIONS:MWEBP}
-LIB_DEPENDS+= libwebp.so:graphics/webp
-.else
-CONFIGURE_ARGS+=--disable-webp
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_CONFIGURE_ENABLE= tiff
+
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+WEBP_CONFIGURE_ENABLE= webp
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
+CXXFLAGS+= -ffast-math
+. if !${PORT_OPTIONS:MPROFILE}
+CXXFLAGS+= -fomit-frame-pointer
+. endif
+. if ${COMPILER_TYPE} == "gcc"
+CXXFLAGS+= -fexpensive-optimizations -finline-functions
+. endif
.endif
post-patch:
# Rename man pages as in manpage.1 --> manpage-17.1 to avoid
# conflicts with fox14 and fox16
- files=$$(${FIND} ${WRKSRC} -name *.1); \
+ @files=$$(${FIND} ${WRKSRC} -name *.1); \
for f in $$files; do \
- ${MV} $$f `echo $$f | sed -e 's|\.1|-17.1|'`; \
+ ${MV} $$f `${ECHO_CMD} $$f | ${SED} -e 's|\.1|-17.1|'`; \
done;
- ${FIND} ${WRKSRC} -name Makefile.am -o -name Makefile.in | ${XARGS} \
- ${REINPLACE_CMD} -i '' -e '/man_MANS/s|\.1|-17.1|g'
- ${REINPLACE_CMD} -e '/^Libs:/s|$$| -pthread|; s|"||g' ${WRKSRC}/fox17.pc.in
-.if !${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} -e '/^SUBDIRS/s/ doc//' ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in
-.endif
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ '/man_MANS/s|\.1|-17.1|g'
+ @${REINPLACE_CMD} -e '/^Libs:/s|$$| -pthread|; s|"||g' ${WRKSRC}/fox17.pc.in
+# CXXFLAGS safeness
+ @${REINPLACE_CMD} -e \
+ 's|^\(CXXFLAGS=""\)|#\1|; \
+ /CXXFLAGS/s|-O2 ||; \
+ /CXXFLAGS/s|\(-Wuninitialized\).*"|\1"|; \
+ /LDFLAGS/s|-s ||' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+post-patch-EXAMPLES-off:
+ @${REINPLACE_CMD} -e \
+ 's|^\(SUBDIRS.*\)adie|\1|; \
+ s|^\(SUBDIRS.*\)pathfinder|\1|; \
+ s|^\(SUBDIRS.*\)shutterbug|\1|; \
+ s|^\(SUBDIRS.*\)calculator|\1|' \
+ ${WRKSRC}/Makefile.in
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libFOX-${MAJORVER}.so \
${STAGEDIR}${PREFIX}/lib/libCHART-${MAJORVER}.so
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/fox17/distinfo b/x11-toolkits/fox17/distinfo
index 871ef3a18b7a..328ca06adcad 100644
--- a/x11-toolkits/fox17/distinfo
+++ b/x11-toolkits/fox17/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fox-1.7.50.tar.gz) = cdc432807f047b312ab54a778dc898e429dcfecf513fe0d350a7952f523a71df
-SIZE (fox-1.7.50.tar.gz) = 5344223
+TIMESTAMP = 1479576730
+SHA256 (fox-1.7.56.tar.gz) = 41a03ff6a211c584e7547004002a1cfc768cdc32c84a46ec1499a4c345190885
+SIZE (fox-1.7.56.tar.gz) = 5409138
diff --git a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
index 26246af19123..1bb43c1cb2b8 100644
--- a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
+++ b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp
@@ -1,21 +1,11 @@
---- lib/FXAtomic.cpp.orig 2013-07-26 16:35:43.000000000 +0200
-+++ lib/FXAtomic.cpp 2013-08-29 09:24:35.000000000 +0200
-@@ -71,6 +71,9 @@
- #if defined( __INTEL_COMPILER ) && !defined( __ia64__ )
- #undef HAVE_BUILTIN_SYNC
- #endif
-+#if defined(__FreeBSD__) && defined(__amd64__) && __FreeBSD_version < 900000
-+#undef HAVE_BUILTIN_SYNC
-+#endif
- #endif
+--- lib/FXAtomic.cpp.orig 2016-11-19 22:24:23 UTC
++++ lib/FXAtomic.cpp
+@@ -54,7 +54,7 @@
-@@ -393,7 +396,7 @@
- "andl $1, %%eax\n\t" : "=a"(ret) : "D"(ptr), "a"(cmpa), "d"(cmpb), "b"(a), "c"(b) : "memory", "cc");
- return ret;
+ // New __atomic_XXX() builtins are available
+-#if ((__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 7)))
++#if ((__GNUC__ > 4) || ((__GNUC__ == 4) && (__GNUC_MINOR__ >= 7))) || defined(__clang__)
+ #define HAVE_BUILTIN_ATOMIC 1
#endif
--#elif ((defined(__GNUC__) || defined(__INTEL_COMPILER)) && defined(__x86_64__))
-+#elif ((defined(__GNUC__) || defined(__INTEL_COMPILER)) && defined(__x86_64__)) && (!defined(__FreeBSD__) || __FreeBSD_version > 900000)
- register FXbool ret;
- __asm__ __volatile__ ("lock\n\t"
- "cmpxchg16b (%1)\n\t"
+
diff --git a/x11-toolkits/fox17/files/patch-tests_math.cpp b/x11-toolkits/fox17/files/patch-tests_math.cpp
new file mode 100644
index 000000000000..6aa211c84c5f
--- /dev/null
+++ b/x11-toolkits/fox17/files/patch-tests_math.cpp
@@ -0,0 +1,26 @@
+--- tests/math.cpp.orig 2016-01-18 02:25:42 UTC
++++ tests/math.cpp
+@@ -105,7 +105,6 @@ static const char *const names[]={
+ "atanh",
+ "expm1",
+ "exp2",
+- "exp10",
+ "log1p",
+ "log2"
+ };
+@@ -128,7 +127,6 @@ static const DBLFUNS dblfuns[]={
+ {Math::atanh, ::atanh},
+ {Math::expm1, ::expm1},
+ {Math::exp2, ::exp2},
+- {Math::exp10, ::exp10},
+ {Math::log1p, ::log1p},
+ {Math::log2, ::log2},
+ };
+@@ -151,7 +149,6 @@ static const FLTFUNS fltfuns[]={
+ {Math::atanh, ::atanhf},
+ {Math::expm1, ::expm1f},
+ {Math::exp2, ::exp2f},
+- {Math::exp10, ::exp10f},
+ {Math::log1p, ::log1pf},
+ {Math::log2, ::log2f},
+ };
diff --git a/x11-toolkits/fox17/pkg-plist b/x11-toolkits/fox17/pkg-plist
index 5d89ef8b932a..df832ad19f64 100644
--- a/x11-toolkits/fox17/pkg-plist
+++ b/x11-toolkits/fox17/pkg-plist
@@ -1,20 +1,11 @@
-bin/fox-%%MAJORVER%%/Adie.stx
+%%PORTEXAMPLES%%bin/fox-%%MAJORVER%%/Adie.stx
bin/fox-%%MAJORVER%%/ControlPanel
-bin/fox-%%MAJORVER%%/PathFinder
-bin/fox-%%MAJORVER%%/adie
-bin/fox-%%MAJORVER%%/calculator
+%%PORTEXAMPLES%%bin/fox-%%MAJORVER%%/PathFinder
+%%PORTEXAMPLES%%bin/fox-%%MAJORVER%%/adie
+%%PORTEXAMPLES%%bin/fox-%%MAJORVER%%/calculator
bin/fox-%%MAJORVER%%/fox-config
bin/fox-%%MAJORVER%%/reswrap
-bin/fox-%%MAJORVER%%/shutterbug
-libdata/pkgconfig/fox17.pc
-lib/libCHART-%%MAJORVER%%.a
-lib/libCHART-%%MAJORVER%%.so
-lib/libCHART-%%MAJORVER%%.so.0
-lib/libCHART-%%MAJORVER%%.so.0.0.50
-lib/libFOX-%%MAJORVER%%.a
-lib/libFOX-%%MAJORVER%%.so
-lib/libFOX-%%MAJORVER%%.so.0
-lib/libFOX-%%MAJORVER%%.so.0.0.50
+%%PORTEXAMPLES%%bin/fox-%%MAJORVER%%/shutterbug
include/fox-%%MAJORVER%%/FX4Splitter.h
include/fox-%%MAJORVER%%/FX7Segment.h
include/fox-%%MAJORVER%%/FX885910Codec.h
@@ -47,7 +38,6 @@ include/fox-%%MAJORVER%%/FXBitmap.h
include/fox-%%MAJORVER%%/FXBitmapFrame.h
include/fox-%%MAJORVER%%/FXBitmapView.h
include/fox-%%MAJORVER%%/FXButton.h
-include/fox-%%MAJORVER%%/FXCompletion.h
include/fox-%%MAJORVER%%/FXCP1250Codec.h
include/fox-%%MAJORVER%%/FXCP1251Codec.h
include/fox-%%MAJORVER%%/FXCP1252Codec.h
@@ -75,6 +65,7 @@ include/fox-%%MAJORVER%%/FXCP874Codec.h
include/fox-%%MAJORVER%%/FXCURCursor.h
include/fox-%%MAJORVER%%/FXCalendar.h
include/fox-%%MAJORVER%%/FXCalendarView.h
+include/fox-%%MAJORVER%%/FXCallback.h
include/fox-%%MAJORVER%%/FXCanvas.h
include/fox-%%MAJORVER%%/FXCheckButton.h
include/fox-%%MAJORVER%%/FXChoiceBox.h
@@ -87,6 +78,7 @@ include/fox-%%MAJORVER%%/FXColorWell.h
include/fox-%%MAJORVER%%/FXColorWheel.h
include/fox-%%MAJORVER%%/FXColors.h
include/fox-%%MAJORVER%%/FXComboBox.h
+include/fox-%%MAJORVER%%/FXCompletion.h
include/fox-%%MAJORVER%%/FXComplexd.h
include/fox-%%MAJORVER%%/FXComplexf.h
include/fox-%%MAJORVER%%/FXComposeContext.h
@@ -113,6 +105,7 @@ include/fox-%%MAJORVER%%/FXDirDialog.h
include/fox-%%MAJORVER%%/FXDirList.h
include/fox-%%MAJORVER%%/FXDirSelector.h
include/fox-%%MAJORVER%%/FXDirVisitor.h
+include/fox-%%MAJORVER%%/FXDispatcher.h
include/fox-%%MAJORVER%%/FXDockBar.h
include/fox-%%MAJORVER%%/FXDockHandler.h
include/fox-%%MAJORVER%%/FXDockSite.h
@@ -121,11 +114,11 @@ include/fox-%%MAJORVER%%/FXDocument.h
include/fox-%%MAJORVER%%/FXDragCorner.h
include/fox-%%MAJORVER%%/FXDrawable.h
include/fox-%%MAJORVER%%/FXDriveBox.h
+include/fox-%%MAJORVER%%/FXEXEIcon.h
+include/fox-%%MAJORVER%%/FXEXEImage.h
include/fox-%%MAJORVER%%/FXElement.h
include/fox-%%MAJORVER%%/FXEvent.h
include/fox-%%MAJORVER%%/FXException.h
-include/fox-%%MAJORVER%%/FXEXEIcon.h
-include/fox-%%MAJORVER%%/FXEXEImage.h
include/fox-%%MAJORVER%%/FXExpression.h
include/fox-%%MAJORVER%%/FXExtentd.h
include/fox-%%MAJORVER%%/FXExtentf.h
@@ -337,11 +330,14 @@ include/fox-%%MAJORVER%%/FXVerticalFrame.h
include/fox-%%MAJORVER%%/FXVisual.h
include/fox-%%MAJORVER%%/FXWEBPIcon.h
include/fox-%%MAJORVER%%/FXWEBPImage.h
+include/fox-%%MAJORVER%%/FXWSQueue.h
include/fox-%%MAJORVER%%/FXWindow.h
include/fox-%%MAJORVER%%/FXWizard.h
include/fox-%%MAJORVER%%/FXWorker.h
include/fox-%%MAJORVER%%/FXXBMIcon.h
include/fox-%%MAJORVER%%/FXXBMImage.h
+include/fox-%%MAJORVER%%/FXXML.h
+include/fox-%%MAJORVER%%/FXXMLFile.h
include/fox-%%MAJORVER%%/FXXPMIcon.h
include/fox-%%MAJORVER%%/FXXPMImage.h
include/fox-%%MAJORVER%%/FXhalf.h
@@ -359,12 +355,22 @@ include/fox-%%MAJORVER%%/fxcpuid.h
include/fox-%%MAJORVER%%/fxdefs.h
include/fox-%%MAJORVER%%/fxendian.h
include/fox-%%MAJORVER%%/fxkeys.h
+include/fox-%%MAJORVER%%/fxmath.h
include/fox-%%MAJORVER%%/fxunicode.h
include/fox-%%MAJORVER%%/fxver.h
include/fox-%%MAJORVER%%/xincs.h
-man/man1/reswrap-17.1.gz
-man/man1/shutterbug-17.1.gz
-man/man1/adie-17.1.gz
-man/man1/PathFinder-17.1.gz
-man/man1/calculator-17.1.gz
+lib/libCHART-%%MAJORVER%%.a
+lib/libCHART-%%MAJORVER%%.so
+lib/libCHART-%%MAJORVER%%.so.0
+lib/libCHART-%%MAJORVER%%.so.0.0.56
+lib/libFOX-%%MAJORVER%%.a
+lib/libFOX-%%MAJORVER%%.so
+lib/libFOX-%%MAJORVER%%.so.0
+lib/libFOX-%%MAJORVER%%.so.0.0.56
+libdata/pkgconfig/fox17.pc
man/man1/ControlPanel-17.1.gz
+%%PORTEXAMPLES%%man/man1/PathFinder-17.1.gz
+%%PORTEXAMPLES%%man/man1/adie-17.1.gz
+%%PORTEXAMPLES%%man/man1/calculator-17.1.gz
+man/man1/reswrap-17.1.gz
+%%PORTEXAMPLES%%man/man1/shutterbug-17.1.gz