aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/fox17
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-01-08 15:29:32 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-01-08 15:29:32 +0000
commitfe79ac5c426480b67f4a2336177f9674731cef4a (patch)
tree0e4e0fe63cf4c65550c5a02b51c482537b707285 /x11-toolkits/fox17
parent2ca72ca1f7c4e7c6b5c466aa9c0ea0b6ea8b2f27 (diff)
downloadports-fe79ac5c426480b67f4a2336177f9674731cef4a.tar.gz
ports-fe79ac5c426480b67f4a2336177f9674731cef4a.zip
- Update to 1.7.45
* FXJSONFile class added. Base class FXJSON improved and generalized. * FXIO now tracks file position; new implementation of FXIO counts bytes read/written. * FXPipe API's added, should now be functional. * Renamed FXStringMap to FXStringDictionary for consistency. * Fixed a few problems in FXVariantMap, FXDictionary. * Fixed possible race in FXThreadPool::startWorker. * New FXThreadException class added; FXThreadException will cause graceful early termination of a thread when thrown inside of FXThread. * FXThread now interceps only FXException (and subclasses), rethrows other exceptions. This was necessary due to the way GNU C++ library performs thread exits. * Non FOX exceptions thrown inside FXThread are now rethrown; but attempts are made to maintain proper bookkeeping when unrolling the stack. * FXThreadPool tasks may throw exceptions. FXThreadPool now intercepts all FOX exceptions and updates bookkeeping when other exceptions are thrown. Note: tasks in FXThreadPool are executed by threads, but since sometimes the main thread is executing tasks in FXThreadPool also we can not allow tasks to throw FXThreadException. * Exceptions thrown inside FXWorker now terminate the worker, and reclaim worker's thread and memory. Before exceptions were all caught, making it impossible to pass return codes from worker execution. * Exceptions thrown in FXTaskGroup::Task correctly reclaim the FXTaskGroup::Task now, and will update completion count and notifications appropriately. * The exception philosophy in FOX is that the library only manages FXExceptions and their subclasses; other exceptions will be either uncaught or caught and rethrown after bookkeeping updates; thus programs should be careful throwing exceptions other than FXExceptions.
Notes
Notes: svn path=/head/; revision=339150
Diffstat (limited to 'x11-toolkits/fox17')
-rw-r--r--x11-toolkits/fox17/Makefile2
-rw-r--r--x11-toolkits/fox17/distinfo4
-rw-r--r--x11-toolkits/fox17/files/patch-bugs46
-rw-r--r--x11-toolkits/fox17/pkg-plist3
4 files changed, 5 insertions, 50 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 00cb8a465870..d04f572f5405 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fox
-PORTVERSION= 1.7.44
+PORTVERSION= 1.7.45
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.fox-toolkit.org/pub/ \
ftp://ftp.fox-toolkit.org/pub/
diff --git a/x11-toolkits/fox17/distinfo b/x11-toolkits/fox17/distinfo
index e4960cba0bbf..4847846598cc 100644
--- a/x11-toolkits/fox17/distinfo
+++ b/x11-toolkits/fox17/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fox-1.7.44.tar.gz) = 1fbead78847d2a2c6ae8a18a5317713f2ef36d4ebeddacf5d097b915e4728b4c
-SIZE (fox-1.7.44.tar.gz) = 5251615
+SHA256 (fox-1.7.45.tar.gz) = 78f2b5f609a52d21da08e693d45b8eeb9d4ceed52ad86e451ef4485f2375c829
+SIZE (fox-1.7.45.tar.gz) = 5254563
diff --git a/x11-toolkits/fox17/files/patch-bugs b/x11-toolkits/fox17/files/patch-bugs
deleted file mode 100644
index 643f723f1a4d..000000000000
--- a/x11-toolkits/fox17/files/patch-bugs
+++ /dev/null
@@ -1,46 +0,0 @@
---- tests/parallel.cpp.orig 2013-09-18 16:31:08.000000000 +0200
-+++ tests/parallel.cpp 2013-09-18 16:55:25.000000000 +0200
-@@ -146,6 +145,7 @@
- FXuint njobs=0;
- FXuint test=2;
- FXuint wait=0;
-+ char *endptr;
-
- // Grab a few arguments
- for(FXint arg=1; arg<argc; ++arg){
-@@ -155,18 +155,18 @@
- }
- else if(strcmp(argv[arg],"--threads")==0){
- if(++arg>=argc){ fxmessage("Missing threads number argument.\n"); exit(1); }
-- nthreads=strtoul(argv[arg],NULL,0);
-- if(nthreads<0){ fxmessage("Value for threads (%d) too small.\n",nthreads); exit(1); }
-+ nthreads=strtoul(argv[arg],&endptr,0);
-+ if(*endptr!='\0'){ fxmessage("Value for threads (%d) too small.\n",nthreads); exit(1); }
- }
- else if(strcmp(argv[arg],"--minimum")==0){
- if(++arg>=argc){ fxmessage("Missing threads number argument.\n"); exit(1); }
-- minimum=strtoul(argv[arg],NULL,0);
-- if(minimum<0){ fxmessage("Value for minimum number of threads (%d) too small.\n",minimum); exit(1); }
-+ minimum=strtoul(argv[arg],&endptr,0);
-+ if(*endptr!='\0'){ fxmessage("Value for minimum number of threads (%d) too small.\n",minimum); exit(1); }
- }
- else if(strcmp(argv[arg],"--maximum")==0){
- if(++arg>=argc){ fxmessage("Missing threads number argument.\n"); exit(1); }
-- maximum=strtoul(argv[arg],NULL,0);
-- if(maximum<0){ fxmessage("Value for maximum number of threads (%d) too small.\n",minimum); exit(1); }
-+ maximum=strtoul(argv[arg],&endptr,0);
-+ if(*endptr!='\0'){ fxmessage("Value for maximum number of threads (%d) too small.\n",minimum); exit(1); }
- }
- else if(strcmp(argv[arg],"--size")==0){
- if(++arg>=argc){ fxmessage("Missing size argument.\n"); exit(1); }
-@@ -176,8 +176,8 @@
- }
- else if(strcmp(argv[arg],"--jobs")==0){
- if(++arg>=argc){ fxmessage("Missing jobs count argument.\n"); exit(1); }
-- njobs=strtoul(argv[arg],NULL,0);
-- if(njobs<0){ fxmessage("Value for njobs (%d) too small.\n",njobs); exit(1); }
-+ njobs=strtoul(argv[arg],&endptr,0);
-+ if(*endptr!='\0'){ fxmessage("Value for njobs (%d) too small.\n",njobs); exit(1); }
- }
- else if(strcmp(argv[arg],"-W")==0 || strcmp(argv[arg],"--wait")==0){
- wait=1;
diff --git a/x11-toolkits/fox17/pkg-plist b/x11-toolkits/fox17/pkg-plist
index 5ff064e89bfe..2bc57f6f0327 100644
--- a/x11-toolkits/fox17/pkg-plist
+++ b/x11-toolkits/fox17/pkg-plist
@@ -180,6 +180,7 @@ include/fox-%%MAJORVER%%/FXJP2Image.h
include/fox-%%MAJORVER%%/FXJPGIcon.h
include/fox-%%MAJORVER%%/FXJPGImage.h
include/fox-%%MAJORVER%%/FXJSON.h
+include/fox-%%MAJORVER%%/FXJSONFile.h
include/fox-%%MAJORVER%%/FXKOI8RCodec.h
include/fox-%%MAJORVER%%/FXKnob.h
include/fox-%%MAJORVER%%/FXLFQueue.h
@@ -289,7 +290,7 @@ include/fox-%%MAJORVER%%/FXStatusLine.h
include/fox-%%MAJORVER%%/FXStream.h
include/fox-%%MAJORVER%%/FXString.h
include/fox-%%MAJORVER%%/FXStringDict.h
-include/fox-%%MAJORVER%%/FXStringMap.h
+include/fox-%%MAJORVER%%/FXStringDictionary.h
include/fox-%%MAJORVER%%/FXSwitcher.h
include/fox-%%MAJORVER%%/FXSystem.h
include/fox-%%MAJORVER%%/FXTGAIcon.h