aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/girara
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-10-21 09:11:51 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-10-21 09:11:51 +0000
commit72594d6241ee8b312042bf14d70cc90e3f4005b7 (patch)
tree33184dd90bd40d46b69fbfbb7c0b790af7165101 /x11-toolkits/girara
parent9486b299e2c9ba0739f567b327d9712ae3728d59 (diff)
downloadports-72594d6241ee8b312042bf14d70cc90e3f4005b7.tar.gz
ports-72594d6241ee8b312042bf14d70cc90e3f4005b7.zip
Add patch to disable optimizations on a keyboard input function
when using the clang compiler. This allows removing the requirement on gcc. Patch based on suggestion from Ivan <bsd@abinet.ru>. Bug has been reported upstream. PR: 213595 Submitted by: Michael Danilov <mike.d.ft402@gmail.com> MFH: 2016Q4
Notes
Notes: svn path=/head/; revision=424401
Diffstat (limited to 'x11-toolkits/girara')
-rw-r--r--x11-toolkits/girara/Makefile8
-rw-r--r--x11-toolkits/girara/files/patch-girara_callbacks.h19
-rw-r--r--x11-toolkits/girara/files/patch-girara_macros.h15
3 files changed, 36 insertions, 6 deletions
diff --git a/x11-toolkits/girara/Makefile b/x11-toolkits/girara/Makefile
index b13a04b98a09..353ce66b8de6 100644
--- a/x11-toolkits/girara/Makefile
+++ b/x11-toolkits/girara/Makefile
@@ -3,7 +3,7 @@
PORTNAME= girara
PORTVERSION= 0.2.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits graphics
MASTER_SITES= http://pwmt.org/projects/girara/download/
@@ -18,14 +18,10 @@ LIBDIR= ${PREFIX}/lib
MAKE_ENV+= SFLAGS=${STRIP} \
VERBOSE=1
-OPTIONS_DEFINE= GCC NLS
-# Force GCC by default due to problems in dependent port zathura with keyboard
-# input when compiled using clang.
-OPTIONS_DEFAULT=GCC
+OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
NLS_USES= gettext
-GCC_USE= GCC=yes
post-patch: .SILENT
${REINPLACE_CMD} -e 's|$${LIBDIR}/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
diff --git a/x11-toolkits/girara/files/patch-girara_callbacks.h b/x11-toolkits/girara/files/patch-girara_callbacks.h
new file mode 100644
index 000000000000..a85c2d4339a7
--- /dev/null
+++ b/x11-toolkits/girara/files/patch-girara_callbacks.h
@@ -0,0 +1,19 @@
+--- girara/callbacks.h.orig 2016-04-18 20:35:34 UTC
++++ girara/callbacks.h
+@@ -4,6 +4,7 @@
+ #define GIRARA_CALLBACKS_H
+
+ #include "types.h"
++#include "macros.h"
+ #include <gtk/gtk.h>
+
+ /**
+@@ -108,7 +109,7 @@ bool girara_callback_inputbar_activate(G
+ * @return FALSE An error occurred
+ */
+ bool girara_callback_inputbar_key_press_event(GtkWidget* widget,
+- GdkEventKey* event, girara_session_t* session);
++ GdkEventKey* event, girara_session_t* session) GIRARA_OPTNONE;
+
+ /**
+ * Default callback if the text of the input bar has changed
diff --git a/x11-toolkits/girara/files/patch-girara_macros.h b/x11-toolkits/girara/files/patch-girara_macros.h
new file mode 100644
index 000000000000..67114da5a086
--- /dev/null
+++ b/x11-toolkits/girara/files/patch-girara_macros.h
@@ -0,0 +1,15 @@
+--- girara/macros.h.orig 2015-04-13 20:49:26 UTC
++++ girara/macros.h
+@@ -69,4 +69,12 @@
+ GIRARA_DO_PRAGMA(GCC diagnostic pop)
+ #endif
+
++#ifndef GIRARA_OPTNONE
++# if defined(__clang__)
++# define GIRARA_OPTNONE __attribute__ ((optnone))
++# else
++# define GIRARA_OPTNONE
++# endif
++#endif
++
+ #endif