aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gnocl/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-07-09 06:38:56 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-07-09 06:38:56 +0000
commita9572e2f705f7fc400181ef093ce25d0cbc2ca3b (patch)
treef067ab059265cb9d296a2f4d013a35e871820714 /x11-toolkits/gnocl/Makefile
parenta9a0dd08bda8d3bfb7e0768d8a0281b98de1a794 (diff)
downloadports-a9572e2f705f7fc400181ef093ce25d0cbc2ca3b.tar.gz
ports-a9572e2f705f7fc400181ef093ce25d0cbc2ca3b.zip
Notes
Diffstat (limited to 'x11-toolkits/gnocl/Makefile')
-rw-r--r--x11-toolkits/gnocl/Makefile39
1 files changed, 17 insertions, 22 deletions
diff --git a/x11-toolkits/gnocl/Makefile b/x11-toolkits/gnocl/Makefile
index 1ae8f7dac6c8..2847bd77f064 100644
--- a/x11-toolkits/gnocl/Makefile
+++ b/x11-toolkits/gnocl/Makefile
@@ -6,29 +6,26 @@
#
PORTNAME= gnocl
-PORTVERSION= 0.9.91
-PORTREVISION= 4
+PORTVERSION= 0.9.94
CATEGORIES= x11-toolkits devel
MASTER_SITES= SF/gnocl
+DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= GTK+ and Gnome extension for Tcl
USE_GMAKE= yes
-USE_BZIP2= yes
-USE_GNOME= gtk20
+USE_ZIP= yes
+USE_GNOME= gtk20 libglade2 gtksourceview2 gtkhtml3
USE_TCL= 84
USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/src
CFLAGS+= -I${LOCALBASE}/include/tcl8.4
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
-BROKEN= Does not compile on sparc64 or ia64
-.endif
-
.if ${ARCH} == amd64
CFLAGS+= -fPIC
.endif
@@ -44,12 +41,6 @@ GNOCL_CANVAS_FILE= "@comment "
USE_GNOME+= libgnomecanvas
.endif
-.if defined(WITHOUT_GCONF)
-GNOCL_GCONF_FILE= "@comment "
-.else
-USE_GNOME+= gconf2
-.endif
-
.if defined(WITHOUT_GNOME)
GNOCL_GNOME_FILE= "@comment "
.else
@@ -67,18 +58,22 @@ PLIST_SUB+= GNOCL_GCONF_FILE=${GNOCL_GCONF_FILE}
PLIST_SUB+= GNOCL_GNOME_FILE=${GNOCL_GNOME_FILE}
PLIST_SUB+= GNOCL_VFS_FILE=${GNOCL_VFS_FILE}
+post-extract:
+ ${FIND} ${WRKSRC} -name "*.o" -delete
+ ${RMDIR} ${WRKSRC}/doc/html # Remove empty/stale directory
+
post-patch:
-.if defined(WITHOUT_CANVAS)
- ${REINPLACE_CMD} -e 's=^USE_CANVAS=#USE_CANVAS=' ${BUILD_WRKSRC}/Makefile
+.if !defined(WITHOUT_CANVAS)
+ ${REINPLACE_CMD} -e 's=^#USE_CANVAS=USE_CANVAS=' ${BUILD_WRKSRC}/Makefile
.endif
-.if defined(WITHOUT_GCONF)
- ${REINPLACE_CMD} -e 's=^USE_GCONF=#USE_GCONF=' ${BUILD_WRKSRC}/Makefile
+.if !defined(WITHOUT_GCONF)
+ ${REINPLACE_CMD} -e 's=^#USE_GCONF=USE_GCONF=' ${BUILD_WRKSRC}/Makefile
.endif
-.if defined(WITHOUT_GNOME)
- ${REINPLACE_CMD} -e 's=^USE_GNOME=#USE_GNOME=' ${BUILD_WRKSRC}/Makefile
+.if !defined(WITHOUT_GNOME)
+ ${REINPLACE_CMD} -e 's=^#USE_GNOME=USE_GNOME=' ${BUILD_WRKSRC}/Makefile
.endif
-.if defined(WITHOUT_GNOMEVFS2)
- ${REINPLACE_CMD} -e 's=^USE_VFS=#USE_VFS=' ${BUILD_WRKSRC}/Makefile
+.if !defined(WITHOUT_GNOMEVFS2)
+ ${REINPLACE_CMD} -e 's=^#USE_VFS=USE_VFS=' ${BUILD_WRKSRC}/Makefile
.endif
${FIND} ${WRKSRC}/demos -name "*.tcl" | ${XARGS} \
${REINPLACE_CMD} -i "" -e 's|tclsh|${TCLSH}|g; \