aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gob
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2000-01-25 11:13:57 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2000-01-25 11:13:57 +0000
commit31294ef072a80be517c5761069ea5f03a29fc672 (patch)
tree2b38868a71bc3baf94710c881e24c9a112af9d8d /x11-toolkits/gob
parent8510f5bd96a98755e024c4630a6f6d42eecc25df (diff)
downloadports-31294ef072a80be517c5761069ea5f03a29fc672.tar.gz
ports-31294ef072a80be517c5761069ea5f03a29fc672.zip
Notes
Diffstat (limited to 'x11-toolkits/gob')
-rw-r--r--x11-toolkits/gob/Makefile29
-rw-r--r--x11-toolkits/gob/distinfo1
-rw-r--r--x11-toolkits/gob/pkg-comment1
-rw-r--r--x11-toolkits/gob/pkg-descr3
-rw-r--r--x11-toolkits/gob/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/x11-toolkits/gob/Makefile b/x11-toolkits/gob/Makefile
new file mode 100644
index 000000000000..5c58d35cfadf
--- /dev/null
+++ b/x11-toolkits/gob/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: GTK+ Object Builder
+# Version required: 0.92.2
+# Date created: 25 January 2000
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= gob-0.92.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://ftp.5z.com/pub/gob/
+
+MAINTAINER= nakai@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= gob.1
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/gob/distinfo b/x11-toolkits/gob/distinfo
new file mode 100644
index 000000000000..64c1edef69db
--- /dev/null
+++ b/x11-toolkits/gob/distinfo
@@ -0,0 +1 @@
+MD5 (gob-0.92.2.tar.gz) = cdf63c37169f15403439887b3c75df20
diff --git a/x11-toolkits/gob/pkg-comment b/x11-toolkits/gob/pkg-comment
new file mode 100644
index 000000000000..ab4a06927153
--- /dev/null
+++ b/x11-toolkits/gob/pkg-comment
@@ -0,0 +1 @@
+a preprocessor for making GTK+ objects with inline C
diff --git a/x11-toolkits/gob/pkg-descr b/x11-toolkits/gob/pkg-descr
new file mode 100644
index 000000000000..c8d116e9e691
--- /dev/null
+++ b/x11-toolkits/gob/pkg-descr
@@ -0,0 +1,3 @@
+a preprocessor for making GTK+ objects with inline C
+
+WWW: http://www.5z.com/jirka/gob.html
diff --git a/x11-toolkits/gob/pkg-plist b/x11-toolkits/gob/pkg-plist
new file mode 100644
index 000000000000..1ee7181a89e1
--- /dev/null
+++ b/x11-toolkits/gob/pkg-plist
@@ -0,0 +1 @@
+bin/gob