aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/granite
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-12-02 18:27:47 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-12-02 18:27:47 +0000
commit74177528a0a3894cf4b4dc89285fb68ad93550d9 (patch)
treeecc44d719a5c6f525524d53dece93da2a44ca5d0 /x11-toolkits/granite
parent1e8d4af36ba0277469826a7d7520935f2803d764 (diff)
downloadports-74177528a0a3894cf4b4dc89285fb68ad93550d9.tar.gz
ports-74177528a0a3894cf4b4dc89285fb68ad93550d9.zip
Update to 0.3.0
Notes
Notes: svn path=/head/; revision=373776
Diffstat (limited to 'x11-toolkits/granite')
-rw-r--r--x11-toolkits/granite/Makefile19
-rw-r--r--x11-toolkits/granite/distinfo4
-rw-r--r--x11-toolkits/granite/files/patch-CMakeLists.txt62
-rw-r--r--x11-toolkits/granite/files/patch-cmake__FindGObjectIntrospection.cmake21
-rw-r--r--x11-toolkits/granite/files/patch-lib__CMakeLists.txt26
-rw-r--r--x11-toolkits/granite/files/patch-lib__Widgets__AboutDialog.vala29
-rw-r--r--x11-toolkits/granite/files/patch-lib__granite.pc.cmake9
-rw-r--r--x11-toolkits/granite/pkg-plist23
8 files changed, 65 insertions, 128 deletions
diff --git a/x11-toolkits/granite/Makefile b/x11-toolkits/granite/Makefile
index fa4479cb158a..49a18c5767e7 100644
--- a/x11-toolkits/granite/Makefile
+++ b/x11-toolkits/granite/Makefile
@@ -3,32 +3,25 @@
#
PORTNAME= granite
-PORTVERSION= 0.2.3.1
-PORTREVISION= 2
+PORTVERSION= 0.3.0
CATEGORIES= x11-toolkits
-MASTER_SITES= https://launchpadlibrarian.net/169958088/ \
- https://launchpad.net/${PORTNAME}/0.2/${PORTVERSION}/+download/
-DIST_SUBDIR= eos
+MASTER_SITES= https://launchpadlibrarian.net/176306383/ \
+ https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION:R}/+download/
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Extensions of Gtk+ toolkit
-LICENSE= GPLv3
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
LIB_DEPENDS= libgee-0.8.so:${PORTSDIR}/devel/libgee
RUN_DEPENDS= contractor:${PORTSDIR}/sysutils/contractor
USE_GCC= yes
-USES= cmake pkgconfig gettext tar:tgz
+USES= cmake pkgconfig gettext
USE_GNOME= glib20 gtk30 introspection:build
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|gee-1.0|gee-0.8|' ${WRKSRC}/lib/granite.deps
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgranite.so
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/granite/distinfo b/x11-toolkits/granite/distinfo
index efc437e89001..f98291902ed0 100644
--- a/x11-toolkits/granite/distinfo
+++ b/x11-toolkits/granite/distinfo
@@ -1,2 +1,2 @@
-SHA256 (eos/granite-0.2.3.1.tgz) = 56f05338bb7967f0b912d35bf780a3ddd68b517e1939371a14a5f79581a8f80d
-SIZE (eos/granite-0.2.3.1.tgz) = 152607
+SHA256 (granite-0.3.0.tar.gz) = df950dd79749213971d50316c68edadf1fb3c2151cb7d63f6a6b9edf12084ad1
+SIZE (granite-0.3.0.tar.gz) = 285072
diff --git a/x11-toolkits/granite/files/patch-CMakeLists.txt b/x11-toolkits/granite/files/patch-CMakeLists.txt
index f85add1cbcbf..537833e3e603 100644
--- a/x11-toolkits/granite/files/patch-CMakeLists.txt
+++ b/x11-toolkits/granite/files/patch-CMakeLists.txt
@@ -1,57 +1,6 @@
---- ./CMakeLists.txt.orig 2014-03-18 20:51:49.000000000 +0000
-+++ ./CMakeLists.txt 2014-05-29 09:36:44.000000000 +0000
-@@ -24,12 +24,28 @@
- include (CPack)
- add_custom_target (dist COMMAND ${CMAKE_MAKE_PROGRAM} package_source)
-
-+find_package (PkgConfig)
- find_package (Vala REQUIRED)
- include (ValaVersion)
- include (ValaPrecompile)
-
- ensure_vala_version ("0.20.1" MINIMUM)
-
-+message ("-- Checking for libgee...")
-+# libgee <= 0.6
-+pkg_check_modules (GEE_10 gee-1.0)
-+if (GEE_10_FOUND)
-+ set (GEE_PACKAGE gee-1.0)
-+ set (GEE_GIR Gee-1.0)
-+else ()
-+ # libgee >= 0.8
-+ pkg_check_modules (GEE_08 gee-0.8)
-+ if (GEE_08_FOUND)
-+ set (GEE_PACKAGE gee-0.8)
-+ set (GEE_GIR Gee-0.8)
-+ endif ()
-+endif ()
-+
- #
- # Packages in PKG_DEPS are used with the vala compiler and other related tools (not versioned.)
- # Packages in PKG_DEPS_CHECK are used with PKG-Config and for linking, etc. They can contain versions.
-@@ -42,31 +58,37 @@
- gtk+-3.0
- gio-unix-2.0
- posix
-- gee-1.0)
-+ ${GEE_PACKAGE})
-
- set (PKG_DEPS_CHECK
- gtk+-3.0>=3.3.14
- gio-unix-2.0
- gthread-2.0
-- gee-1.0)
-+ ${GEE_PACKAGE})
-
- # GI dependencies
--set (GI_PKG_DEPS Gtk-3.0 Gee-1.0)
-+set (GI_PKG_DEPS Gtk-3.0 ${GEE_GIR})
-
- # Check for the deps
--find_package (PkgConfig)
- pkg_check_modules (DEPS REQUIRED ${PKG_DEPS_CHECK})
-
- set (VALAC_OPTIONS
+--- ./CMakeLists.txt.orig 2014-05-25 19:42:24.000000000 +0000
++++ ./CMakeLists.txt 2014-07-27 10:49:39.000000000 +0000
+@@ -61,12 +61,18 @@
--thread
--target-glib=2.32)
@@ -71,6 +20,7 @@
add_subdirectory (lib)
-add_subdirectory (demo)
-add_subdirectory (doc)
-+#add_subdirectory (doc)
add_subdirectory (po)
- add_subdirectory (icons)
+-add_subdirectory (icons)
+\ No newline at end of file
++add_subdirectory (icons)
diff --git a/x11-toolkits/granite/files/patch-cmake__FindGObjectIntrospection.cmake b/x11-toolkits/granite/files/patch-cmake__FindGObjectIntrospection.cmake
deleted file mode 100644
index 3dae38e5addd..000000000000
--- a/x11-toolkits/granite/files/patch-cmake__FindGObjectIntrospection.cmake
+++ /dev/null
@@ -1,21 +0,0 @@
---- ./cmake/FindGObjectIntrospection.cmake.orig 2013-08-10 02:01:58.000000000 +0000
-+++ ./cmake/FindGObjectIntrospection.cmake 2013-09-28 15:03:47.000000000 +0000
-@@ -50,6 +50,18 @@
- endif()
- endif()
-
-+if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
-+ string (REPLACE "/usr/local"
-+ ${CMAKE_INSTALL_PREFIX} GIR_DIR ${INTROSPECTION_GIRDIR})
-+ unset (INTROSPECTION_GIRDIR)
-+ set (INTROSPECTION_GIRDIR ${GIR_DIR})
-+
-+ string (REPLACE "/usr/local"
-+ ${CMAKE_INSTALL_PREFIX} TYPELIB_DIR ${INTROSPECTION_TYPELIBDIR})
-+ unset (INTROSPECTION_TYPELIBDIR)
-+ set (INTROSPECTION_TYPELIBDIR ${TYPELIB_DIR})
-+endif ()
-+
- mark_as_advanced(
- INTROSPECTION_SCANNER
- INTROSPECTION_COMPILER
diff --git a/x11-toolkits/granite/files/patch-lib__CMakeLists.txt b/x11-toolkits/granite/files/patch-lib__CMakeLists.txt
index fd7137421488..6ed97ecc9e7f 100644
--- a/x11-toolkits/granite/files/patch-lib__CMakeLists.txt
+++ b/x11-toolkits/granite/files/patch-lib__CMakeLists.txt
@@ -1,16 +1,22 @@
---- ./lib/CMakeLists.txt.orig 2013-12-15 12:43:00.000000000 +0000
-+++ ./lib/CMakeLists.txt 2014-02-11 21:08:46.000000000 +0000
-@@ -64,7 +64,12 @@
- if(NOT DEFINED LIB_INSTALL_DIR)
- set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib")
- endif()
--install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
-+
-+if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
+--- ./lib/CMakeLists.txt.orig 2014-05-25 19:42:24.000000000 +0000
++++ ./lib/CMakeLists.txt 2014-07-27 11:00:15.000000000 +0000
+@@ -62,7 +62,11 @@
+ configure_file (${CMAKE_CURRENT_SOURCE_DIR}/${PKG_NAME}.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc)
+
+ include (GNUInstallDirs)
+-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig)
++if (${CMAKE_SYSTEM_NAME} MATCHES "DragonFly" OR ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig)
+else ()
-+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
++ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${CMAKE_INSTALL_FULL_LIBDIR}/pkgconfig)
+endif ()
# Link all
set (CFLAGS ${DEPS_CFLAGS} ${DEPS_CFLAGS_OTHER})
+@@ -114,4 +118,4 @@
+ if (INTROSPECTION_FOUND)
+ include (GObjectIntrospectionMacros)
+ add_target_gir (${PKG_NAME} ${PKG_GIR_NAME} ${PKG_NAME}.h "${VALA_C}" "${DEPS_CFLAGS}" ${API_VERSION} ${GI_PKG_DEPS})
+-endif ()
+\ No newline at end of file
++endif ()
diff --git a/x11-toolkits/granite/files/patch-lib__Widgets__AboutDialog.vala b/x11-toolkits/granite/files/patch-lib__Widgets__AboutDialog.vala
new file mode 100644
index 000000000000..1966dfcc0da7
--- /dev/null
+++ b/x11-toolkits/granite/files/patch-lib__Widgets__AboutDialog.vala
@@ -0,0 +1,29 @@
+--- ./lib/Widgets/AboutDialog.vala.orig 2014-05-25 19:42:24.000000000 +0000
++++ ./lib/Widgets/AboutDialog.vala 2014-07-27 13:06:32.000000000 +0000
+@@ -65,7 +65,7 @@
+
+ private Button help_button;
+ private Button translate_button;
+- private Button bug_button;
++ private LinkButton bug_button;
+
+ private Granite.Drawing.BufferSurface buffer;
+
+@@ -128,15 +128,8 @@
+ action_area.pack_start (translate_button, false, false, 0);
+
+ /* bug button */
+- bug_button = new Button.with_label (_("Report a Problem"));
+- bug_button.clicked.connect (() => {
+- try {
+- GLib.Process.spawn_command_line_async ("apport-bug %i".printf (Posix.getpid ()));
+- } catch (Error e) {
+- warning ("Could Not Launch 'apport-bug'.");
+- activate_link (bug);
+- }
+- });
++ string _uri = "https://bugs.freebsd.org/bugzilla/enter_bug.cgi";
++ bug_button = new LinkButton.with_label (_uri, _("Report a Problem"));
+ action_area.pack_start (bug_button, false, false, 0);
+
+ action_area.reorder_child (bug_button, 0);
diff --git a/x11-toolkits/granite/files/patch-lib__granite.pc.cmake b/x11-toolkits/granite/files/patch-lib__granite.pc.cmake
deleted file mode 100644
index b15a9bf885f4..000000000000
--- a/x11-toolkits/granite/files/patch-lib__granite.pc.cmake
+++ /dev/null
@@ -1,9 +0,0 @@
---- ./lib/granite.pc.cmake.orig 2013-08-10 02:01:58.000000000 +0000
-+++ ./lib/granite.pc.cmake 2013-11-20 23:13:44.000000000 +0000
-@@ -8,5 +8,5 @@
- Version: @PKG_VERSION@
- Libs: -L@DOLLAR@{libdir} -l@PKG_NAME@
- Cflags: -I@DOLLAR@{includedir}/@PKG_NAME@
--Requires: cairo gee-1.0 glib-2.0 gio-unix-2.0 gobject-2.0 gthread-2.0 gdk-3.0 gdk-pixbuf-2.0 gtk+-3.0
-+Requires: cairo @GEE_PACKAGE@ glib-2.0 gio-unix-2.0 gobject-2.0 gthread-2.0 gdk-3.0 gdk-pixbuf-2.0 gtk+-3.0
-
diff --git a/x11-toolkits/granite/pkg-plist b/x11-toolkits/granite/pkg-plist
index 11b9e0b3f979..1e14b22cca97 100644
--- a/x11-toolkits/granite/pkg-plist
+++ b/x11-toolkits/granite/pkg-plist
@@ -2,13 +2,15 @@ include/granite/granite.h
include/granite/widgets-utils.h
lib/girepository-1.0/Granite-1.0.typelib
lib/libgranite.so
-lib/libgranite.so.1
-lib/libgranite.so.1.0.1
+lib/libgranite.so.2
+lib/libgranite.so.2.0.1
libdata/pkgconfig/granite.pc
share/gir-1.0/Granite-1.0.gir
share/icons/hicolor/16x16/actions/application-menu.svg
+share/icons/hicolor/16x16/actions/appointment.svg
share/icons/hicolor/22x22/actions/application-menu.svg
share/icons/hicolor/24x24/actions/application-menu.svg
+share/icons/hicolor/24x24/actions/appointment.svg
share/icons/hicolor/32x32/actions/application-menu.svg
share/icons/hicolor/48x48/actions/application-menu.svg
share/icons/hicolor/scalable/actions/application-menu-symbolic.svg
@@ -60,8 +62,10 @@ share/locale/rue/LC_MESSAGES/granite.mo
share/locale/sk/LC_MESSAGES/granite.mo
share/locale/sl/LC_MESSAGES/granite.mo
share/locale/sma/LC_MESSAGES/granite.mo
+share/locale/sq/LC_MESSAGES/granite.mo
share/locale/sr/LC_MESSAGES/granite.mo
share/locale/sv/LC_MESSAGES/granite.mo
+share/locale/ta/LC_MESSAGES/granite.mo
share/locale/te/LC_MESSAGES/granite.mo
share/locale/tr/LC_MESSAGES/granite.mo
share/locale/ug/LC_MESSAGES/granite.mo
@@ -71,18 +75,3 @@ share/locale/zh_CN/LC_MESSAGES/granite.mo
share/locale/zh_TW/LC_MESSAGES/granite.mo
share/vala/vapi/granite.deps
share/vala/vapi/granite.vapi
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/sma/LC_MESSAGES
-@dirrmtry share/locale/sma
-@dirrmtry share/locale/rue/LC_MESSAGES
-@dirrmtry share/locale/rue
-@dirrmtry share/locale/lb/LC_MESSAGES
-@dirrmtry share/locale/lb
-@dirrmtry share/locale/fy/LC_MESSAGES
-@dirrmtry share/locale/fy
-@dirrmtry share/locale/fr_CA/LC_MESSAGES
-@dirrmtry share/locale/fr_CA
-@dirrm include/granite