aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-12-30 21:09:09 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-12-30 21:09:09 +0000
commit162e3f2bcb2c01b7c3e8d7699a73b1a11cc5f157 (patch)
tree33e4dcce1f4db88ec67269a1007c97e61e0dcafb /x11-toolkits/gtk30/Makefile
parentb703cedd67c6f252982eddff094dddcb2bf085cb (diff)
downloadports-162e3f2bcb2c01b7c3e8d7699a73b1a11cc5f157.tar.gz
ports-162e3f2bcb2c01b7c3e8d7699a73b1a11cc5f157.zip
Update to 3.8.8.
Stagify, sort USES, use new lib_depend syntax. Use USE_GNOME introspection now that it doesn't break the build. Switch to to libtool less ltverhack. Use new gtk-query-immodules --update-cache functionality. Obtained from: GNOME devel repo (based on)
Notes
Notes: svn path=/head/; revision=338170
Diffstat (limited to 'x11-toolkits/gtk30/Makefile')
-rw-r--r--x11-toolkits/gtk30/Makefile46
1 files changed, 24 insertions, 22 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index ab40146b70c5..c6ea24bc0b6b 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -3,8 +3,8 @@
# $MCom: ports/trunk/x11-toolkits/gtk30/Makefile 18610 2013-06-30 16:33:05Z marcus $
PORTNAME= gtk
-PORTVERSION= 3.8.2
-PORTREVISION?= 1
+PORTVERSION= 3.8.8
+PORTREVISION?= 0
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -19,42 +19,41 @@ LICENSE= LGPL20
USE_XZ= yes
-.if !defined(REFERENCE_PORT)
+.if defined(REFERENCE_PORT)
+PORTSCOUT= ignore:1
+.else
+PORTSCOUT= limit:1,even
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/atk-bridge-2.0.pc:${PORTSDIR}/accessibility/at-spi2-atk
-BUILD_DEPENDS+= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
${LOCALBASE}/libdata/pkgconfig/atk-bridge-2.0.pc:${PORTSDIR}/accessibility/at-spi2-atk
-MAKE_JOBS_UNSAFE= yes
-USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
-USE_GNOME= atk pango gdkpixbuf2 ltverhack gtk-update-icon-cache
-# introspection:build
-USES= gettext gmake pathfix pkgconfig perl5
USE_PERL5= build
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_GNOME= atk pango gdkpixbuf2 ltverhack gtk-update-icon-cache \
+ introspection:build
+USES= gettext gmake pathfix perl5 pkgconfig
USE_XORG= xext xrender x11 xinerama xi xrandr xcursor xfixes xdamage \
xcomposite
CONFIGURE_ARGS= --enable-gtk2-dependency --disable-packagekit
CPPFLAGS+= -I${LOCALBASE}/include -fno-omit-frame-pointer
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= INTROSPECTION_GIRDIR=`pkg-config --variable=girdir gobject-introspection-1.0`
+ltverhack_PATCH_FILES=build-aux/ltmain.sh
GLIB_SCHEMAS= org.gtk.Demo.gschema.xml \
org.gtk.Settings.ColorChooser.gschema.xml \
org.gtk.Settings.FileChooser.gschema.xml
-MAN1= gtk-query-immodules-3.0.1
-
OPTIONS_DEFINE= CUPS COLORD DEBUG
OPTIONS_DEFAULT=CUPS COLORD
COLORD_DESC= Color profile support
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCUPS}
-LIB_DEPENDS+= cups:${PORTSDIR}/print/cups-client
+LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
CONFIGURE_ARGS+=--enable-cups=auto
PLIST_SUB+= CUPS=""
.else
@@ -67,7 +66,7 @@ CONFIGURE_ARGS+= --enable-debug=yes
.endif
.if ${PORT_OPTIONS:MCOLORD}
-LIB_DEPENDS+= colord:${PORTSDIR}/graphics/colord
+LIB_DEPENDS+= libcolord.so:${PORTSDIR}/graphics/colord
CONFIGURE_ARGS+=--enable-colord
.else
CONFIGURE_ARGS+=--disable-colord
@@ -92,13 +91,16 @@ pre-build:
@${RM} -rf ${WRKSRC}/docs/gtk.info*
post-install:
- -@${FIND} ${LOCALBASE}/share/icons -type d -depth 1 -exec \
- ${PREFIX}/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null
- @${MKDIR} ${PREFIX}/lib/gtk-3.0/modules
- @${MKDIR} ${PREFIX}/lib/gtk-3.0/${GTK3_VERSION}/engines
- @${MKDIR} ${PREFIX}/lib/gtk-3.0/${GTK3_VERSION}/loaders
- ${INSTALL_MAN} ${MAN1:S|^|${WRKSRC}/docs/reference/gtk/|} \
- ${PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/gtk-3.0/modules
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/gtk-3.0/${GTK3_VERSION}/engines
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/gtk-3.0/${GTK3_VERSION}/loaders
+ ${INSTALL_MAN} ${WRKSRC}/docs/reference/gtk/gtk-query-immodules-3.0.1 \
+ ${STAGEDIR}${PREFIX}/man/man1
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgdk-3.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgtk-3.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgailutil-3.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gtk-3.0/3.0.0/immodules/im*.so
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gtk-3.0/3.0.0/printbackends/libprintbackend-*.so
.include <bsd.port.mk>