aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/gtk30
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /x11-toolkits/gtk30
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Notes
Notes: svn path=/head/; revision=372768
Diffstat (limited to 'x11-toolkits/gtk30')
-rw-r--r--x11-toolkits/gtk30/Makefile60
-rw-r--r--x11-toolkits/gtk30/distinfo4
-rw-r--r--x11-toolkits/gtk30/files/patch-Makefile.in10
-rw-r--r--x11-toolkits/gtk30/files/patch-docs_reference_gtk_Makefile.in10
-rw-r--r--x11-toolkits/gtk30/pkg-plist195
5 files changed, 112 insertions, 167 deletions
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 6aafa2c2e28b..db1d03f3c113 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -1,9 +1,10 @@
# Created by: Vanilla I. Shu <vanilla@MinJe.com.TW>
# $FreeBSD$
-# $MCom: ports/trunk/x11-toolkits/gtk30/Makefile 18610 2013-06-30 16:33:05Z marcus $
+# $MCom: ports/trunk/x11-toolkits/gtk30/Makefile 19945 2014-10-15 05:41:04Z gusi $
+# Please keep gtk30 and x11-themes/gnome-themes-standard minor version in sync
PORTNAME= gtk
-PORTVERSION= 3.8.8
+PORTVERSION= 3.14.3
PORTREVISION?= 1
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
@@ -24,9 +25,9 @@ PORTSCOUT= ignore:1
.else
PORTSCOUT= limit:1,even
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/atk-bridge-2.0.pc:${PORTSDIR}/accessibility/at-spi2-atk
-RUN_DEPENDS+= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicolor-icon-theme \
- ${LOCALBASE}/libdata/pkgconfig/atk-bridge-2.0.pc:${PORTSDIR}/accessibility/at-spi2-atk
+BUILD_DEPENDS+= at-spi2-atk>=0:${PORTSDIR}/accessibility/at-spi2-atk
+RUN_DEPENDS+= hicolor-icon-theme>=0:${PORTSDIR}/misc/hicolor-icon-theme \
+ at-spi2-atk>=0:${PORTSDIR}/accessibility/at-spi2-atk
USE_PERL5= build
USE_LDCONFIG= yes
@@ -36,45 +37,38 @@ USE_GNOME= atk gdkpixbuf2 gtk-update-icon-cache \
USES+= gettext gmake libtool pathfix perl5 pkgconfig
USE_XORG= xext xrender x11 xinerama xi xrandr xcursor xfixes xdamage \
xcomposite
-CONFIGURE_ARGS= --enable-gtk2-dependency --disable-packagekit
+CONFIGURE_ARGS= --enable-gtk2-dependency --disable-packagekit \
+ --enable-introspection
CPPFLAGS+= -I${LOCALBASE}/include -fno-omit-frame-pointer
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= INTROSPECTION_GIRDIR=`pkg-config --variable=girdir gobject-introspection-1.0`
+LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-LIBVERSION= 0.800.8
+LIBVERSION= 0.1400.3
PLIST_SUB+= LIBVERSION=${LIBVERSION}
GLIB_SCHEMAS= org.gtk.Demo.gschema.xml \
org.gtk.Settings.ColorChooser.gschema.xml \
- org.gtk.Settings.FileChooser.gschema.xml
+ org.gtk.Settings.Debug.gschema.xml \
+ org.gtk.Settings.FileChooser.gschema.xml \
+ org.gtk.exampleapp.gschema.xml
-OPTIONS_DEFINE= CUPS COLORD DEBUG
+OPTIONS_DEFINE= CUPS CLOUDPRINT COLORD DEBUG
OPTIONS_DEFAULT=CUPS COLORD
+OPTIONS_SUB= yes
COLORD_DESC= Color profile support
-
+COLORD_LIB_DEPENDS= libcolord.so:${PORTSDIR}/graphics/colord
+COLORD_CONFIGURE_ENABLE=colord
+CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
+CUPS_CONFIGURE_ENABLE= cups
+CLOUDPRINT_DESC= Cloud printing support
+CLOUDPRINT_CONFIGURE_ENABLE= cloudprint
+CLOUDPRINT_LIB_DEPENDS= librest-0.7.so:${PORTSDIR}/devel/librest \
+ libjson-glib-1.0.so:${PORTSDIR}/devel/json-glib
+DEBUG_CONFIGURE_ENABLE=debug
+
+# needed for the exists() check, booo
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MCUPS}
-LIB_DEPENDS+= libcups.so:${PORTSDIR}/print/cups-client
-CONFIGURE_ARGS+=--enable-cups=auto
-PLIST_SUB+= CUPS=""
-.else
-CONFIGURE_ARGS+=--disable-cups
-PLIST_SUB+= CUPS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug=yes
-.endif
-
-.if ${PORT_OPTIONS:MCOLORD}
-LIB_DEPENDS+= libcolord.so:${PORTSDIR}/graphics/colord
-CONFIGURE_ARGS+=--enable-colord
-.else
-CONFIGURE_ARGS+=--disable-colord
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${GREP} -l lgmodule | \
${XARGS} ${REINPLACE_CMD} -e 's|-lgmodule|@GMODULE_LIBS@|g'
@@ -83,6 +77,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|@LN_S@|${LN} -sf|' ${WRKSRC}/gtk/Makefile.in
@${REINPLACE_CMD} -e 's|file,cups|file,cups,lpr|' \
${WRKSRC}/gtk/Makefile.in
+ @${REINPLACE_CMD} -e 's|-DG_DISABLE_CHECKS||' \
+ ${WRKSRC}/configure
pre-configure:
.if !exists(${LOCALBASE}/libdata/pkgconfig/cairo-xlib.pc)
diff --git a/x11-toolkits/gtk30/distinfo b/x11-toolkits/gtk30/distinfo
index 8062edd58442..41108098aedc 100644
--- a/x11-toolkits/gtk30/distinfo
+++ b/x11-toolkits/gtk30/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/gtk+-3.8.8.tar.xz) = d9299ab06e1e3feb19d16fc217de441ded0280eda433b718d9705024f7de19a6
-SIZE (gnome3/gtk+-3.8.8.tar.xz) = 13851660
+SHA256 (gnome3/gtk+-3.14.3.tar.xz) = 5e8c62b932f4f0384c3c8cbf251f65978bdecde3211bb16e4c2bde5d8b3af72f
+SIZE (gnome3/gtk+-3.14.3.tar.xz) = 15646820
diff --git a/x11-toolkits/gtk30/files/patch-Makefile.in b/x11-toolkits/gtk30/files/patch-Makefile.in
index 610efe8e57b7..0f19135f1df4 100644
--- a/x11-toolkits/gtk30/files/patch-Makefile.in
+++ b/x11-toolkits/gtk30/files/patch-Makefile.in
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2011-09-15 18:04:34.000000000 +0200
-+++ Makefile.in 2011-09-15 18:05:12.000000000 +0200
-@@ -422,7 +422,7 @@
+--- Makefile.in.orig 2014-10-14 15:48:07.903444240 +0200
++++ Makefile.in 2014-10-14 15:49:51.089555876 +0200
+@@ -540,7 +540,7 @@
|| { echo "Gtk+Tests:ERROR: Failed to start Xvfb environment for X11 target tests."; exit 1; } \
&& DISPLAY=:$$XID && export DISPLAY
--SRC_SUBDIRS = gdk gtk libgail-util modules demos tests perf examples
-+SRC_SUBDIRS = gdk gtk libgail-util modules demos perf examples
+-SRC_SUBDIRS = util gdk gtk libgail-util modules demos tests testsuite examples
++SRC_SUBDIRS = util gdk gtk libgail-util modules demos examples
SUBDIRS = po po-properties $(SRC_SUBDIRS) docs m4macros build
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
MAINTAINERCLEANFILES = \
diff --git a/x11-toolkits/gtk30/files/patch-docs_reference_gtk_Makefile.in b/x11-toolkits/gtk30/files/patch-docs_reference_gtk_Makefile.in
index 862035f409f3..83ee0513ad31 100644
--- a/x11-toolkits/gtk30/files/patch-docs_reference_gtk_Makefile.in
+++ b/x11-toolkits/gtk30/files/patch-docs_reference_gtk_Makefile.in
@@ -1,10 +1,10 @@
---- docs/reference/gtk/Makefile.in.orig 2013-03-28 10:39:58.000000000 +0000
-+++ docs/reference/gtk/Makefile.in 2013-03-28 10:43:09.000000000 +0000
-@@ -852,7 +852,6 @@
+--- docs/reference/gtk/Makefile.in.orig 2014-10-14 15:50:07.675435846 +0200
++++ docs/reference/gtk/Makefile.in 2014-10-14 15:50:49.218431589 +0200
+@@ -820,7 +820,6 @@
########################################################################
man_MANS = \
gtk-query-immodules-3.0.1 \
- gtk-update-icon-cache.1 \
+ gtk-encode-symbolic-svg.1 \
gtk-launch.1 \
- broadwayd.1
-
+ gtk3-demo.1 \
diff --git a/x11-toolkits/gtk30/pkg-plist b/x11-toolkits/gtk30/pkg-plist
index 0296c6c3add3..aac9078c29ef 100644
--- a/x11-toolkits/gtk30/pkg-plist
+++ b/x11-toolkits/gtk30/pkg-plist
@@ -1,7 +1,9 @@
+bin/gtk-encode-symbolic-svg
bin/gtk-launch
bin/gtk-query-immodules-3.0
bin/gtk3-demo
bin/gtk3-demo-application
+bin/gtk3-icon-browser
bin/gtk3-widget-factory
etc/gtk-3.0/im-multipress.conf
include/gail-3.0/libgail-util/gail-util.h
@@ -10,7 +12,6 @@ include/gail-3.0/libgail-util/gailtextutil.h
include/gtk-3.0/gdk/gdk.h
include/gtk-3.0/gdk/gdkapplaunchcontext.h
include/gtk-3.0/gdk/gdkcairo.h
-include/gtk-3.0/gdk/gdkcolor.h
include/gtk-3.0/gdk/gdkconfig.h
include/gtk-3.0/gdk/gdkcursor.h
include/gtk-3.0/gdk/gdkdevice.h
@@ -70,6 +71,8 @@ include/gtk-3.0/gtk/a11y/gtkcontaineraccessible.h
include/gtk-3.0/gtk/a11y/gtkcontainercellaccessible.h
include/gtk-3.0/gtk/a11y/gtkentryaccessible.h
include/gtk-3.0/gtk/a11y/gtkexpanderaccessible.h
+include/gtk-3.0/gtk/a11y/gtkflowboxaccessible.h
+include/gtk-3.0/gtk/a11y/gtkflowboxchildaccessible.h
include/gtk-3.0/gtk/a11y/gtkframeaccessible.h
include/gtk-3.0/gtk/a11y/gtkiconviewaccessible.h
include/gtk-3.0/gtk/a11y/gtkimageaccessible.h
@@ -77,13 +80,17 @@ include/gtk-3.0/gtk/a11y/gtkimagecellaccessible.h
include/gtk-3.0/gtk/a11y/gtklabelaccessible.h
include/gtk-3.0/gtk/a11y/gtklevelbaraccessible.h
include/gtk-3.0/gtk/a11y/gtklinkbuttonaccessible.h
+include/gtk-3.0/gtk/a11y/gtklistboxaccessible.h
+include/gtk-3.0/gtk/a11y/gtklistboxrowaccessible.h
include/gtk-3.0/gtk/a11y/gtklockbuttonaccessible.h
include/gtk-3.0/gtk/a11y/gtkmenuaccessible.h
+include/gtk-3.0/gtk/a11y/gtkmenubuttonaccessible.h
include/gtk-3.0/gtk/a11y/gtkmenuitemaccessible.h
include/gtk-3.0/gtk/a11y/gtkmenushellaccessible.h
include/gtk-3.0/gtk/a11y/gtknotebookaccessible.h
include/gtk-3.0/gtk/a11y/gtknotebookpageaccessible.h
include/gtk-3.0/gtk/a11y/gtkpanedaccessible.h
+include/gtk-3.0/gtk/a11y/gtkpopoveraccessible.h
include/gtk-3.0/gtk/a11y/gtkprogressbaraccessible.h
include/gtk-3.0/gtk/a11y/gtkradiobuttonaccessible.h
include/gtk-3.0/gtk/a11y/gtkradiomenuitemaccessible.h
@@ -103,6 +110,12 @@ include/gtk-3.0/gtk/a11y/gtktoplevelaccessible.h
include/gtk-3.0/gtk/a11y/gtktreeviewaccessible.h
include/gtk-3.0/gtk/a11y/gtkwidgetaccessible.h
include/gtk-3.0/gtk/a11y/gtkwindowaccessible.h
+include/gtk-3.0/gdk/deprecated/gdkcolor.h
+include/gtk-3.0/gtk/deprecated/gtkaction.h
+include/gtk-3.0/gtk/deprecated/gtkactiongroup.h
+include/gtk-3.0/gtk/deprecated/gtkactivatable.h
+include/gtk-3.0/gtk/deprecated/gtkalignment.h
+include/gtk-3.0/gtk/deprecated/gtkarrow.h
include/gtk-3.0/gtk/deprecated/gtkcolorsel.h
include/gtk-3.0/gtk/deprecated/gtkcolorseldialog.h
include/gtk-3.0/gtk/deprecated/gtkfontsel.h
@@ -115,11 +128,22 @@ include/gtk-3.0/gtk/deprecated/gtkhscale.h
include/gtk-3.0/gtk/deprecated/gtkhscrollbar.h
include/gtk-3.0/gtk/deprecated/gtkhseparator.h
include/gtk-3.0/gtk/deprecated/gtkhsv.h
+include/gtk-3.0/gtk/deprecated/gtkiconfactory.h
+include/gtk-3.0/gtk/deprecated/gtkimagemenuitem.h
+include/gtk-3.0/gtk/deprecated/gtkmisc.h
+include/gtk-3.0/gtk/deprecated/gtknumerableicon.h
+include/gtk-3.0/gtk/deprecated/gtkradioaction.h
include/gtk-3.0/gtk/deprecated/gtkrc.h
+include/gtk-3.0/gtk/deprecated/gtkrecentaction.h
+include/gtk-3.0/gtk/deprecated/gtkstock.h
include/gtk-3.0/gtk/deprecated/gtkstyle.h
+include/gtk-3.0/gtk/deprecated/gtkstatusicon.h
include/gtk-3.0/gtk/deprecated/gtksymboliccolor.h
include/gtk-3.0/gtk/deprecated/gtktable.h
include/gtk-3.0/gtk/deprecated/gtktearoffmenuitem.h
+include/gtk-3.0/gtk/deprecated/gtkthemingengine.h
+include/gtk-3.0/gtk/deprecated/gtktoggleaction.h
+include/gtk-3.0/gtk/deprecated/gtkuimanager.h
include/gtk-3.0/gtk/deprecated/gtkvbbox.h
include/gtk-3.0/gtk/deprecated/gtkvbox.h
include/gtk-3.0/gtk/deprecated/gtkvpaned.h
@@ -133,19 +157,15 @@ include/gtk-3.0/gtk/gtkaccelgroup.h
include/gtk-3.0/gtk/gtkaccellabel.h
include/gtk-3.0/gtk/gtkaccelmap.h
include/gtk-3.0/gtk/gtkaccessible.h
-include/gtk-3.0/gtk/gtkaction.h
include/gtk-3.0/gtk/gtkactionable.h
-include/gtk-3.0/gtk/gtkactiongroup.h
-include/gtk-3.0/gtk/gtkactivatable.h
+include/gtk-3.0/gtk/gtkactionbar.h
include/gtk-3.0/gtk/gtkadjustment.h
-include/gtk-3.0/gtk/gtkalignment.h
include/gtk-3.0/gtk/gtkappchooser.h
include/gtk-3.0/gtk/gtkappchooserbutton.h
include/gtk-3.0/gtk/gtkappchooserdialog.h
include/gtk-3.0/gtk/gtkappchooserwidget.h
include/gtk-3.0/gtk/gtkapplication.h
include/gtk-3.0/gtk/gtkapplicationwindow.h
-include/gtk-3.0/gtk/gtkarrow.h
include/gtk-3.0/gtk/gtkaspectframe.h
include/gtk-3.0/gtk/gtkassistant.h
include/gtk-3.0/gtk/gtkbbox.h
@@ -195,6 +215,7 @@ include/gtk-3.0/gtk/gtkentrybuffer.h
include/gtk-3.0/gtk/gtkentrycompletion.h
include/gtk-3.0/gtk/gtkenums.h
include/gtk-3.0/gtk/gtkeventbox.h
+include/gtk-3.0/gtk/gtkeventcontroller.h
include/gtk-3.0/gtk/gtkexpander.h
include/gtk-3.0/gtk/gtkfilechooser.h
include/gtk-3.0/gtk/gtkfilechooserbutton.h
@@ -202,17 +223,26 @@ include/gtk-3.0/gtk/gtkfilechooserdialog.h
include/gtk-3.0/gtk/gtkfilechooserwidget.h
include/gtk-3.0/gtk/gtkfilefilter.h
include/gtk-3.0/gtk/gtkfixed.h
+include/gtk-3.0/gtk/gtkflowbox.h
include/gtk-3.0/gtk/gtkfontbutton.h
include/gtk-3.0/gtk/gtkfontchooser.h
include/gtk-3.0/gtk/gtkfontchooserdialog.h
include/gtk-3.0/gtk/gtkfontchooserwidget.h
include/gtk-3.0/gtk/gtkframe.h
+include/gtk-3.0/gtk/gtkgesture.h
+include/gtk-3.0/gtk/gtkgesturedrag.h
+include/gtk-3.0/gtk/gtkgesturelongpress.h
+include/gtk-3.0/gtk/gtkgesturemultipress.h
+include/gtk-3.0/gtk/gtkgesturepan.h
+include/gtk-3.0/gtk/gtkgesturerotate.h
+include/gtk-3.0/gtk/gtkgesturesingle.h
+include/gtk-3.0/gtk/gtkgestureswipe.h
+include/gtk-3.0/gtk/gtkgesturezoom.h
include/gtk-3.0/gtk/gtkgrid.h
-include/gtk-3.0/gtk/gtkiconfactory.h
+include/gtk-3.0/gtk/gtkheaderbar.h
include/gtk-3.0/gtk/gtkicontheme.h
include/gtk-3.0/gtk/gtkiconview.h
include/gtk-3.0/gtk/gtkimage.h
-include/gtk-3.0/gtk/gtkimagemenuitem.h
include/gtk-3.0/gtk/gtkimcontext.h
include/gtk-3.0/gtk/gtkimcontextinfo.h
include/gtk-3.0/gtk/gtkimcontextsimple.h
@@ -224,6 +254,7 @@ include/gtk-3.0/gtk/gtklabel.h
include/gtk-3.0/gtk/gtklayout.h
include/gtk-3.0/gtk/gtklevelbar.h
include/gtk-3.0/gtk/gtklinkbutton.h
+include/gtk-3.0/gtk/gtklistbox.h
include/gtk-3.0/gtk/gtkliststore.h
include/gtk-3.0/gtk/gtklockbutton.h
include/gtk-3.0/gtk/gtkmain.h
@@ -234,40 +265,40 @@ include/gtk-3.0/gtk/gtkmenuitem.h
include/gtk-3.0/gtk/gtkmenushell.h
include/gtk-3.0/gtk/gtkmenutoolbutton.h
include/gtk-3.0/gtk/gtkmessagedialog.h
-include/gtk-3.0/gtk/gtkmisc.h
include/gtk-3.0/gtk/gtkmodules.h
include/gtk-3.0/gtk/gtkmountoperation.h
include/gtk-3.0/gtk/gtknotebook.h
-include/gtk-3.0/gtk/gtknumerableicon.h
include/gtk-3.0/gtk/gtkoffscreenwindow.h
include/gtk-3.0/gtk/gtkorientable.h
include/gtk-3.0/gtk/gtkoverlay.h
include/gtk-3.0/gtk/gtkpagesetup.h
include/gtk-3.0/gtk/gtkpaned.h
include/gtk-3.0/gtk/gtkpapersize.h
+include/gtk-3.0/gtk/gtkplacessidebar.h
include/gtk-3.0/gtk/gtkplug.h
+include/gtk-3.0/gtk/gtkpopover.h
include/gtk-3.0/gtk/gtkprintcontext.h
include/gtk-3.0/gtk/gtkprintoperation.h
include/gtk-3.0/gtk/gtkprintoperationpreview.h
include/gtk-3.0/gtk/gtkprintsettings.h
include/gtk-3.0/gtk/gtkprogressbar.h
-include/gtk-3.0/gtk/gtkradioaction.h
include/gtk-3.0/gtk/gtkradiobutton.h
include/gtk-3.0/gtk/gtkradiomenuitem.h
include/gtk-3.0/gtk/gtkradiotoolbutton.h
include/gtk-3.0/gtk/gtkrange.h
-include/gtk-3.0/gtk/gtkrecentaction.h
include/gtk-3.0/gtk/gtkrecentchooser.h
include/gtk-3.0/gtk/gtkrecentchooserdialog.h
include/gtk-3.0/gtk/gtkrecentchoosermenu.h
include/gtk-3.0/gtk/gtkrecentchooserwidget.h
include/gtk-3.0/gtk/gtkrecentfilter.h
include/gtk-3.0/gtk/gtkrecentmanager.h
+include/gtk-3.0/gtk/gtkrevealer.h
include/gtk-3.0/gtk/gtkscale.h
include/gtk-3.0/gtk/gtkscalebutton.h
include/gtk-3.0/gtk/gtkscrollable.h
include/gtk-3.0/gtk/gtkscrollbar.h
include/gtk-3.0/gtk/gtkscrolledwindow.h
+include/gtk-3.0/gtk/gtksearchbar.h
include/gtk-3.0/gtk/gtksearchentry.h
include/gtk-3.0/gtk/gtkselection.h
include/gtk-3.0/gtk/gtkseparator.h
@@ -281,8 +312,8 @@ include/gtk-3.0/gtk/gtksocket.h
include/gtk-3.0/gtk/gtkspinbutton.h
include/gtk-3.0/gtk/gtkspinner.h
include/gtk-3.0/gtk/gtkstatusbar.h
-include/gtk-3.0/gtk/gtkstatusicon.h
-include/gtk-3.0/gtk/gtkstock.h
+include/gtk-3.0/gtk/gtkstack.h
+include/gtk-3.0/gtk/gtkstackswitcher.h
include/gtk-3.0/gtk/gtkstylecontext.h
include/gtk-3.0/gtk/gtkstyleproperties.h
include/gtk-3.0/gtk/gtkstyleprovider.h
@@ -299,8 +330,6 @@ include/gtk-3.0/gtk/gtktextmark.h
include/gtk-3.0/gtk/gtktexttag.h
include/gtk-3.0/gtk/gtktexttagtable.h
include/gtk-3.0/gtk/gtktextview.h
-include/gtk-3.0/gtk/gtkthemingengine.h
-include/gtk-3.0/gtk/gtktoggleaction.h
include/gtk-3.0/gtk/gtktogglebutton.h
include/gtk-3.0/gtk/gtktoggletoolbutton.h
include/gtk-3.0/gtk/gtktoolbar.h
@@ -321,13 +350,13 @@ include/gtk-3.0/gtk/gtktreeview.h
include/gtk-3.0/gtk/gtktreeviewcolumn.h
include/gtk-3.0/gtk/gtktypebuiltins.h
include/gtk-3.0/gtk/gtktypes.h
-include/gtk-3.0/gtk/gtkuimanager.h
include/gtk-3.0/gtk/gtkversion.h
include/gtk-3.0/gtk/gtkviewport.h
include/gtk-3.0/gtk/gtkvolumebutton.h
include/gtk-3.0/gtk/gtkwidget.h
include/gtk-3.0/gtk/gtkwidgetpath.h
include/gtk-3.0/gtk/gtkwindow.h
+include/gtk-3.0/gtk/gtkwindowgroup.h
include/gtk-3.0/gtk/gtkx.h
include/gtk-3.0/unix-print/gtk/gtkpagesetupunixdialog.h
include/gtk-3.0/unix-print/gtk/gtkprinter.h
@@ -348,6 +377,7 @@ lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-ti-er.so
lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-ti-et.so
lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-viqr.so
lib/gtk-3.0/%%GTK3_VERSION%%/immodules/im-xim.so
+%%CLOUDPRINT%%lib/gtk-3.0/%%GTK3_VERSION%%/printbackends/libprintbackend-cloudprint.so
%%CUPS%%lib/gtk-3.0/%%GTK3_VERSION%%/printbackends/libprintbackend-cups.so
lib/gtk-3.0/%%GTK3_VERSION%%/printbackends/libprintbackend-file.so
lib/gtk-3.0/%%GTK3_VERSION%%/printbackends/libprintbackend-lpr.so
@@ -368,10 +398,25 @@ libdata/pkgconfig/gtk+-unix-print-3.0.pc
libdata/pkgconfig/gtk+-x11-3.0.pc
man/man1/gtk-query-immodules-3.0.1.gz
share/aclocal/gtk-3.0.m4
+share/applications/gtk3-demo.desktop
+share/applications/gtk3-icon-browser.desktop
+share/applications/gtk3-widget-factory.desktop
share/gir-1.0/Gdk-3.0.gir
share/gir-1.0/GdkX11-3.0.gir
share/gir-1.0/Gtk-3.0.gir
share/gtk-3.0/gtkbuilder.rng
+share/icons/hicolor/16x16/apps/gtk3-demo.png
+share/icons/hicolor/16x16/apps/gtk3-widget-factory.png
+share/icons/hicolor/22x22/apps/gtk3-demo.png
+share/icons/hicolor/22x22/apps/gtk3-widget-factory.png
+share/icons/hicolor/24x24/apps/gtk3-demo.png
+share/icons/hicolor/24x24/apps/gtk3-widget-factory.png
+share/icons/hicolor/256x256/apps/gtk3-demo.png
+share/icons/hicolor/256x256/apps/gtk3-widget-factory.png
+share/icons/hicolor/32x32/apps/gtk3-demo.png
+share/icons/hicolor/32x32/apps/gtk3-widget-factory.png
+share/icons/hicolor/48x48/apps/gtk3-demo.png
+share/icons/hicolor/48x48/apps/gtk3-widget-factory.png
share/locale/af/LC_MESSAGES/gtk30-properties.mo
share/locale/af/LC_MESSAGES/gtk30.mo
share/locale/am/LC_MESSAGES/gtk30-properties.mo
@@ -566,6 +611,8 @@ share/locale/ta/LC_MESSAGES/gtk30-properties.mo
share/locale/ta/LC_MESSAGES/gtk30.mo
share/locale/te/LC_MESSAGES/gtk30-properties.mo
share/locale/te/LC_MESSAGES/gtk30.mo
+share/locale/tg/LC_MESSAGES/gtk30-properties.mo
+share/locale/tg/LC_MESSAGES/gtk30.mo
share/locale/th/LC_MESSAGES/gtk30-properties.mo
share/locale/th/LC_MESSAGES/gtk30.mo
share/locale/tk/LC_MESSAGES/gtk30-properties.mo
@@ -602,111 +649,13 @@ share/themes/Default/gtk-3.0/gtk-keys.css
share/themes/Emacs/gtk-3.0/gtk-keys.css
@exec /usr/bin/find %%LOCALBASE%%/share/icons -type d -depth 1 -exec %D/bin/gtk-update-icon-cache -q -f {} \; 2>/dev/null || /usr/bin/true
@unexec /usr/bin/find %%LOCALBASE%%/share/icons -type f -depth 2 -name icon-theme.cache -delete 2>/dev/null || /usr/bin/true
-@dirrm share/themes/Emacs/gtk-3.0
-@dirrmtry share/themes/Emacs
-@dirrm share/themes/Default/gtk-3.0
-@dirrmtry share/themes/Default
-@dirrmtry share/themes
-@dirrmtry share/locale/zh_HK/LC_MESSAGES
-@dirrmtry share/locale/zh_HK
-@dirrmtry share/locale/yi/LC_MESSAGES
-@dirrmtry share/locale/yi
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/uz@cyrillic/LC_MESSAGES
-@dirrmtry share/locale/uz@cyrillic
-@dirrmtry share/locale/ur/LC_MESSAGES
-@dirrmtry share/locale/ur
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/tt/LC_MESSAGES
-@dirrmtry share/locale/tt
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/sr@ije/LC_MESSAGES
-@dirrmtry share/locale/sr@ije
-@dirrmtry share/locale/si/LC_MESSAGES
-@dirrmtry share/locale/si
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/ps/LC_MESSAGES
-@dirrmtry share/locale/ps
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrmtry share/locale/nso/LC_MESSAGES
-@dirrmtry share/locale/nso
-@dirrmtry share/locale/nds/LC_MESSAGES
-@dirrmtry share/locale/nds
-@dirrmtry share/locale/my/LC_MESSAGES
-@dirrmtry share/locale/my
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/mi/LC_MESSAGES
-@dirrmtry share/locale/mi
-@dirrmtry share/locale/mai/LC_MESSAGES
-@dirrmtry share/locale/mai
-@dirrmtry share/locale/lg/LC_MESSAGES
-@dirrmtry share/locale/lg
-@dirrmtry share/locale/ky/LC_MESSAGES
-@dirrmtry share/locale/ky
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/km/LC_MESSAGES
-@dirrmtry share/locale/km
-@dirrmtry share/locale/kk/LC_MESSAGES
-@dirrmtry share/locale/kk
-@dirrmtry share/locale/kg/LC_MESSAGES
-@dirrmtry share/locale/kg
-@dirrmtry share/locale/io/LC_MESSAGES
-@dirrmtry share/locale/io
-@dirrmtry share/locale/ia/LC_MESSAGES
-@dirrmtry share/locale/ia
-@dirrmtry share/locale/hy/LC_MESSAGES
-@dirrmtry share/locale/hy
-@dirrmtry share/locale/gd/LC_MESSAGES
-@dirrmtry share/locale/gd
-@dirrmtry share/locale/en@shaw/LC_MESSAGES
-@dirrmtry share/locale/en@shaw
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/crh/LC_MESSAGES
-@dirrmtry share/locale/crh
-@dirrmtry share/locale/ca@valencia/LC_MESSAGES
-@dirrmtry share/locale/ca@valencia
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/be@latin/LC_MESSAGES
-@dirrmtry share/locale/be@latin
-@dirrmtry share/locale/az_IR/LC_MESSAGES
-@dirrmtry share/locale/az_IR
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as
-@dirrmtry share/locale/ang/LC_MESSAGES
-@dirrmtry share/locale/ang
-@dirrmtry share/locale/an/LC_MESSAGES
-@dirrmtry share/locale/an
-@dirrm share/gtk-3.0
@exec %D/bin/gtk-query-immodules-3.0 --update-cache > /dev/null 2>&1 || /usr/bin/true
@rmtry lib/gtk-3.0/%%GTK3_VERSION%%/immodules.cache
-@dirrm lib/gtk-3.0/modules
-@dirrm lib/gtk-3.0/%%GTK3_VERSION%%/printbackends
-@dirrm lib/gtk-3.0/%%GTK3_VERSION%%/loaders
-@dirrm lib/gtk-3.0/%%GTK3_VERSION%%/immodules
-@dirrm lib/gtk-3.0/%%GTK3_VERSION%%/engines
-@dirrm lib/gtk-3.0/%%GTK3_VERSION%%
-@dirrm lib/gtk-3.0
-@dirrm include/gtk-3.0/unix-print/gtk
-@dirrm include/gtk-3.0/unix-print
-@dirrm include/gtk-3.0/gtk/deprecated
-@dirrm include/gtk-3.0/gtk/a11y
-@dirrm include/gtk-3.0/gtk
-@dirrm include/gtk-3.0/gdk/x11
-@dirrm include/gtk-3.0/gdk
-@dirrm include/gtk-3.0
-@dirrm include/gail-3.0/libgail-util
-@dirrm include/gail-3.0
-@dirrm etc/gtk-3.0
+@exec /bin/mkdir -p %D/lib/gtk-3.0/modules
+@exec /bin/mkdir -p %D/lib/gtk-3.0/%%GTK3_VERSION%%/engines
+@exec /bin/mkdir -p %D/lib/gtk-3.0/%%GTK3_VERSION%%/loaders
+@dir lib/gtk-3.0
+@dir lib/gtk-3.0/%%GTK3_VERSION%%
+@dir lib/gtk-3.0/%%GTK3_VERSION%%/engines
+@dir lib/gtk-3.0/%%GTK3_VERSION%%/loaders
+@dir lib/gtk-3.0/modules