aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/iwidgets
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2006-05-17 20:35:55 +0000
committerMikhail Teterin <mi@FreeBSD.org>2006-05-17 20:35:55 +0000
commitddb5a7b884735b58415ebdc7736d2bbbb70aa0c7 (patch)
treeb4025948ba0158a02bf41683dc1c945669897f4f /x11-toolkits/iwidgets
parent3b866d3c349efaa7b818dccb50371f64bf9a2bed (diff)
Update the itcl/itk from 3.2 to 3.3 (released in April 2005). The
installed libraries are now named libitcl.so.3 & libitk.so.3 instead of having the version be part of the libname (libitcl33.so.1). The itclConfig.sh and itkConfig.sh are now also installed, which is required by some software (such as the insight -- a gdb frontend). Fix-up the (unchanged) iwidgets port to reflect the above and improve it to not require its own copy of the itcl tree at install time. Approved by: maintainer Fix-up the tkdesk port to reflect the itcl/itk changes, which required updating it to the 2.0p2 (from 2.0). (This lovely piece of software badly needs a caring maintainer, BTW.) While here, teach tkdesk to use installed blt instead of building its own. The only iwidget/itk/itcl consumer that remains broken is net/smm++ (a MUD client). This should change as soon as the maintainer get back to me.
Notes
Notes: svn path=/head/; revision=162683
Diffstat (limited to 'x11-toolkits/iwidgets')
-rw-r--r--x11-toolkits/iwidgets/Makefile13
-rw-r--r--x11-toolkits/iwidgets/files/patch-noitcl12
2 files changed, 22 insertions, 3 deletions
diff --git a/x11-toolkits/iwidgets/Makefile b/x11-toolkits/iwidgets/Makefile
index 0f656170f5fa..f5f188a74031 100644
--- a/x11-toolkits/iwidgets/Makefile
+++ b/x11-toolkits/iwidgets/Makefile
@@ -11,19 +11,18 @@ CATEGORIES= x11-toolkits tk84
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=incrtcl
DISTNAME= iwidgets${PORTVERSION}
-DISTFILES= itcl3.2.1_src.tgz ${PORTNAME}${PORTVERSION}.tar.gz
MAINTAINER= pauls@utdallas.edu
COMMENT= Iwidgets - [incr Widgets]
-LIB_DEPENDS= itk32.1:${PORTSDIR}/x11-toolkits/itk
+LIB_DEPENDS= itk:${PORTSDIR}/x11-toolkits/itk
NO_BUILD= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--with-tcl=${LOCALBASE}/lib/tcl8.4 \
--with-tk=${LOCALBASE}/lib/tk8.4 \
- --with-itcl=${WRKDIR}/itcl3.2.1
+ --with-itcl=${LOCALBASE}/lib/itcl3.3
SUB_LIST= IWIDGETS=${DISTNAME}
SUB_FILES= pkg-message
PLIST_SUB= IWIDGETS=${DISTNAME}
@@ -44,6 +43,14 @@ MANN= iwidgets_buttonbox.n iwidgets_calendar.n iwidgets_canvasprintbox.n iwidget
iwidgets_spintime.n iwidgets_tabnotebook.n iwidgets_tabset.n iwidgets_timeentry.n iwidgets_timefield.n \
iwidgets_toolbar.n iwidgets_watch.n
+post-patch:
+ ${REINPLACE_CMD} -e 's,^MKINSTALLDIRS =.*,MKINSTALLDIRS=${MKDIR},' \
+ -e 's,^INSTALL =.*,INSTALL=${INSTALL} -c,' \
+ -e 's,^INSTALL_PROGRAM =.*,INSTALL_PROGRAM=${INSTALL_PROGRAM},' \
+ -e 's,^INSTALL_DATA =.*,INSTALL_DATA=${INSTALL_DATA},' \
+ -e 's,^INSTALL_SCRIPT =.*,INSTALL_SCRIPT=${INSTALL_SCRIPT},' \
+ -e 's,@ITCL_VERSION@,3.3,g' ${WRKSRC}/Makefile.in
+
post-install:
.if !defined(NOPORTDOCS)
diff --git a/x11-toolkits/iwidgets/files/patch-noitcl b/x11-toolkits/iwidgets/files/patch-noitcl
new file mode 100644
index 000000000000..ae5db7228024
--- /dev/null
+++ b/x11-toolkits/iwidgets/files/patch-noitcl
@@ -0,0 +1,12 @@
+--- configure Thu Nov 29 15:51:34 2001
++++ configure Tue May 16 17:36:14 2006
+@@ -818,9 +818,4 @@
+ fi
+
+-if test -z "$ITCL_LIB_DIR"; then
+- { echo "configure: error: Can't find Itcl source. Use --with-itcl to specify the the toplevel incr Tcl directory on your system. (This directory should contain itcl/library/itcl.tcl, itk/library/itk.tcl, and config/mkinstalldirs.)" 1>&2; exit 1; }
+-fi
+-
+-
+ #--------------------------------------------------------------------
+ # Needed for running the test suite