aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgdiplus
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /x11-toolkits/libgdiplus
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'x11-toolkits/libgdiplus')
-rw-r--r--x11-toolkits/libgdiplus/Makefile6
-rw-r--r--x11-toolkits/libgdiplus/files/patch-pngcodec.c10
2 files changed, 13 insertions, 3 deletions
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index 01c16f14ee52..c3bd6bf0959f 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libgdiplus
PORTVERSION= 2.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
@@ -16,7 +16,7 @@ COMMENT= GDI+ API for System.Windows.Forms in Mono
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
gif.5:${PORTSDIR}/graphics/giflib \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
cairo.2:${PORTSDIR}/graphics/cairo
GNU_CONFIGURE= yes
@@ -25,7 +25,7 @@ USE_GNOME= gnomehack glib20
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_XORG= x11
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= lib/libgdiplus.a \
diff --git a/x11-toolkits/libgdiplus/files/patch-pngcodec.c b/x11-toolkits/libgdiplus/files/patch-pngcodec.c
new file mode 100644
index 000000000000..2c8c9c79119d
--- /dev/null
+++ b/x11-toolkits/libgdiplus/files/patch-pngcodec.c
@@ -0,0 +1,10 @@
+--- src/pngcodec.c.orig 2011-01-13 23:28:19.000000000 +0100
++++ src/pngcodec.c 2012-04-27 12:33:01.000000000 +0200
+@@ -35,6 +35,7 @@
+ #ifdef HAVE_LIBPNG
+
+ #include <png.h>
++#include <pngpriv.h>
+ #include "gdiplus-private.h"
+ #include "pngcodec.h"
+ #include <setjmp.h>