aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libgdiplus
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-24 01:27:03 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-24 01:27:03 +0000
commit9e02a5f3687d8bf95d1d945e63bf05261371dea7 (patch)
tree2ae3e9bdbc270da165da0abc1db90a073d284034 /x11-toolkits/libgdiplus
parent71db4f9e29648793600c8a8a2d54db00e74498ee (diff)
downloadports-9e02a5f3687d8bf95d1d945e63bf05261371dea7.tar.gz
ports-9e02a5f3687d8bf95d1d945e63bf05261371dea7.zip
Properly support png15, remove useless patch
Notes
Notes: svn path=/head/; revision=375380
Diffstat (limited to 'x11-toolkits/libgdiplus')
-rw-r--r--x11-toolkits/libgdiplus/Makefile4
-rw-r--r--x11-toolkits/libgdiplus/files/patch-pngcodec.c10
2 files changed, 2 insertions, 12 deletions
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index 1781e3dd083d..fdef634f1458 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -12,7 +12,7 @@ COMMENT= GDI+ API for System.Windows.Forms in Mono
LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libgif.so:${PORTSDIR}/graphics/giflib \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libcairo.so:${PORTSDIR}/graphics/cairo
GNU_CONFIGURE= yes
@@ -20,7 +20,7 @@ USES= gmake libtool:keepla pathfix pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
USE_XORG= x11
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
diff --git a/x11-toolkits/libgdiplus/files/patch-pngcodec.c b/x11-toolkits/libgdiplus/files/patch-pngcodec.c
deleted file mode 100644
index 2c8c9c79119d..000000000000
--- a/x11-toolkits/libgdiplus/files/patch-pngcodec.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/pngcodec.c.orig 2011-01-13 23:28:19.000000000 +0100
-+++ src/pngcodec.c 2012-04-27 12:33:01.000000000 +0200
-@@ -35,6 +35,7 @@
- #ifdef HAVE_LIBPNG
-
- #include <png.h>
-+#include <pngpriv.h>
- #include "gdiplus-private.h"
- #include "pngcodec.h"
- #include <setjmp.h>