aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libunique3/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-19 13:30:41 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-19 13:30:41 +0000
commit65a2ac97296dd817642f19db184a12496ad958f4 (patch)
treec2258aa59da46d0d34f6830d47d04f2a3d3aac1e /x11-toolkits/libunique3/Makefile
parenteebe4f631a95b6151f791063ddd89470be950018 (diff)
downloadports-65a2ac97296dd817642f19db184a12496ad958f4.tar.gz
ports-65a2ac97296dd817642f19db184a12496ad958f4.zip
Notes
Diffstat (limited to 'x11-toolkits/libunique3/Makefile')
-rw-r--r--x11-toolkits/libunique3/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/libunique3/Makefile b/x11-toolkits/libunique3/Makefile
new file mode 100644
index 000000000000..e5c29675641a
--- /dev/null
+++ b/x11-toolkits/libunique3/Makefile
@@ -0,0 +1,33 @@
+# Created by: Koop Mast <kwm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libunique
+PORTVERSION= 3.0.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= GNOME
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Library for single instance applications
+
+BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+
+LATEST_LINK= libunique3
+USE_XORG= ice x11
+USE_XZ= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
+USE_GNOME= gtk30 gnomeprefix ltverhack:0
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-maintainer-flags --enable-gtk-doc-html=no
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|g' \
+ -e 's|unique tests doc|unique tests|g' \
+ ${WRKSRC}/configure ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>