aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/libwnck/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-06-30 18:50:52 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-06-30 18:50:52 +0000
commit9bc854160974fec3cd1814850d3abfde53e4e662 (patch)
treef418f765057ee9339c43c20c914e66041245d584 /x11-toolkits/libwnck/Makefile
parent4fa3402af340cd0ca84d0e2e90523f9823e4c3ac (diff)
downloadports-9bc854160974fec3cd1814850d3abfde53e4e662.tar.gz
ports-9bc854160974fec3cd1814850d3abfde53e4e662.zip
Notes
Diffstat (limited to 'x11-toolkits/libwnck/Makefile')
-rw-r--r--x11-toolkits/libwnck/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/x11-toolkits/libwnck/Makefile b/x11-toolkits/libwnck/Makefile
index 9413646ad66c..ee27aa922b8e 100644
--- a/x11-toolkits/libwnck/Makefile
+++ b/x11-toolkits/libwnck/Makefile
@@ -1,10 +1,10 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/x11-toolkits/libwnck/Makefile,v 1.133 2010/11/17 11:38:29 kwm Exp $
+# $MCom$
PORTNAME= libwnck
-PORTVERSION= 2.30.6
-PORTREVISION?= 1
+PORTVERSION= 2.30.7
+PORTREVISION?= 0
CATEGORIES= x11-toolkits gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -12,31 +12,27 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Library used for writing pagers and taskslists
-USES= tar:bzip2
+USES= tar:xz
+
+PORTSCOUT= ignore
.if !defined(REFERENCE_PORT)
-USE_XORG= xres
-USES+= bison pathfix gettext gmake pkgconfig
-USE_GNOME= gtk20 ltverhack referencehack intlhack introspection:build,run
+USE_XORG= xres x11
+USE_GNOME= gtk20 referencehack intlhack introspection
+USES+= bison gettext gmake libtool:keepla pathfix pkgconfig
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
OPTIONS_DEFINE= STARTUP
OPTIONS_DEFAULT=STARTUP
STARTUP_DESC= Startup notification support
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSTARTUP}
-LIB_DEPENDS+= startup-notification-1:${PORTSDIR}/x11/startup-notification
-CONFIGURE_ARGS+=--enable-startup-notification
-.else
-CONFIGURE_ARGS+=--disable-startup-notification
-.endif
+STARTUP_LIB_DEPENDS= libstartup-notification-1.so:${PORTSDIR}/x11/startup-notification
+STARTUP_CONFIGURE_ENABLE= startup-notification
.include <bsd.port.mk>