aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/mygui-opengl
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-01-16 17:48:12 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-01-16 17:48:12 +0000
commit24ca34ac96510b368eaf205cad63e4658e9bee88 (patch)
tree82b076300076db8ac99abe932bdde3c03ab73049 /x11-toolkits/mygui-opengl
parent7a351e44a02c8ca721093ce1d3516808ed9cf2bc (diff)
downloadports-24ca34ac96510b368eaf205cad63e4658e9bee88.tar.gz
ports-24ca34ac96510b368eaf205cad63e4658e9bee88.zip
Split render engine modules into separate ports to allow multiple
render modules installed at the same time without introducing unneeded dependencies. PR: 205726
Notes
Notes: svn path=/head/; revision=406252
Diffstat (limited to 'x11-toolkits/mygui-opengl')
-rw-r--r--x11-toolkits/mygui-opengl/Makefile16
-rw-r--r--x11-toolkits/mygui-opengl/pkg-plist8
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-toolkits/mygui-opengl/Makefile b/x11-toolkits/mygui-opengl/Makefile
new file mode 100644
index 000000000000..6a086a6a9a36
--- /dev/null
+++ b/x11-toolkits/mygui-opengl/Makefile
@@ -0,0 +1,16 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -opengl
+
+COMMENT= OpenGL renderer for MyGUI
+
+MASTERDIR= ${.CURDIR}/../mygui
+
+MYGUI_RENDERSYSTEM= 4
+MYGUI_SUBDIR= Platforms/OpenGL/OpenGLPlatform
+
+USE_GL= glu
+
+.include "${MASTERDIR}/Makefile"
diff --git a/x11-toolkits/mygui-opengl/pkg-plist b/x11-toolkits/mygui-opengl/pkg-plist
new file mode 100644
index 000000000000..cb2567b088cb
--- /dev/null
+++ b/x11-toolkits/mygui-opengl/pkg-plist
@@ -0,0 +1,8 @@
+include/MYGUI/MyGUI_OpenGLDataManager.h
+include/MYGUI/MyGUI_OpenGLDiagnostic.h
+include/MYGUI/MyGUI_OpenGLPlatform.h
+include/MYGUI/MyGUI_OpenGLRTTexture.h
+include/MYGUI/MyGUI_OpenGLRenderManager.h
+include/MYGUI/MyGUI_OpenGLTexture.h
+include/MYGUI/MyGUI_OpenGLVertexBuffer.h
+lib/libMyGUI.OpenGLPlatform.a