aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/mygui
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-26 17:27:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-07-26 17:27:42 +0000
commit5c162b8d02e72bdb2426673d969b2a611c08f13d (patch)
treebd85f1ae379801fd0810b4ba8db4998f9860b769 /x11-toolkits/mygui
parent80f0ddf7dc2359e8d122f49f61da682e258f91bd (diff)
downloadports-5c162b8d02e72bdb2426673d969b2a611c08f13d.tar.gz
ports-5c162b8d02e72bdb2426673d969b2a611c08f13d.zip
MyGUI is a library for creating Graphical User Interfaces (GUIs)
for games and 3D applications. The main goals of mygui are: speed, flexibility and ease of use. WWW: http://mygui.info/
Notes
Notes: svn path=/head/; revision=323738
Diffstat (limited to 'x11-toolkits/mygui')
-rw-r--r--x11-toolkits/mygui/Makefile31
-rw-r--r--x11-toolkits/mygui/distinfo2
-rw-r--r--x11-toolkits/mygui/files/patch-Common-FileSystemInfo-FileSystemInfo.h10
-rw-r--r--x11-toolkits/mygui/pkg-descr5
-rw-r--r--x11-toolkits/mygui/pkg-plist187
5 files changed, 235 insertions, 0 deletions
diff --git a/x11-toolkits/mygui/Makefile b/x11-toolkits/mygui/Makefile
new file mode 100644
index 000000000000..5b2c4f010c9c
--- /dev/null
+++ b/x11-toolkits/mygui/Makefile
@@ -0,0 +1,31 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mygui
+PORTVERSION= 3.2.0
+CATEGORIES= x11-toolkits graphics devel
+MASTER_SITES= SF/my-gui/MyGUI/MyGUI_${PORTVERSION}
+DISTNAME= MyGUI_${PORTVERSION}
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Fast, simple and flexible GUI system for Ogre engine
+
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
+BUILD_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
+ ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
+RUN_DEPENDS= ${LOCALBASE}/lib/libOgreMain.so:${PORTSDIR}/graphics/ogre3d \
+ ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois
+
+USE_ZIP= yes
+USES= cmake
+CMAKE_ARGS= -DMYGUI_BUILD_DEMOS=OFF -DMYGUI_BUILD_DOCS=OFF
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+USE_GCC= 4.6+
+USE_DOS2UNIX= *.cpp *.h
+
+post-patch:
+ @${REINPLACE_CMD} -e '/install/ s|lib/pkgconfig|libdata/pkgconfig|' \
+ ${WRKSRC}/CMake/ConfigureBuild.cmake
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/mygui/distinfo b/x11-toolkits/mygui/distinfo
new file mode 100644
index 000000000000..2f3fe18b5ca6
--- /dev/null
+++ b/x11-toolkits/mygui/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MyGUI_3.2.0.zip) = 1704006f364b733b2d2cc6807c6dc10833cf695542b797aee50b8fd061eea19a
+SIZE (MyGUI_3.2.0.zip) = 14383788
diff --git a/x11-toolkits/mygui/files/patch-Common-FileSystemInfo-FileSystemInfo.h b/x11-toolkits/mygui/files/patch-Common-FileSystemInfo-FileSystemInfo.h
new file mode 100644
index 000000000000..ac617bb6883b
--- /dev/null
+++ b/x11-toolkits/mygui/files/patch-Common-FileSystemInfo-FileSystemInfo.h
@@ -0,0 +1,10 @@
+--- Common/FileSystemInfo/FileSystemInfo.h.orig 2012-02-22 22:28:12.000000000 +0400
++++ Common/FileSystemInfo/FileSystemInfo.h 2012-07-16 22:55:36.977549896 +0400
+@@ -14,6 +14,7 @@
+ #else
+ #include <unistd.h>
+ #include <dirent.h>
++#include <sys/syslimits.h>
+ #endif
+
+ #include <string>
diff --git a/x11-toolkits/mygui/pkg-descr b/x11-toolkits/mygui/pkg-descr
new file mode 100644
index 000000000000..9b52b5e3eef2
--- /dev/null
+++ b/x11-toolkits/mygui/pkg-descr
@@ -0,0 +1,5 @@
+MyGUI is a library for creating Graphical User Interfaces (GUIs)
+for games and 3D applications. The main goals of mygui are: speed,
+flexibility and ease of use.
+
+WWW: http://mygui.info/
diff --git a/x11-toolkits/mygui/pkg-plist b/x11-toolkits/mygui/pkg-plist
new file mode 100644
index 000000000000..f80f05317c5e
--- /dev/null
+++ b/x11-toolkits/mygui/pkg-plist
@@ -0,0 +1,187 @@
+include/MYGUI/MyGUI.h
+include/MYGUI/MyGUI_ActionController.h
+include/MYGUI/MyGUI_Align.h
+include/MYGUI/MyGUI_Allocator.h
+include/MYGUI/MyGUI_Any.h
+include/MYGUI/MyGUI_BackwardCompatibility.h
+include/MYGUI/MyGUI_BiIndexBase.h
+include/MYGUI/MyGUI_Bitwise.h
+include/MYGUI/MyGUI_Button.h
+include/MYGUI/MyGUI_Canvas.h
+include/MYGUI/MyGUI_ChildSkinInfo.h
+include/MYGUI/MyGUI_ClipboardManager.h
+include/MYGUI/MyGUI_Colour.h
+include/MYGUI/MyGUI_ComboBox.h
+include/MYGUI/MyGUI_Common.h
+include/MYGUI/MyGUI_CommonStateInfo.h
+include/MYGUI/MyGUI_ConsoleLogListener.h
+include/MYGUI/MyGUI_Constants.h
+include/MYGUI/MyGUI_ControllerEdgeHide.h
+include/MYGUI/MyGUI_ControllerFadeAlpha.h
+include/MYGUI/MyGUI_ControllerItem.h
+include/MYGUI/MyGUI_ControllerManager.h
+include/MYGUI/MyGUI_ControllerPosition.h
+include/MYGUI/MyGUI_CoordConverter.h
+include/MYGUI/MyGUI_CustomAllocator.h
+include/MYGUI/MyGUI_DDContainer.h
+include/MYGUI/MyGUI_DDItemInfo.h
+include/MYGUI/MyGUI_DataFileStream.h
+include/MYGUI/MyGUI_DataManager.h
+include/MYGUI/MyGUI_DataStream.h
+include/MYGUI/MyGUI_Delegate.h
+include/MYGUI/MyGUI_DelegateImplement.h
+include/MYGUI/MyGUI_DeprecatedTypes.h
+include/MYGUI/MyGUI_DeprecatedWidgets.h
+include/MYGUI/MyGUI_Diagnostic.h
+include/MYGUI/MyGUI_DynLib.h
+include/MYGUI/MyGUI_DynLibManager.h
+include/MYGUI/MyGUI_EditBox.h
+include/MYGUI/MyGUI_EditText.h
+include/MYGUI/MyGUI_Enumerator.h
+include/MYGUI/MyGUI_EventPair.h
+include/MYGUI/MyGUI_Exception.h
+include/MYGUI/MyGUI_FactoryManager.h
+include/MYGUI/MyGUI_FileLogListener.h
+include/MYGUI/MyGUI_FlowDirection.h
+include/MYGUI/MyGUI_FontData.h
+include/MYGUI/MyGUI_FontManager.h
+include/MYGUI/MyGUI_GenericFactory.h
+include/MYGUI/MyGUI_GeometryUtility.h
+include/MYGUI/MyGUI_Gui.h
+include/MYGUI/MyGUI_IBItemInfo.h
+include/MYGUI/MyGUI_ICroppedRectangle.h
+include/MYGUI/MyGUI_IDataStream.h
+include/MYGUI/MyGUI_IFont.h
+include/MYGUI/MyGUI_IItem.h
+include/MYGUI/MyGUI_IItemContainer.h
+include/MYGUI/MyGUI_ILayer.h
+include/MYGUI/MyGUI_ILayerItem.h
+include/MYGUI/MyGUI_ILayerNode.h
+include/MYGUI/MyGUI_ILogFilter.h
+include/MYGUI/MyGUI_ILogListener.h
+include/MYGUI/MyGUI_IObject.h
+include/MYGUI/MyGUI_IPointer.h
+include/MYGUI/MyGUI_IRenderTarget.h
+include/MYGUI/MyGUI_IResource.h
+include/MYGUI/MyGUI_ISerializable.h
+include/MYGUI/MyGUI_IStateInfo.h
+include/MYGUI/MyGUI_ISubWidget.h
+include/MYGUI/MyGUI_ISubWidgetRect.h
+include/MYGUI/MyGUI_ISubWidgetText.h
+include/MYGUI/MyGUI_ITexture.h
+include/MYGUI/MyGUI_IUnlinkWidget.h
+include/MYGUI/MyGUI_IVertexBuffer.h
+include/MYGUI/MyGUI_ImageBox.h
+include/MYGUI/MyGUI_ImageInfo.h
+include/MYGUI/MyGUI_InputManager.h
+include/MYGUI/MyGUI_ItemBox.h
+include/MYGUI/MyGUI_KeyCode.h
+include/MYGUI/MyGUI_LanguageManager.h
+include/MYGUI/MyGUI_LastHeader.h
+include/MYGUI/MyGUI_LayerItem.h
+include/MYGUI/MyGUI_LayerManager.h
+include/MYGUI/MyGUI_LayerNode.h
+include/MYGUI/MyGUI_LayoutData.h
+include/MYGUI/MyGUI_LayoutManager.h
+include/MYGUI/MyGUI_LevelLogFilter.h
+include/MYGUI/MyGUI_ListBox.h
+include/MYGUI/MyGUI_LogLevel.h
+include/MYGUI/MyGUI_LogManager.h
+include/MYGUI/MyGUI_LogSource.h
+include/MYGUI/MyGUI_LogStream.h
+include/MYGUI/MyGUI_Macros.h
+include/MYGUI/MyGUI_MainSkin.h
+include/MYGUI/MyGUI_MaskPickInfo.h
+include/MYGUI/MyGUI_MenuBar.h
+include/MYGUI/MyGUI_MenuControl.h
+include/MYGUI/MyGUI_MenuItem.h
+include/MYGUI/MyGUI_MenuItemType.h
+include/MYGUI/MyGUI_MouseButton.h
+include/MYGUI/MyGUI_MultiListBox.h
+include/MYGUI/MyGUI_MultiListItem.h
+include/MYGUI/MyGUI_OgreDataManager.h
+include/MYGUI/MyGUI_OgreDataStream.h
+include/MYGUI/MyGUI_OgreDiagnostic.h
+include/MYGUI/MyGUI_OgrePlatform.h
+include/MYGUI/MyGUI_OgreRTTexture.h
+include/MYGUI/MyGUI_OgreRenderManager.h
+include/MYGUI/MyGUI_OgreTexture.h
+include/MYGUI/MyGUI_OgreVertexBuffer.h
+include/MYGUI/MyGUI_OverlappedLayer.h
+include/MYGUI/MyGUI_Platform.h
+include/MYGUI/MyGUI_Plugin.h
+include/MYGUI/MyGUI_PluginManager.h
+include/MYGUI/MyGUI_PointerManager.h
+include/MYGUI/MyGUI_PolygonalSkin.h
+include/MYGUI/MyGUI_PopupMenu.h
+include/MYGUI/MyGUI_Precompiled.h
+include/MYGUI/MyGUI_Prerequest.h
+include/MYGUI/MyGUI_ProgressBar.h
+include/MYGUI/MyGUI_RTTI.h
+include/MYGUI/MyGUI_RenderFormat.h
+include/MYGUI/MyGUI_RenderItem.h
+include/MYGUI/MyGUI_RenderManager.h
+include/MYGUI/MyGUI_RenderTargetInfo.h
+include/MYGUI/MyGUI_ResizingPolicy.h
+include/MYGUI/MyGUI_ResourceImageSet.h
+include/MYGUI/MyGUI_ResourceImageSetData.h
+include/MYGUI/MyGUI_ResourceImageSetPointer.h
+include/MYGUI/MyGUI_ResourceLayout.h
+include/MYGUI/MyGUI_ResourceManager.h
+include/MYGUI/MyGUI_ResourceManualFont.h
+include/MYGUI/MyGUI_ResourceManualPointer.h
+include/MYGUI/MyGUI_ResourceSkin.h
+include/MYGUI/MyGUI_ResourceTrueTypeFont.h
+include/MYGUI/MyGUI_RotatingSkin.h
+include/MYGUI/MyGUI_ScrollBar.h
+include/MYGUI/MyGUI_ScrollView.h
+include/MYGUI/MyGUI_ScrollViewBase.h
+include/MYGUI/MyGUI_SharedLayer.h
+include/MYGUI/MyGUI_SharedLayerNode.h
+include/MYGUI/MyGUI_SimpleText.h
+include/MYGUI/MyGUI_Singleton.h
+include/MYGUI/MyGUI_SkinItem.h
+include/MYGUI/MyGUI_SkinManager.h
+include/MYGUI/MyGUI_StringUtility.h
+include/MYGUI/MyGUI_SubSkin.h
+include/MYGUI/MyGUI_SubWidgetBinding.h
+include/MYGUI/MyGUI_SubWidgetInfo.h
+include/MYGUI/MyGUI_SubWidgetManager.h
+include/MYGUI/MyGUI_TCoord.h
+include/MYGUI/MyGUI_TPoint.h
+include/MYGUI/MyGUI_TRect.h
+include/MYGUI/MyGUI_TSize.h
+include/MYGUI/MyGUI_TabControl.h
+include/MYGUI/MyGUI_TabItem.h
+include/MYGUI/MyGUI_TextBox.h
+include/MYGUI/MyGUI_TextChangeHistory.h
+include/MYGUI/MyGUI_TextIterator.h
+include/MYGUI/MyGUI_TextView.h
+include/MYGUI/MyGUI_TextViewData.h
+include/MYGUI/MyGUI_TextureUtility.h
+include/MYGUI/MyGUI_TileRect.h
+include/MYGUI/MyGUI_Timer.h
+include/MYGUI/MyGUI_ToolTipManager.h
+include/MYGUI/MyGUI_Types.h
+include/MYGUI/MyGUI_UString.h
+include/MYGUI/MyGUI_Version.h
+include/MYGUI/MyGUI_VertexData.h
+include/MYGUI/MyGUI_Widget.h
+include/MYGUI/MyGUI_WidgetDefines.h
+include/MYGUI/MyGUI_WidgetInput.h
+include/MYGUI/MyGUI_WidgetManager.h
+include/MYGUI/MyGUI_WidgetStyle.h
+include/MYGUI/MyGUI_WidgetToolTip.h
+include/MYGUI/MyGUI_WidgetTranslate.h
+include/MYGUI/MyGUI_WidgetUserData.h
+include/MYGUI/MyGUI_Window.h
+include/MYGUI/MyGUI_XmlDocument.h
+include/MYGUI/Plugin.h
+include/MYGUI/StrangeButton.h
+lib/libMyGUI.OgrePlatform.a
+lib/libMyGUIEngine.so
+lib/libMyGUIEngine.so.3
+lib/libMyGUIEngine.so.3.2.0
+lib/libPlugin_StrangeButton.so
+libdata/pkgconfig/MYGUI.pc
+@dirrm include/MYGUI