aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ocaml-lablgtk2
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2020-11-16 12:34:02 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2020-11-16 12:34:02 +0000
commit87ac7af505ad924da2b4ee0e8d3e330eee9afbc8 (patch)
treeb86d229c05bca4e2e0b1eae845c0d6e10c1c44f2 /x11-toolkits/ocaml-lablgtk2
parent364cf4f8b239b990dd1c3516da7ae80d7e935669 (diff)
downloadports-87ac7af505ad924da2b4ee0e8d3e330eee9afbc8.tar.gz
ports-87ac7af505ad924da2b4ee0e8d3e330eee9afbc8.zip
- Update x11-toolkits/ocaml-lablgtk2 to 2.18.11 [1]
- Update net/unison to 2.51.3 - Add patch to pots of previouss unison versions to work with newer x11-toolkits/ocaml-lablgtk2 [2] Approved by: mandree [2], danfe (via email) [1] Differential Revision: https://reviews.freebsd.org/D26924
Notes
Notes: svn path=/head/; revision=555474
Diffstat (limited to 'x11-toolkits/ocaml-lablgtk2')
-rw-r--r--x11-toolkits/ocaml-lablgtk2/Makefile8
-rw-r--r--x11-toolkits/ocaml-lablgtk2/distinfo6
-rw-r--r--x11-toolkits/ocaml-lablgtk2/files/patch-fno-common22
3 files changed, 8 insertions, 28 deletions
diff --git a/x11-toolkits/ocaml-lablgtk2/Makefile b/x11-toolkits/ocaml-lablgtk2/Makefile
index 601e9b2856b1..73d6f4dbeab2 100644
--- a/x11-toolkits/ocaml-lablgtk2/Makefile
+++ b/x11-toolkits/ocaml-lablgtk2/Makefile
@@ -2,12 +2,10 @@
# $FreeBSD$
PORTNAME= lablgtk2
-PORTVERSION= 2.18.5
+PORTVERSION= 2.18.11
PORTREVISION= 1
CATEGORIES= x11-toolkits
-MASTER_SITES= https://download.ocamlcore.org/lablgtk/Lablgtk2/${PORTVERSION}/
PKGNAMEPREFIX= ocaml-
-DISTNAME= lablgtk-${PORTVERSION}
MAINTAINER= danfe@FreeBSD.org
COMMENT= Objective Caml interface to GTK+ 2.x
@@ -39,6 +37,10 @@ HAS_CONFIGURE= yes
ALL_TARGET= all opt
MAKE_JOBS_UNSAFE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= garrigue
+GH_PROJECT= lablgtk
+
CONFIGURE_ARGS= --prefix=${PREFIX} --with-libdir=${PREFIX}/${OCAML_LIBDIR} \
--without-gtksourceview
CONFIGURE_ENV= CAMLP4O="camlp4 pa_o.cmo pa_op.cmo pr_dump.cmo"
diff --git a/x11-toolkits/ocaml-lablgtk2/distinfo b/x11-toolkits/ocaml-lablgtk2/distinfo
index 4bed6ac93bc5..707fdfe899c2 100644
--- a/x11-toolkits/ocaml-lablgtk2/distinfo
+++ b/x11-toolkits/ocaml-lablgtk2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1559922306
-SHA256 (lablgtk-2.18.5.tar.gz) = 2bf251db21c077fdd26c035ea03edd8fe609187f908e520e87a8ffdd9c36d233
-SIZE (lablgtk-2.18.5.tar.gz) = 808005
+TIMESTAMP = 1603308851
+SHA256 (garrigue-lablgtk-2.18.11_GH0.tar.gz) = ff3c551df4e220b0c0fb9a3da6429413bff14f8fc93f4dd6807a35463982c863
+SIZE (garrigue-lablgtk-2.18.11_GH0.tar.gz) = 1068587
diff --git a/x11-toolkits/ocaml-lablgtk2/files/patch-fno-common b/x11-toolkits/ocaml-lablgtk2/files/patch-fno-common
deleted file mode 100644
index 08749e40f530..000000000000
--- a/x11-toolkits/ocaml-lablgtk2/files/patch-fno-common
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/ml_gdk.c.orig
-+++ src/ml_gdk.c
-@@ -48,6 +48,8 @@
- #include "gdk_tags.h"
-
-
-+lookup_info *ml_table_extension_events;
-+
- CAMLprim void ml_raise_gdk (const char *errmsg)
- {
- static const value * exn = NULL;
---- src/ml_gdk.h.orig
-+++ src/ml_gdk.h
-@@ -86,7 +86,7 @@ CAMLexport value Val_GdkEvent (GdkEvent *);
- CAMLexport int OptFlags_GdkModifier_val (value);
- CAMLexport int Flags_GdkModifier_val (value);
- CAMLexport int Flags_Event_mask_val (value);
--CAMLexport lookup_info *ml_table_extension_events;
-+CAMLextern lookup_info *ml_table_extension_events;
- #define Extension_events_val(key) ml_lookup_to_c(ml_table_extension_events,key)
-
- #define GdkDragContext_val(val) check_cast(GDK_DRAG_CONTEXT,val)