aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ocaml-lablgtk2
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-05 19:01:53 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-08-05 19:01:53 +0000
commit945631eae31e53117e17b7fd80035a73ba4f7e61 (patch)
tree2f17f82f45b976d5f8fc379b83fe93a8194c99cb /x11-toolkits/ocaml-lablgtk2
parent724636363e3c6a31b9603ba8b4cb60ceb60fff32 (diff)
downloadports-945631eae31e53117e17b7fd80035a73ba4f7e61.tar.gz
ports-945631eae31e53117e17b7fd80035a73ba4f7e61.zip
- CFLAGS safety
- Fix permissions (change cp->install in Makefile) - Use new OCaml framework - Pass maintainership to submitter PR: ports/101130 Submitted by: Stanislav Sedov
Notes
Notes: svn path=/head/; revision=169769
Diffstat (limited to 'x11-toolkits/ocaml-lablgtk2')
-rw-r--r--x11-toolkits/ocaml-lablgtk2/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/x11-toolkits/ocaml-lablgtk2/Makefile b/x11-toolkits/ocaml-lablgtk2/Makefile
index dfbfa39aee26..e49c01e399fa 100644
--- a/x11-toolkits/ocaml-lablgtk2/Makefile
+++ b/x11-toolkits/ocaml-lablgtk2/Makefile
@@ -6,7 +6,7 @@
PORTNAME= lablgtk2
PORTVERSION= 2.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.kurims.kyoto-u.ac.jp/pub/lang/olabl/ \
http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/ \
@@ -15,14 +15,12 @@ MASTER_SITES= ftp://ftp.kurims.kyoto-u.ac.jp/pub/lang/olabl/ \
PKGNAMEPREFIX= ocaml-
DISTNAME= lablgtk-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ssedov@mbsd.msk.ru
COMMENT= An Objective Caml interface to GTK+ 2.x
-BUILD_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml
-RUN_DEPENDS+= ocamlc:${PORTSDIR}/lang/ocaml
-
USE_GMAKE= yes
USE_GNOME= gtk20
+USE_OCAML= yes
OPTIONS= GLADE "With glade support" ON \
GNOMECANVAS "With gnomecanvas support" ON \
@@ -40,7 +38,10 @@ ALL_TARGET= all opt
CONFIGURE_ARGS= --prefix=${PREFIX} --with-libdir=${PREFIX}/lib/ocaml
+PATTERN= [[:space:]]*(do|then)?[[:space:]]*)cp([[:space:]]
+
.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
.if (exists(${LOCALBASE}/bin/lablgl) && exists(${X11BASE}/libdata/pkgconfig/gtkgl-2.0.pc)) || defined(WITH_GTKTL)
CONFIGURE_ARGS+= --with-gl
@@ -115,6 +116,14 @@ CONFIGURE_ARGS+= --without-gtkspell
PLIST_SUB+= GTKSPELL="@comment "
.endif
+post-extract:
+ @${REINPLACE_CMD} -E \
+ -e 's,^(CFLAGS[[:space:]]*\+=[[:space:]]*-O),\1 ${CFLAGS},' \
+ -e 's,^(${PATTERN}+.*INSTALLDIR),\1\$${BSD_INSTALL_DATA} \3,' \
+ -e 's,^(${PATTERN}+.*BINDIR),\1\$${BSD_INSTALL_SCRIPT} \3,' \
+ -e 's,^(${PATTERN}+.*LIBDIR),\1\$${BSD_INSTALL_DATA} \3,' \
+ ${WRKSRC}/src/Makefile
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}