aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/otk/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-21 17:47:19 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-21 17:47:19 +0000
commitb3967937cc752f29982fd0fa212c7b2955b8ea2f (patch)
tree9099bd36e7afa2d4108f64e1d98dd558b93a976e /x11-toolkits/otk/Makefile
parent085ebfad27c84f39b1bf9b5eabfba7a9ba42d421 (diff)
downloadports-b3967937cc752f29982fd0fa212c7b2955b8ea2f.tar.gz
ports-b3967937cc752f29982fd0fa212c7b2955b8ea2f.zip
Notes
Diffstat (limited to 'x11-toolkits/otk/Makefile')
-rw-r--r--x11-toolkits/otk/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/otk/Makefile b/x11-toolkits/otk/Makefile
new file mode 100644
index 000000000000..5841545944ba
--- /dev/null
+++ b/x11-toolkits/otk/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: otk
+# Date created: 21 Jan 2006
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= otk
+PORTVERSION= 0.40
+CATEGORIES= x11-toolkits graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_lib_v${PORTVERSION}
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= An OpenGL based GUI widget library
+
+USE_GL= yes
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}_lib
+
+PLIST_FILES= lib/libotk.a include/gadget_lib.h include/otk_lib.h
+
+do-build:
+ cd ${WRKSRC} && \
+ ${CC} ${CFLAGS} -I${X11BASE}/include -c ./otk_lib.c && \
+ ar q ./libotk.a ./otk_lib.o && ranlib ./libotk.a
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libotk.a ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include
+
+.include <bsd.port.mk>