aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/otk
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-07-22 12:16:05 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-07-22 12:16:05 +0000
commitfd77c93082244e547e8d8971768cb476e8019f21 (patch)
treedd5def6c3504d85dd2f09d7ccb933e40b1679de8 /x11-toolkits/otk
parentcdaab81c8deaa4f5df4525586a683801e453b684 (diff)
downloadports-fd77c93082244e547e8d8971768cb476e8019f21.tar.gz
ports-fd77c93082244e547e8d8971768cb476e8019f21.zip
- Update to 0.53 and adopt
Notes
Notes: svn path=/head/; revision=168489
Diffstat (limited to 'x11-toolkits/otk')
-rw-r--r--x11-toolkits/otk/Makefile11
-rw-r--r--x11-toolkits/otk/distinfo6
-rw-r--r--x11-toolkits/otk/files/patch-otk__lib.c24
-rw-r--r--x11-toolkits/otk/files/patch-otk__lib.h10
4 files changed, 10 insertions, 41 deletions
diff --git a/x11-toolkits/otk/Makefile b/x11-toolkits/otk/Makefile
index e19403d162d6..47640b1d05be 100644
--- a/x11-toolkits/otk/Makefile
+++ b/x11-toolkits/otk/Makefile
@@ -6,14 +6,17 @@
#
PORTNAME= otk
-PORTVERSION= 0.45
+PORTVERSION= 0.53
CATEGORIES= x11-toolkits graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}_lib_v${PORTVERSION}
+DISTNAME= ${PORTNAME}_lib_${PORTVERSION}
+EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An OpenGL based GUI widget library
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Widget library based on OpenGL
+
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
USE_GL= yes
USE_X_PREFIX= yes
diff --git a/x11-toolkits/otk/distinfo b/x11-toolkits/otk/distinfo
index 2ff72b1be84f..ce15f86f996d 100644
--- a/x11-toolkits/otk/distinfo
+++ b/x11-toolkits/otk/distinfo
@@ -1,3 +1,3 @@
-MD5 (otk_lib_v0.45.tar.gz) = b38d092e051cac068cb1997af0e13810
-SHA256 (otk_lib_v0.45.tar.gz) = f318fcdfce18f5d3d78148c96683de2d2c6989e28363a4873cc82c41dae4e019
-SIZE (otk_lib_v0.45.tar.gz) = 59434
+MD5 (otk_lib_0.53.tgz) = b63e12cfd908f0662ef3ff233444a35a
+SHA256 (otk_lib_0.53.tgz) = 1e56674eaca26657b8ad12ded6c133f6da9642a7be2880b13bbf8108514f9fda
+SIZE (otk_lib_0.53.tgz) = 65615
diff --git a/x11-toolkits/otk/files/patch-otk__lib.c b/x11-toolkits/otk/files/patch-otk__lib.c
deleted file mode 100644
index 856d7ba5724c..000000000000
--- a/x11-toolkits/otk/files/patch-otk__lib.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- otk_lib.c.orig
-+++ otk_lib.c
-@@ -70,6 +70,7 @@
-
- #if (PLATFORM_KIND==Posix_Platform)
- // #include <unistd.h>
-+ #include <sys/time.h>
- #define GlutEnabled 0 /* Choice: 0=Use X-windows, 1=Use Glut. */
- #define WinGLEnabled 0
- #ifndef SocEnabled
-@@ -111,6 +112,7 @@
- #endif
-
- #include "otk_lib.h"
-+#include "gadget_lib.h"
-
- int Otk_verbose=0;
- int OtkWindowSizeX=-1, OtkWindowSizeY=-1;
-@@ -4517,3 +4519,5 @@
- glutMainLoop();
- #endif
- }
-+
-+#include "gadget_lib.c"
diff --git a/x11-toolkits/otk/files/patch-otk__lib.h b/x11-toolkits/otk/files/patch-otk__lib.h
deleted file mode 100644
index c9dcfb7b25ef..000000000000
--- a/x11-toolkits/otk/files/patch-otk__lib.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- otk_lib.h.orig
-+++ otk_lib.h
-@@ -283,4 +283,7 @@
-
- OtkFont *Otk_Read_SVG_Font( char *filename ); /* FONTS insertion */
-
-+extern struct OtkObjectInstance *OtkRootObject, *OtkOuterWindow,
-+ *Otk_keyboard_focus, *Otk_OpenMenu;
-+
- #endif