aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Alien-wxWidgets/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:09:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-03-15 17:09:14 +0000
commit57b4d85e4f5816f4d7c1f47ed847ba87c8f08f8f (patch)
tree13beb2833fa6aa059af45e2f48dd99df719722fa /x11-toolkits/p5-Alien-wxWidgets/Makefile
parente674016d33adda1ba9e4beb69e8fa943e878926c (diff)
downloadports-57b4d85e4f5816f4d7c1f47ed847ba87c8f08f8f.tar.gz
ports-57b4d85e4f5816f4d7c1f47ed847ba87c8f08f8f.zip
Notes
Diffstat (limited to 'x11-toolkits/p5-Alien-wxWidgets/Makefile')
-rw-r--r--x11-toolkits/p5-Alien-wxWidgets/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-toolkits/p5-Alien-wxWidgets/Makefile b/x11-toolkits/p5-Alien-wxWidgets/Makefile
new file mode 100644
index 000000000000..9052e4365947
--- /dev/null
+++ b/x11-toolkits/p5-Alien-wxWidgets/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: p5-Alien-wxWidgets
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Alien-wxWidgets
+PORTVERSION= 0.42
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Perl5 module for building, finding and using wxWidgets binaries
+
+BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/CBuilder.pm:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
+
+OPTIONS= UNICODE "Build with Unicode support" on
+
+USE_WX= 2.6+
+WX_COMPS= wx contrib
+PERL_MODBUILD= YES
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_UNICODE)
+WX_UNICODE= yes
+WX_UNI= uni_
+CONFIGURE_ARGS+= --build_wx=0 --unicode=1
+.else
+CONFIGURE_ARGS+= --build_wx=0 --unicode=0
+.endif
+
+WX_UVER= ${WX_CONFIG:T} --version | ${TR} '.' '_'
+PLIST_SUB+= WX_UVER="$$(${WX_UVER})" WX_UNI=${WX_UNI}
+
+MAN3= Alien::wxWidgets.3 \
+ Alien::wxWidgets::Utility.3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/wx-config/${WX_CONFIG:T}/' ${WRKSRC}/Build.PL
+ @${REINPLACE_CMD} -e "s/\'wx-config/\'${WX_CONFIG:T}/" -e "s/lc_r/lpthread/" \
+ ${WRKSRC}/inc/My/Build/Any_wx_config.pm
+
+.include <bsd.port.post.mk>