aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/p5-Alien-wxWidgets
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-04-27 18:55:29 +0000
committerJohn Marino <marino@FreeBSD.org>2014-04-27 18:55:29 +0000
commit1a7693cfbf0eb4d19ff917b360991e7e04322d89 (patch)
treef6664b3ac127ea6ed31968bdf78b01df80f07623 /x11-toolkits/p5-Alien-wxWidgets
parent0199dc835a7baf557007da8635301fcb50a8c836 (diff)
downloadports-1a7693cfbf0eb4d19ff917b360991e7e04322d89.tar.gz
ports-1a7693cfbf0eb4d19ff917b360991e7e04322d89.zip
x11-toolkits/p5-Alien-wxWidgets: Unbreak on some platforms
For me, the most cringeworthy makefile technique is the shell command (!=) evaluating another port with "make -C". This is very slow, fragile, and can cause a huge mess if something is out of wack. The technique was used in this port and it didn't even work on all platforms. For sure FreeBSD 8 (according to portsmon) and DragonFly were broken. Essentially the file "gtk2_3_0_0_uni_gcc_3.4.pm" was installed, but the broken plist substitution was looking for "gtk2__uni_gcc_3.4.pm". To fix this robustly, get rid of the whole "make -C" mess and the plist substituion and just use the find command to dynamically add this one file to the plist. Since it starts with a unique pattern, we really don't need to know the Wx version in order to establish the plist with this technique. Approved by: blanket
Notes
Notes: svn path=/head/; revision=352448
Diffstat (limited to 'x11-toolkits/p5-Alien-wxWidgets')
-rw-r--r--x11-toolkits/p5-Alien-wxWidgets/Makefile9
-rw-r--r--x11-toolkits/p5-Alien-wxWidgets/pkg-plist1
2 files changed, 5 insertions, 5 deletions
diff --git a/x11-toolkits/p5-Alien-wxWidgets/Makefile b/x11-toolkits/p5-Alien-wxWidgets/Makefile
index d3c79bcd9f2f..d1a1b4ae8263 100644
--- a/x11-toolkits/p5-Alien-wxWidgets/Makefile
+++ b/x11-toolkits/p5-Alien-wxWidgets/Makefile
@@ -16,15 +16,16 @@ USE_PERL5= modbuild
USE_WX= 3.0
WX_COMPS= wx
WX_UNICODE= yes
-WX_UNI= uni_
CONFIGURE_ARGS+= --wxWidgets-build=0 --wxWidgets-unicode=1
-WX_UVER!= ${MAKE} -C ${.CURDIR}/../../x11-toolkits/wxgtk30 -V'$${PORTVERSION:C/\./_/g}'
-PLIST_SUB+= WX_UVER=${WX_UVER} WX_UNI=${WX_UNI}
-
post-patch:
@${REINPLACE_CMD} -e 's/wx-config/${WX_CONFIG:T}/' ${WRKSRC}/Build.PL
@${REINPLACE_CMD} -e "s/\'wx-config/\'${WX_CONFIG:T}/" -e "s/lc_r/lpthread/" \
${WRKSRC}/inc/My/Build/Any_wx_config.pm
+post-install:
+ # file name is function of wx version, add it dynamically
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} * -type f -name gtk2_\* -print \
+ >> ${TMPPLIST})
+
.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Alien-wxWidgets/pkg-plist b/x11-toolkits/p5-Alien-wxWidgets/pkg-plist
index f51872195ddd..ff3c47547ed0 100644
--- a/x11-toolkits/p5-Alien-wxWidgets/pkg-plist
+++ b/x11-toolkits/p5-Alien-wxWidgets/pkg-plist
@@ -1,7 +1,6 @@
%%PERL5_MAN3%%/Alien::wxWidgets.3.gz
%%PERL5_MAN3%%/Alien::wxWidgets::Utility.3.gz
%%SITE_PERL%%/%%PERL_ARCH%%/Alien/wxWidgets/Utility.pm
-%%SITE_PERL%%/%%PERL_ARCH%%/Alien/wxWidgets/Config/gtk2_%%WX_UVER%%_%%WX_UNI%%gcc_3_4.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Alien/wxWidgets.pm
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Alien/wxWidgets/Config
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Alien/wxWidgets