aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/pure-gtk
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:46:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-27 14:46:18 +0000
commitae90397d31045e2d94ad13561abd3ba3337a336c (patch)
tree0659561acb35382bb9f387f1a72aae1406b40ff5 /x11-toolkits/pure-gtk
parent91263b07cf717ac40e28782a3dac9addd17d353b (diff)
Notes
Diffstat (limited to 'x11-toolkits/pure-gtk')
-rw-r--r--x11-toolkits/pure-gtk/Makefile39
-rw-r--r--x11-toolkits/pure-gtk/distinfo2
-rw-r--r--x11-toolkits/pure-gtk/pkg-descr5
-rw-r--r--x11-toolkits/pure-gtk/pkg-plist10
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-toolkits/pure-gtk/Makefile b/x11-toolkits/pure-gtk/Makefile
new file mode 100644
index 000000000000..cf6e22a09ceb
--- /dev/null
+++ b/x11-toolkits/pure-gtk/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pure-gtk
+# Date created: 2011-03-18
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-gtk
+PORTVERSION= 0.9
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://pure-lang.googlecode.com/files/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A set of Pure language bindings for GTK+
+
+LIB_DEPENDS+= pure.7:${PORTSDIR}/lang/pure \
+ cairo.2:${PORTSDIR}/graphics/cairo
+RUN_DEPENDS+= ${LOCALBASE}/lib/pure/ffi.pure:${PORTSDIR}/devel/pure-ffi
+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_GCC= 4.2+
+USE_GMAKE= yes
+USE_GNOME= glib20 gtk20 atk pango
+
+MAKE_ARGS+= prefix=${PREFIX} CPPFLAGS+=-I${LOCALBASE}/include \
+ LDFLAGS+=-L${LOCALBASE}/lib CFLAGS="${CFLAGS}"
+
+PORTEXAMPLES= *
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/pure-gtk/distinfo b/x11-toolkits/pure-gtk/distinfo
new file mode 100644
index 000000000000..3d978132d6bd
--- /dev/null
+++ b/x11-toolkits/pure-gtk/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure-gtk-0.9.tar.gz) = 1fb826f67ce944119e35cbc13614dd7530e477ef0bc72bb6edc2a682e554007b
+SIZE (pure-gtk-0.9.tar.gz) = 144196
diff --git a/x11-toolkits/pure-gtk/pkg-descr b/x11-toolkits/pure-gtk/pkg-descr
new file mode 100644
index 000000000000..fff29fc72f78
--- /dev/null
+++ b/x11-toolkits/pure-gtk/pkg-descr
@@ -0,0 +1,5 @@
+pure-gtk is a collection of bindings to use the GTK+ GUI toolkit version 2.x
+with Pure. The bindings include the gtk (+gdk), glib, atk, cairo and pango
+libraries, each in their own Pure module.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-gtk.html
diff --git a/x11-toolkits/pure-gtk/pkg-plist b/x11-toolkits/pure-gtk/pkg-plist
new file mode 100644
index 000000000000..62e0f828ba42
--- /dev/null
+++ b/x11-toolkits/pure-gtk/pkg-plist
@@ -0,0 +1,10 @@
+lib/pure/atk.pure
+lib/pure/atk.so
+lib/pure/cairo.pure
+lib/pure/cairo.so
+lib/pure/glib.pure
+lib/pure/glib.so
+lib/pure/gtk.pure
+lib/pure/gtk.so
+lib/pure/pango.pure
+lib/pure/pango.so