aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-easygui
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-05-11 18:54:34 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-05-11 18:54:34 +0000
commita069bc93540b9fe1b03df81ced462fdce216a218 (patch)
tree728e7e507e43167da22f9d5584fa3f17a370702b /x11-toolkits/py-easygui
parent1fa2cddb351fea4c5250828cde33029474a50325 (diff)
downloadports-a069bc93540b9fe1b03df81ced462fdce216a218.tar.gz
ports-a069bc93540b9fe1b03df81ced462fdce216a218.zip
New port: x11-toolkits/py-easygui
EasyGUI is a module for very simple, very easy GUI programming in Python. EasyGUI is different from other GUI generators in that EasyGUI is NOT event-driven. Instead, all GUI interactions are invoked by simple function calls. WWW: https://github.com/robertlugg/easygui
Notes
Notes: svn path=/head/; revision=501289
Diffstat (limited to 'x11-toolkits/py-easygui')
-rw-r--r--x11-toolkits/py-easygui/Makefile22
-rw-r--r--x11-toolkits/py-easygui/distinfo3
-rw-r--r--x11-toolkits/py-easygui/pkg-descr6
3 files changed, 31 insertions, 0 deletions
diff --git a/x11-toolkits/py-easygui/Makefile b/x11-toolkits/py-easygui/Makefile
new file mode 100644
index 000000000000..67b8ed4fb09a
--- /dev/null
+++ b/x11-toolkits/py-easygui/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= easygui
+PORTVERSION= 0.98.1
+CATEGORIES= x11-toolkits python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Easy GUI programming in python
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-easygui/distinfo b/x11-toolkits/py-easygui/distinfo
new file mode 100644
index 000000000000..bc9a6da895a9
--- /dev/null
+++ b/x11-toolkits/py-easygui/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557574991
+SHA256 (easygui-0.98.1.tar.gz) = dbc89afbb1aca83830ea4af568eb2491654e16b2706a14d040757fdf1fafbbfe
+SIZE (easygui-0.98.1.tar.gz) = 81024
diff --git a/x11-toolkits/py-easygui/pkg-descr b/x11-toolkits/py-easygui/pkg-descr
new file mode 100644
index 000000000000..f1b450796556
--- /dev/null
+++ b/x11-toolkits/py-easygui/pkg-descr
@@ -0,0 +1,6 @@
+EasyGUI is a module for very simple, very easy GUI programming in Python.
+EasyGUI is different from other GUI generators in that EasyGUI is NOT
+event-driven. Instead, all GUI interactions are invoked by simple function
+calls.
+
+WWW: https://github.com/robertlugg/easygui