aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-gtk
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-02-22 21:59:16 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-02-22 21:59:16 +0000
commit6a49767d3f433ed9ff8e3bf411489e0f162da0ad (patch)
tree8762c99bbffc195e15f511d282ce3a3ed1706394 /x11-toolkits/py-gtk
parent249faedcf5e10a712a11f8fa75181bbfaf9f7b09 (diff)
downloadports-6a49767d3f433ed9ff8e3bf411489e0f162da0ad.tar.gz
ports-6a49767d3f433ed9ff8e3bf411489e0f162da0ad.zip
Notes
Diffstat (limited to 'x11-toolkits/py-gtk')
-rw-r--r--x11-toolkits/py-gtk/Makefile22
-rw-r--r--x11-toolkits/py-gtk/distinfo2
-rw-r--r--x11-toolkits/py-gtk/pkg-plist106
3 files changed, 68 insertions, 62 deletions
diff --git a/x11-toolkits/py-gtk/Makefile b/x11-toolkits/py-gtk/Makefile
index f8e1c2ffccd7..4c03da1ad3c5 100644
--- a/x11-toolkits/py-gtk/Makefile
+++ b/x11-toolkits/py-gtk/Makefile
@@ -1,13 +1,13 @@
-# New ports collection makefile for: pygtk
-# Version required: 0.5.9
+# New ports collection makefile for: py-gtk
+# Version required: 0.5.10
# Date created: 12/26/1998
# Whom: nectar@FreeBSD.ORG
#
-# $Id: Makefile,v 1.17 1999/01/07 00:29:39 nectar Exp $
+# $Id: Makefile,v 1.18 1999/01/17 17:34:21 nectar Exp $
#
-DISTNAME= pygtk-0.5.9
-PKGNAME= py-gtk-0.5.9
+DISTNAME= pygtk-0.5.10
+PKGNAME= py-gtk-0.5.10
CATEGORIES= x11-toolkits python
MASTER_SITES= ftp://ftp.daa.com.au/pub/james/python/ \
ftp://ftp.gimp.org/pub/gtk/python/ \
@@ -25,13 +25,17 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= GTK_CONFIG=${X11BASE}/bin/gtk11d-config
MAKE_FLAGS= OPT="${CFLAGS}"
+# NOTE: for packaging to work properly, this port should be
+# built with PREFIX set the same as when the python port
+# was built.
+
post-install:
- @${MKDIR} ${PREFIX}/share/examples/pygtk
+ @${MKDIR} ${PREFIX}/share/examples/py-gtk
@(cd ${WRKSRC}/examples; tar cf - *) | \
- (cd ${PREFIX}/share/examples/pygtk; tar xf -)
+ (cd ${PREFIX}/share/examples/py-gtk; tar xf -)
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/pygtk
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/pygtk
+ @${MKDIR} ${PREFIX}/share/doc/py-gtk
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/py-gtk
.endif
.include <bsd.port.mk>
diff --git a/x11-toolkits/py-gtk/distinfo b/x11-toolkits/py-gtk/distinfo
index b86121e607c2..e4cf686580cd 100644
--- a/x11-toolkits/py-gtk/distinfo
+++ b/x11-toolkits/py-gtk/distinfo
@@ -1 +1 @@
-MD5 (pygtk-0.5.9.tar.gz) = ce6057ec2385701e96c4f3ef708f0f2d
+MD5 (pygtk-0.5.10.tar.gz) = 30a6223befbaea85329a5a0e2501eecb
diff --git a/x11-toolkits/py-gtk/pkg-plist b/x11-toolkits/py-gtk/pkg-plist
index c5274bb73f23..71ab2476f33b 100644
--- a/x11-toolkits/py-gtk/pkg-plist
+++ b/x11-toolkits/py-gtk/pkg-plist
@@ -31,55 +31,57 @@ lib/python1.5/site-packages/GTK.pyo
lib/python1.5/site-packages/GDK.pyo
lib/python1.5/site-packages/GtkExtra.pyo
lib/python1.5/site-packages/GdkImlib.pyo
-share/doc/pygtk/README
-@dirrm share/doc/pygtk
-share/examples/pygtk/glade/README
-share/examples/pygtk/glade/test2.glade
-share/examples/pygtk/glade/glade.py
-share/examples/pygtk/glade/test.glade
-@dirrm share/examples/pygtk/glade
-share/examples/pygtk/ide/gtkcons.py
-share/examples/pygtk/ide/gtkdb.py
-share/examples/pygtk/ide/edit.py
-share/examples/pygtk/ide/browse.py
-share/examples/pygtk/ide/minibreak.xpm
-share/examples/pygtk/ide/README
-share/examples/pygtk/ide/gtkprof.py
-share/examples/pygtk/ide/pyide.py
-share/examples/pygtk/ide/break.xpm
-share/examples/pygtk/ide/return.xpm
-share/examples/pygtk/ide/next.xpm
-share/examples/pygtk/ide/continue.xpm
-share/examples/pygtk/ide/step.xpm
-share/examples/pygtk/ide/edit.xpm
-share/examples/pygtk/ide/run.xpm
-share/examples/pygtk/ide/quit.xpm
-@dirrm share/examples/pygtk/ide
-share/examples/pygtk/imlib/view.py
-@dirrm share/examples/pygtk/imlib
-share/examples/pygtk/neil/TAppli.py
-share/examples/pygtk/neil/TAppli2.py
-share/examples/pygtk/neil/TAppli3.py
-share/examples/pygtk/neil/TAppli4.py
-share/examples/pygtk/neil/TAppli5.py
-share/examples/pygtk/neil/bomb.xpm
-share/examples/pygtk/neil/gtk-logo.xpm
-share/examples/pygtk/neil/question.xpm
-share/examples/pygtk/neil/notebook.py
-share/examples/pygtk/neil/README
-@dirrm share/examples/pygtk/neil
-share/examples/pygtk/simple/hello1.py
-share/examples/pygtk/simple/hello2.py
-share/examples/pygtk/simple/simple1.py
-share/examples/pygtk/simple/simple2.py
-share/examples/pygtk/simple/tooltip1.py
-share/examples/pygtk/simple/tooltip2.py
-share/examples/pygtk/simple/scribble.py
-share/examples/pygtk/simple/README
-@dirrm share/examples/pygtk/simple
-share/examples/pygtk/testgtk/testgtk.py
-share/examples/pygtk/testgtk/test.xpm
-share/examples/pygtk/testgtk/testgtkrc
-share/examples/pygtk/testgtk/README
-@dirrm share/examples/pygtk/testgtk
-@dirrm share/examples/pygtk
+share/doc/py-gtk/README
+@dirrm share/doc/py-gtk
+share/examples/py-gtk/glade/README
+share/examples/py-gtk/glade/test2.glade
+share/examples/py-gtk/glade/glade.py
+share/examples/py-gtk/glade/test.glade
+@dirrm share/examples/py-gtk/glade
+share/examples/py-gtk/ide/gtkcons.py
+share/examples/py-gtk/ide/gtkdb.py
+share/examples/py-gtk/ide/edit.py
+share/examples/py-gtk/ide/browse.py
+share/examples/py-gtk/ide/minibreak.xpm
+share/examples/py-gtk/ide/README
+share/examples/py-gtk/ide/gtkprof.py
+share/examples/py-gtk/ide/pyide.py
+share/examples/py-gtk/ide/break.xpm
+share/examples/py-gtk/ide/return.xpm
+share/examples/py-gtk/ide/next.xpm
+share/examples/py-gtk/ide/continue.xpm
+share/examples/py-gtk/ide/step.xpm
+share/examples/py-gtk/ide/edit.xpm
+share/examples/py-gtk/ide/run.xpm
+share/examples/py-gtk/ide/quit.xpm
+@dirrm share/examples/py-gtk/ide
+share/examples/py-gtk/imlib/view.py
+@dirrm share/examples/py-gtk/imlib
+share/examples/py-gtk/neil/TAppli.py
+share/examples/py-gtk/neil/TAppli2.py
+share/examples/py-gtk/neil/TAppli3.py
+share/examples/py-gtk/neil/TAppli4.py
+share/examples/py-gtk/neil/TAppli5.py
+share/examples/py-gtk/neil/bomb.xpm
+share/examples/py-gtk/neil/gtk-logo.xpm
+share/examples/py-gtk/neil/question.xpm
+share/examples/py-gtk/neil/notebook.py
+share/examples/py-gtk/neil/README
+@dirrm share/examples/py-gtk/neil
+share/examples/py-gtk/simple/hello1.py
+share/examples/py-gtk/simple/hello2.py
+share/examples/py-gtk/simple/simple1.py
+share/examples/py-gtk/simple/simple2.py
+share/examples/py-gtk/simple/tooltip1.py
+share/examples/py-gtk/simple/tooltip2.py
+share/examples/py-gtk/simple/scribble.py
+share/examples/py-gtk/simple/dnd.py
+share/examples/py-gtk/simple/dndpixmap.py
+share/examples/py-gtk/simple/README
+@dirrm share/examples/py-gtk/simple
+share/examples/py-gtk/testgtk/testgtk.py
+share/examples/py-gtk/testgtk/test.xpm
+share/examples/py-gtk/testgtk/testgtkrc
+share/examples/py-gtk/testgtk/README
+@dirrm share/examples/py-gtk/testgtk
+@dirrm share/examples/py-gtk