aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-guietta/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-05 06:25:22 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-07-05 06:25:22 +0000
commitb1ab99239ba49e84caadf49cc079582b853e4c53 (patch)
tree5b7135279cc8ab944eb0d29370eb65e08d205901 /x11-toolkits/py-guietta/Makefile
parent11b679d6f95b03b3fd240a6e167945b96bd7ae9c (diff)
downloadports-b1ab99239ba49e84caadf49cc079582b853e4c53.tar.gz
ports-b1ab99239ba49e84caadf49cc079582b853e4c53.zip
Notes
Diffstat (limited to 'x11-toolkits/py-guietta/Makefile')
-rw-r--r--x11-toolkits/py-guietta/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11-toolkits/py-guietta/Makefile b/x11-toolkits/py-guietta/Makefile
new file mode 100644
index 000000000000..0139425582a6
--- /dev/null
+++ b/x11-toolkits/py-guietta/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= guietta
+DISTVERSION= 0.3.3
+CATEGORIES= x11-toolkits python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Simple GUI for Python
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyside2>=0:devel/pyside2@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>