aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/py-kivy
diff options
context:
space:
mode:
authorDavid Naylor <dbn@FreeBSD.org>2014-10-04 08:19:00 +0000
committerDavid Naylor <dbn@FreeBSD.org>2014-10-04 08:19:00 +0000
commitae578fb217b49ac5b3e9cb987161d75499dddbf6 (patch)
treeec009fb8a298499f4f25db3894dbfc66400b5389 /x11-toolkits/py-kivy
parentcef2d1a49a710b214a35c2b1e6f487060d4087f2 (diff)
downloadports-ae578fb217b49ac5b3e9cb987161d75499dddbf6.tar.gz
ports-ae578fb217b49ac5b3e9cb987161d75499dddbf6.zip
Notes
Diffstat (limited to 'x11-toolkits/py-kivy')
-rw-r--r--x11-toolkits/py-kivy/Makefile6
-rw-r--r--x11-toolkits/py-kivy/files/patch-kivy__grahics__shader.pyx22
2 files changed, 24 insertions, 4 deletions
diff --git a/x11-toolkits/py-kivy/Makefile b/x11-toolkits/py-kivy/Makefile
index 300ef912a01e..1a9c2026a2c0 100644
--- a/x11-toolkits/py-kivy/Makefile
+++ b/x11-toolkits/py-kivy/Makefile
@@ -20,14 +20,12 @@ MAKE_JOBS_UNSAFE= yes # does not (really) use make
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}
GH_COMMIT= d602d4b
-USES= shebangfix
+USES= python:2.7+ shebangfix
USE_GL= gl
-USE_PYDISTUTILS= yes
-PYDISTUTILS_AUTOPLIST= yes
PYDISTUTILS_BUILD_TARGET= build_ext
PYDISTUTILS_BUILDARGS= --inplace
PYDISTUTILS_EGGINFO= Kivy-${PORTVERSION}-py${PYTHON_VER}.egg-info
-USE_PYTHON= 2.7+
+USE_PYTHON= autoplist distutils
SHEBANG_FILES= kivy/lib/osc/OSC.py
OPTIONS_DEFINE= DOCS PDF TEST
diff --git a/x11-toolkits/py-kivy/files/patch-kivy__grahics__shader.pyx b/x11-toolkits/py-kivy/files/patch-kivy__grahics__shader.pyx
new file mode 100644
index 000000000000..8b221a5856d4
--- /dev/null
+++ b/x11-toolkits/py-kivy/files/patch-kivy__grahics__shader.pyx
@@ -0,0 +1,22 @@
+diff --git a/kivy/graphics/shader.pyx b/kivy/graphics/shader.pyx
+index eab0f42..39c449a 100644
+--- kivy/graphics/shader.pyx
++++ kivy/graphics/shader.pyx
+@@ -421,6 +421,7 @@ cdef class Shader:
+ cdef void bind_vertex_format(self, VertexFormat vertex_format):
+ cdef unsigned int i
+ cdef vertex_attr_t *attr
++ cdef bytes name
+
+ # if the current vertex format used in the shader is the current one, do
+ # nothing.
+@@ -445,7 +446,8 @@ cdef class Shader:
+ attr = &vertex_format.vattr[i]
+ if attr.per_vertex == 0:
+ continue
+- attr.index = glGetAttribLocation(self.program, <char *><bytes>attr.name)
++ name = <bytes>attr.name
++ attr.index = glGetAttribLocation(self.program, <char *>name)
+ glEnableVertexAttribArray(attr.index)
+
+ # save for the next run.